Head-Fi.org › Forums › Equipment Forums › Portable Headphone Amps › E17 won't turn on
New Posts  All Forums:Forum Nav:

E17 won't turn on - Page 3

post #31 of 36

My 2nd E17 just arrived this morning from Amazon (different seller from 1st E17).

Fortunately, It is not an old batch.  It has the authenticity sticker which I haven't bothered running it thru Fiio's website yet.

I want to make sure the unit charges, holds charge and operates properly first.

 

So far, everything is working.  All input options were tested and verified to be working.  The unit is charging and holding charge nicely.

I will fully charge it tonite and see how many hours it will last.  Volume however seems to be lower than the 1st E17.  This is kind of strange.

On the one I returned, I had gain at +6, volume at 40/60, USB input.  On this new unit, volume got to go up to 50/60 to be comparable.

 

The vendor I bought the 2nd unit from was SMICORP.  Their E17 stock is new.

 

Hope this help E17 owners facing the same problems I've had.

post #32 of 36
Quote:
Originally Posted by koiloco View Post

As a manufacturer, they should communicate with their vendors and fix this old stock issue and at the same time alter their battery design or have the protection circuit kick in a lot sooner to prevent battery from discharge to a risky level.

I contacted one of the UK's official resellers (ea audio) about this. They told me the following:
Quote:
FiiO informed us that some of our E17’s may have been affected. When they released this statement to us we returned the batch to have the batteries replaced so this should no longer be a problem.

It could be that only official resellers (the ones shown on FiiO's website) had their full stocks replaced and that some 'unofficial' resellers still have some of the old faulty stock.
post #33 of 36
Quote:
Originally Posted by lokiboi686 View Post

I purchased a brand new Fiio E17 on amazon about two weeks ago and absolutly loved the sound quality I was getting from this amp. Every couple of days however,even though the battery was completely charged from the usb cable, when i went to turn it on, plugged in or not, the unit would not turn on. I could see a faint red color when plugged in, but not not the bright red color the on button should show, and it just would not power on. After many times of unplugging the unit it would eventually power on out of nowhere. I sent that unit back to amazon for a full refund and purchased another brand new one which came yesterday since i enjoyed the amp so much. Today I cant turn it on again even plugged in and thats how i arrived at this forum. 

 

My question since i love the amp so much should i just bear with the inconsistency, or should i just send it back for a full refund as the problem might only get worse. Also this being my first headphone amp any suggestions on a amp which plugs into my mac desktop as easily as this fiio e17 amp would be great. Preferably an amp under $250. Thanks for any help!

 

 Unfortunately, I found this thread because I have the same problem... I purchased my e17 (brand-new genuine product) last week from an Australian eBay reseller. After 1 week working normally,  this morning I could not turn it on ... and I also see the faint red color light. Now I'm trying to contact with the seller for warranty but after seeing this thread I feel worried about Fiio's product quality :(

post #34 of 36
Quote:
Originally Posted by Chisu View Post
 

 

 Unfortunately, I found this thread because I have the same problem... I purchased my e17 (brand-new genuine product) last week from an Australian eBay reseller. After 1 week working normally,  this morning I could not turn it on ... and I also see the faint red color light. Now I'm trying to contact with the seller for warranty but after seeing this thread I feel worried about Fiio's product quality :(

I bought E17 2 weeks ago, it has been working well. It does not turn on now. I do not know what to do! I bought E17 after reading many reviews. There is a faint light, if I connect to usb port of my laptop :(.

post #35 of 36
That sucks!!!! I ordered my fiio e17 on amazon so I had no problems exchanging mine. However my current e17 is the third one I ordered since the first two gave me the same problem i.e. after two days of usage the light around the on button would be faint and would not turn on. After about an hour or two of unplugging and plugging in the USB and then pressing the on button it would all of a sudden just come back to life. This third unit has not had that problem at all and I have had it since my last post which is a couple of months now. I would have giving up on fiio if not for the amazing sound quality that it gives to my headphones. I ordered two other amps because I had given up when the second unit was damaged, the audio engine d1 and when I wasn't satisfied with that one i ordered an xm 5. Needless to say after being exposed to the fiio e17 I was not satisfied with those other two amps at all and decided to order the fiio e17 one more time. Thankfully the third time was a charm. I know technically that's not what you want to hear but if where you ordered your unit has a good return/replacement policy all I can says is there is hope you will get a good unit. But the choice is yours nonetheless. Good luck to you!!!
post #36 of 36

After posting the previous post, I tried to reset the E17 and it switched on. It did not give any problems since then.

But I contacted Fiio in the meanwhile. They said that my E17 does not belong to faulty batch. I can test the charging time and discharging time of battery, if I want. So I am gonna try this out.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Headphone Amps
Head-Fi.org › Forums › Equipment Forums › Portable Headphone Amps › E17 won't turn on