Head-Fi.org › Forums › Equipment Forums › Headphones (full-size) › My HD 598 sound seems to be slightly distorted. help?
New Posts  All Forums:Forum Nav:

My HD 598 sound seems to be slightly distorted. help?

post #1 of 5
Thread Starter 

Good day everyone, I'm a new member looking for an opinion or possibly and explanation,

I just got my  Sennheiser HD 598 and the sound on them... seems to have a distorted cracking anytime my music is just a tad louder then medium volume, I own a pair of ATH M50's and never experienced this before. I purchased them on amazon for a rather decent price considering what they usually go for. Bought new. 

So does anyone know why it could be distorted? does it need a burn in?

Thanks in advance!

post #2 of 5
Quote:
Originally Posted by m9prime View Post

Good day everyone, I'm a new member looking for an opinion or possibly and explanation,

I just got my  Sennheiser HD 598 and the sound on them... seems to have a distorted cracking anytime my music is just a tad louder then medium volume, I own a pair of ATH M50's and never experienced this before. I purchased them on amazon for a rather decent price considering what they usually go for. Bought new. 

So does anyone know why it could be distorted? does it need a burn in?

Thanks in advance!

 

Heya,

 

What are you plugging them into?
What is your music source? If digital, what bit-rate and container (mp3, flac, etc)?

 

If you're listening to some dumpy youtube rips or some low quality MP3's you're going to hear that all the time.

 

Very best,

post #3 of 5
Thread Starter 
Quote:
Originally Posted by MalVeauX View Post

 

Heya,

 

What are you plugging them into?
What is your music source? If digital, what bit-rate and container (mp3, flac, etc)?

 

If you're listening to some dumpy youtube rips or some low quality MP3's you're going to hear that all the time.

 

Very best,

I have a Small Pyle Splitter amp, It's not the best, But it gets the job done with my ath m50's , I do listen to youtube music, but its nearly the same on my itunes.

what would you recommend for the bit rate and quality settings?

post #4 of 5
Quote:
Originally Posted by m9prime View Post

I have a Small Pyle Splitter amp, It's not the best, But it gets the job done with my ath m50's , I do listen to youtube music, but its nearly the same on my itunes.

what would you recommend for the bit rate and quality settings?

 

Heya,

 

So you're using a Pyle piece of equipment with a highly resolving headphone. There's one problem. You're listening to YouTube music. There's another problem. Nearly and equal are two different things and on a highly resolving headphone, you're going to hear minute differences that will sound awful because of it.

 

Your problem here is source. The Audio quality itself is lacking. And your amp is really not something I'd hook any audio equipment for critical listening to.

 

Just strive for the highest possible audio quality you can get. Otherwise, why get expensive headphones? Lossless is ideal. Listen from the original source if possible. If using digital containers, try higher quality MP3 like 320kbps, and FLAC or iTunes lossless version (though I recommend you ween off iTunes and start using something you have control over). Get used CD's from Amazon and rip them yourself. Get albums from HDTracks.com if you want higher quality stuff in FLAC.

 

And get rid of the Pyle amp, I would get a little Fiio E10 instead.

 

Very best,

post #5 of 5
Thread Starter 
I did some reading... Funny thing... I actually ordered a e10 and your recommendation makes my decision better,

Thanks so much
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Headphones (full-size)
Head-Fi.org › Forums › Equipment Forums › Headphones (full-size) › My HD 598 sound seems to be slightly distorted. help?