Head-Fi.org › Forums › Equipment Forums › Headphones (full-size) › need help with razer chimaera (the non 5.1 version)
New Posts  All Forums:Forum Nav:

need help with razer chimaera (the non 5.1 version)

post #1 of 4
Thread Starter 

hi. a friend of mine gave me these headphones and i've been trying to set them up with my laptop all day. I've managed to figure out the sync thing, i plugged in a 3.5 wire on both ends from the razer stand to my laptop, and i am getting a faint audio from my laptop. 

 

however there is one big issue. there is this constant loud buzzing sound in the headphones when ever i plug in the 3.5 wire, and for the life of me i can't seem to get rid of it. any help would be appreciated. thanks .

post #2 of 4
Thread Starter 

nvm guys, i finally found a way to fix it. thanks!

post #3 of 4

Hi lonewolf! i just bought my own razer, and i'm trying to have it in my laptop. any chance you could guide me in getting this to work in my laptop? thanks in advance!

post #4 of 4

Hi.
I've bought one of this headsets and im with one question.

How can i use it with hdmi at my Xbox?
Can i use a 2.5" to 3.5" cable to conect the wi fi station to the sound
output of the TV(The one that i can connect a phone for example)?
Is there any way of use it without have to play with an ugly graphic using
rca cable?

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Headphones (full-size)
Head-Fi.org › Forums › Equipment Forums › Headphones (full-size) › need help with razer chimaera (the non 5.1 version)