Head-Fi.org › Forums › Equipment Forums › Headphones (full-size) › Just got my DT770 Pros 80Ohm. no sound at all from Right Side?
New Posts  All Forums:Forum Nav:

Just got my DT770 Pros 80Ohm. no sound at all from Right Side?

post #1 of 12
Thread Starter 

Am I missing a connection somewhere? Jack is well connected to PC.

 

Got it direct from amazon UK. Looks like it's a lemon? ): ): ): ):

 

Help appreciated! I'll probably have to return them yeah?

post #2 of 12

try them with another source. if you are using an adapter, make sure it is properly fitted. if the problem remains, then exchange/return them while the warranty is still valid.

post #3 of 12

I just recently purchased the same pair of headphones Beyerdynamic DT 770 Pro 80 ohm from Guitar Center.  They worked perfectly for about 5 minutes of play.  The right side then just stopped working with no sound on that side.  The left side is working well.  I tried connecting to different amps and iPhones with no luck.  I ended up returning them for a replacement pair with no problems from Guitar Center. 

 

As a whole, I am very happy with the headphones overall sound with rock and pop music.  However, I found these headphones demonstrated quite a bit of distortion with certain "bass heavy"/sustained sub bass music when played from higher powered amps.  Try listening to the song "Whisper to Me" by Liquid Mind and you'll see what I mean.  This is probably not a fair criticism since the headphone is rated at 80 ohms.  I do feel it sounds absolutely great from a iPhone or iPod.  Very happy.  I actually prefer them to the Beyerdynamic T50p for rock and pop music.  I'm also going to end up picking up the DT 770 Pro 250 ohm version for my higher end amps to see if that takes care of the distortion.

 

Rich

post #4 of 12
Quote:
Originally Posted by iztis View Post

Am I missing a connection somewhere? Jack is well connected to PC.

Got it direct from amazon UK. Looks like it's a lemon? ): ): ): ):

Help appreciated! I'll probably have to return them yeah?

What are you plugged into? Motherboard directly? Sound Card?

You could be plugged into one of the speaker out's instead of the headphone out if you are plugged into the mobo...
post #5 of 12
Thread Starter 

Tried it out of my laptop headphone jack, desktop soundcard jack, iphone all the same results ):

 

Looks like I got ask for a new pair.

 

I'm frankly very disappointed, I've been waiting eagerly for this pair of headphones and I'm really really surprised to find that such a well reknowned brand like Beyer ships defective products! Where's the quality control?

 

I mean with one sound not ouputing any sound at all...do they even test their products before boxing them?

 

Sorry for the rant, jsut abit peeved and mostly disappointed. Now I gotta wait another week or 2 for the replacement pair from amazon. I really hope it has no problems this time round....

post #6 of 12
Quote:
Originally Posted by iztis View Post

Tried it out of my laptop headphone jack, desktop soundcard jack, iphone all the same results ):

 

Looks like I got ask for a new pair.

 

I'm frankly very disappointed, I've been waiting eagerly for this pair of headphones and I'm really really surprised to find that such a well reknowned brand like Beyer ships defective products! Where's the quality control?

 

I mean with one sound not ouputing any sound at all...do they even test their products before boxing them?

 

Sorry for the rant, jsut abit peeved and mostly disappointed. Now I gotta wait another week or 2 for the replacement pair from amazon. I really hope it has no problems this time round....

 

Heya,

 

I've used over a dozen Beyers, never had an issue. Just like thousands of others. One problem does not mean that all of Beyer, and the concept of quality control, is faulty to the point of disdain. You merely are one in a few thousand who got a defective product. Happens even with flagship $1500 headphones. What makes you think it won't happen with a pair of $150 headphones? Not trying to be a jerk, but seriously, it's going to be ok. And Amazon returns are super easy; they ship before you even send in the defective product. It'll be there in like 2 days too.

 

Very best,

post #7 of 12
This is weird. I got the exact same problem when i received mybfirst dt 770 pro ever yesterday.
I was so excited plugged them in but the right side wouldn't make a sound.
I returned them today....
Now i'm not sure if i should try for another or find a new HP i can get excited about
post #8 of 12
Quote:
Originally Posted by howardroak View Post

This is weird. I got the exact same problem when i received mybfirst dt 770 pro ever yesterday.
I was so excited plugged them in but the right side wouldn't make a sound.
I returned them today....
Now i'm not sure if i should try for another or find a new HP i can get excited about

Try for another. Just get your money back and get a working pair.
post #9 of 12
Thread Starter 
Quote:
Originally Posted by howardroak View Post

This is weird. I got the exact same problem when i received mybfirst dt 770 pro ever yesterday.
I was so excited plugged them in but the right side wouldn't make a sound.
I returned them today....
Now i'm not sure if i should try for another or find a new HP i can get excited about

Where'd you buy them from howardroak?


I got amazon UK to send me a replacement pair, takes about a week plus. I'll let you know how it goes when it arrives. I'm thinking maybe wednesday or thursday.

 

MalVeauX I didn't mean to offend you, but I'm still a student, and from my point of view spending 130pounds on defective hardware really burns. Try to see it from someone else's shoes. I'm not dissing beyerdynamic either, but I do hold them to a much higher standard then say if I were to receive defective hardware from some lesser known company.

 

Peace
 

post #10 of 12
Thread Starter 
Quote:
Originally Posted by howardroak View Post

This is weird. I got the exact same problem when i received mybfirst dt 770 pro ever yesterday.
I was so excited plugged them in but the right side wouldn't make a sound.
I returned them today....
Now i'm not sure if i should try for another or find a new HP i can get excited about

 

Hey! I got my replacement from amazon UK finally. Both sides work perfectly

 

Sound is **** when I heard it through my laptop just for a quick test (muddy as hell)

 

But when I plugged it in to my Xonar Essence ST (headphone amp port)...HOT DAMN. (:

post #11 of 12
Quote:
Originally Posted by iztis View Post

Hey! I got my replacement from amazon UK finally. Both sides work perfectly

Sound is **** when I heard it through my laptop just for a quick test (muddy as hell)

But when I plugged it in to my Xonar Essence ST (headphone amp port)...HOT DAMN. (:

Glad it all worked out for ya. Pick up a Fiio E10 for 50 bucks to use with your laptop and you will be able to use them on both. It will be well worth it for ya.
post #12 of 12
Thread Starter 
Quote:
Originally Posted by Doc-holliday View Post


Glad it all worked out for ya. Pick up a Fiio E10 for 50 bucks to use with your laptop and you will be able to use them on both. It will be well worth it for ya.

Thanks for the tips doc

 

I'll consider the E17 maybe in the future.  I'm broke now :P

 

Will stick with my IE80s or 2.1 speakers for laptop use! 

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Headphones (full-size)
Head-Fi.org › Forums › Equipment Forums › Headphones (full-size) › Just got my DT770 Pros 80Ohm. no sound at all from Right Side?