Head-Fi.org › Forums › Equipment Forums › Portable Headphones, Earphones and In-Ear Monitors › XBA-3/ XBA-30..The Appreciation thread.
New Posts  All Forums:Forum Nav:

XBA-3/ XBA-30..The Appreciation thread. - Page 38

post #556 of 1160

how do you order through Tenso?

post #557 of 1160
Quote:
Originally Posted by aras View Post

how do you order through Tenso?

 

They have a step-by-step guide here.

post #558 of 1160
Quote:
Originally Posted by PeterDLai View Post

Price on XBA-30 has reached a new low if purchased directly from Amazon.jp: ¥ 12,544 (approximately $135 USD). Tenso service/shipping fees usually are about $20.

 

Not currently in stock, but it seems the past few times they've ran out they've had it back in stock much earlier than the 1-2 months they estimate. It's usually in small quantities, however.

You made me pull the trigger man, it is all your fault biggrin.gif

post #559 of 1160
Quote:
Originally Posted by PeterDLai View Post

 

They have a step-by-step guide here.

Thanks!

post #560 of 1160

I have to say I'm really disappointed with the Bass on the XBA3, I was expecting to be blown away after how well my XB41's were. There is hardly any bass at all, even with my Digizoid Z2o amp its rubbish compared to the MDR-XB41, it sounds flat, the XB41's go really really deep and loud. But the sound quality on the XBA 3 is outstanding, the sound stage is great, the treble is much better, but why is the bass so low and flat? 

 

Forgot to mention I'm using this with my NWZ-Z1050, Clear bass on Max.


Edited by zaim - 3/12/13 at 12:30pm
post #561 of 1160
Quote:
Originally Posted by zaim View Post

I have to say I'm really disappointed with the Bass on the XBA3, I was expecting to be blown away after how well my XB41's were. There is hardly any bass at all, even with my Digizoid Z2o amp its rubbish compared to the MDR-XB41, it sounds flat, the XB41's go really really deep and loud. But the sound quality on the XBA 3 is outstanding, the sound stage is great, the treble is much better, but why is the bass so low and flat? 

 

Forgot to mention I'm using this with my NWZ-Z1050, Clear bass on Max.

 

Sounds like the Sony MDR-XB90EX should be more up your alley. Either that or perhaps there's a seal issue going on (but since you say the SQ is outstanding, this is doubtful).

 

In my experience, none of the balanced armature-based IEMs I've tried have done bass as well as a good dynamic driver.


Edited by PeterDLai - 3/12/13 at 12:48pm
post #562 of 1160

Hmm, would you say its worth trying the XBA 4? It does say it has a super woofer in it, should be better ?


Edited by zaim - 3/14/13 at 8:44am
post #563 of 1160
Quote:
Originally Posted by Jakkal View Post

You made me pull the trigger man, it is all your fault biggrin.gif

 

Well, Amazon decided to raise the price back all the way up to ¥ 16,030 so if you don't cancel your order you will have saved at least $30 unless you buy from a third party merchant (which doesn't seem to have the silver in stock either). Either way, sorry for your wallet. redface.gif

post #564 of 1160

Ye I just saw the Amazon price blink.gif. I have ordered it for 12500, but it is still on hold waiting to get in stock. Well i'll have to wait :)

post #565 of 1160

Hi Guys, So I got my XBA-3IPs yesterday as an upgrade from MDR ex300s. Generally the sound is lovely, but I'm finding that the treble is way too bright on certain frequencies, it's almost painful. I'm not sure what the issue is, whether it's just my ears or there's an issue with the tweeter BA (unlikely?). I'm using an iphone 5 for output, so nothing high-end, I've also tried in an ipad and it's the same. Any ideas? Could it just be these IEMs are not suited to my ears?


Edited by MrFujisawa - 3/19/13 at 12:02pm
post #566 of 1160
Quote:
Originally Posted by MrFujisawa View Post

Hi Guys, So I got my XBA-3IPs yesterday. Generally the sound is lovely, but I'm finding that the treble is way too bright on certain frequencies, it's almost painful. I'm not sure what the issue is, whether it's just my ears or there's an issue with the tweeter BA (unlikely?). I'm using an iphone 5 for output, so nothing high-end but I've also tried in an ipad and it's the same. Any ideas? Could it just be these IEMs are not suited to my ears?

yes, the XBA1/2/3/4 have this problem.

They solved it on the upgraded models XBA10/20/30/40.

post #567 of 1160
Quote:
Originally Posted by Seekky View Post

yes, the XBA1/2/3/4 have this problem.

They solved it on the upgraded models XBA10/20/30/40.

ah. thanks! that was nice and simple

post #568 of 1160
Quote:
Originally Posted by MrFujisawa View Post

ah. thanks! that was nice and simple

try to use foam tips. like comply t200

post #569 of 1160
Quote:
Originally Posted by Seekky View Post

try to use foam tips. like comply t200

gonna return them and go for the 30, have just read http://www.head-fi.org/t/608447/sony-xba-series-review-and-comparison-xba-1-2-3-4/45 and it confirms what I am hearing and its really not agreeing with me, rather than try to fix I will return them whilst i can.

post #570 of 1160
Quote:
Originally Posted by MrFujisawa View Post

gonna return them and go for the 30, have just read http://www.head-fi.org/t/608447/sony-xba-series-review-and-comparison-xba-1-2-3-4/45 and it confirms what I am hearing and its really not agreeing with me, rather than try to fix I will return them whilst i can.

that's a good move also.

New Posts  All Forums:Forum Nav:
Head-Fi.org › Forums › Equipment Forums › Portable Headphones, Earphones and In-Ear Monitors › XBA-3/ XBA-30..The Appreciation thread.