Head-Fi.org › Forums › Equipment Forums › Computer Audio › Very small, annoying gap between tracks on Potplayer
New Posts  All Forums:Forum Nav:

Very small, annoying gap between tracks on Potplayer

post #1 of 5
Thread Starter 

I'm not sure how many people use Potplayer here, but it's my main player for music and video, and there's been something bothering me since I switched to it from Kmplayer. Between tracks on a playlist, there is always a very, very small gap, maybe a few milliseconds, between the end of one track and the beginning of another. This generally isn't a problem, but it's definitely audible when the two tracks are linked at the beginning and end.

 

It happens with any kind of file in the playlist, so mp3s and the like. But it also happens to single flac files connected with a cue file. This is a problem with Potplayer, as Kmplayer can play files on a playlist with no gap. Does anyone else have this problem, and is there any way to fix it? I'm using the x64 version if that matters.

post #2 of 5

You want gapless playback. http://en.wikipedia.org/wiki/Gapless_playback

Potplayer supports gapless video playback, but I'm not sure about audio. Might have to resort to another player for that functionality. 

post #3 of 5
Thread Starter 

Oh, I think what's going is "In some cases, software closes and re-opens the output stream when switching tracks, causing the hardware to create a very short "click"" described here. The guy who made Potplayer also made Kmplayer so I thought there was something fixable in the settings.

 

Edit: Just tried it out and Kmplayer doesn't actually have gapless playback. My bad. Is the only option out there Foobar2k? It's nice, but the UI is hard to swallow.


Edited by CBF- - 10/20/12 at 10:35pm
post #4 of 5
foobar2000 is hardly the only option. Many players support gapless these days. Winamp, xmplay, even my lowly favorite 1by1 supports gapless.

I've used potplayer before, and it is not gapless, and I saw no way of telling it to play gaplessly (if that's even a word).
post #5 of 5

Under Preferences, Playback -> Seamless Playback.. It allows you to let the player read files ahead of time to reduce the interval (turned off by default). I am not sure whether this applies to Video or Audio.. but the I haven't heard much of the click every since I turned this setting on.

 

I'm pretty sure you must have known of this, but I'm just throwing this out here :)

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Computer Audio
Head-Fi.org › Forums › Equipment Forums › Computer Audio › Very small, annoying gap between tracks on Potplayer