Head-Fi.org › Forums › Equipment Forums › Portable Headphones, Earphones and In-Ear Monitors › Sorry but I don't like the sound from my Beyer T50p with my iPod classic...
New Posts  All Forums:Forum Nav:

Sorry but I don't like the sound from my Beyer T50p with my iPod classic...

post #1 of 19
Thread Starter 
It just passed about 50 hours mark, the sound is thin and not clear, like a USD50 product.

Should I sell it and go for another set or wait? Or???

Thank you!
post #2 of 19

Could be the ipod classic is not driving them properly.  May need to get a portable amp to get the most out of them.  Also what bitrate is your music encoded at?  That could be a factor as well.

 

Cheers


Edited by davidcotton - 10/8/12 at 11:37am
post #3 of 19
Thread Starter 
I use apple lossless and wave. I prefer not to use a portable amp, well... maybe consider another phone??
post #4 of 19
Thread Starter 
Oh yes, I tested its sweet spot already, it helps a bit.
post #5 of 19
I doubt they're being driven to satisfactory levels. I'd advice to buy an E5 / E6 Fiio amp, give them some more juice.
post #6 of 19

Sometimes it has nothing to do with the source, or what your powering them with, or whether you've burned them in for 20000 hours or not, or whether you've replaced your cable with Cryoed Unobtainium XXX cables.

 

It could just be that the headphones suck.

 

No, this isn't some strange warp of reality. I've heard the T50p too, and I thought they were pretty mediocre. Sometimes people just pile all the blame on everything else, and never seem to stop at the possibility that they just might not like the headphones. Can you describe in more detail what exactly you don't like about them ? (i.e. without using vague terms like "the higher aren't clear" "the bass is bad", not to say you've used that) Maybe we can find something else that you'd like better.

post #7 of 19
Thread Starter 
Well... This will be a bit difficult to me, not enough vocabulary. Let me see, at this price, the resolution is not acceptable. You know that some sound is there, but ypu just cannot hear it. It is lacking the base, the kick durm(?), almost dispeared. I also kinda hear some kid of resonance sound, from the cup(?), its like not enough sound absorbing material in it.
post #8 of 19
Thread Starter 
the kick drum(?) almost disapear.
post #9 of 19
Thread Starter 
dispear
post #10 of 19
Thread Starter 
Sorry my kid is playing with my computer keyboard.
post #11 of 19

If your kid is playing with your keyboard, edit your posts..? I know for one that I'm not a fan of the Beyer T50P. Almost felt like it had no bass at all compared to the DT1350 and Sennheiser HD-25. I thought it was one of Beyers "miss" products, while the DT1350 was a massive hit. I suggest selling your T50P and buying the DT1350, and seeing the used selection, there's plenty to choose from. You will get significantly more bass with the DT1350 and a much better and higher quality sound than the T50P. I doubt it's not the source that's causing the problem... I drive my HD-25s fine with my iPhone and others fine. I found the T50P to sound thin in general. Other better alternatives are the Vmoda M-80, HD-25, and the Beyer DT1350

post #12 of 19
Quote:
Originally Posted by Griffiths View Post

Well... This will be a bit difficult to me, not enough vocabulary. Let me see, at this price, the resolution is not acceptable. You know that some sound is there, but ypu just cannot hear it. It is lacking the base, the kick durm(?), almost dispeared. I also kinda hear some kid of resonance sound, from the cup(?), its like not enough sound absorbing material in it.

Sounds exactly like the T50p like I heard them. The resonance that you hear just completely confirms it. You should probably send them back, and get new DT1350s.

post #13 of 19

I had the same experience, wait until 200 hours and SQUASH THE PADS!!! this makes all the difference. I hated mine at first, now I love them

post #14 of 19

and I compared to HD25s the other day, and the run in T50P is much better in every area.

post #15 of 19
Quote:
Originally Posted by KT66 View Post

I had the same experience, wait until 200 hours and SQUASH THE PADS!!! this makes all the difference. I hated mine at first, now I love them

You might have to expand on that. I did try to press them against my ear when I listened to them because I thought I wasn't getting a seal, and the resonance and anemic sound was still there. I really wish it would have been a seal problem, extremely disappointed with them.

New Posts  All Forums:Forum Nav:
Head-Fi.org › Forums › Equipment Forums › Portable Headphones, Earphones and In-Ear Monitors › Sorry but I don't like the sound from my Beyer T50p with my iPod classic...