Head-Fi.org › Forums › Equipment Forums › Dedicated Source Components › FiiO D3 + SMSL SA-98 Sound Issue.. HELP!
New Posts  All Forums:Forum Nav:

FiiO D3 + SMSL SA-98 Sound Issue.. HELP!

post #1 of 6
Thread Starter 

Hey Guys,

 

First of all i do not know if this is the right place to post this topic.

But nonetheless i'll cut to the chase.

 

Just bought an LG47LM6200 for my TV, MacBook Pro and PS3.

I am using a SMSL SA-98 T-Amp + FiiO D3 out to a pair of Wharfedale Diamonds 10.1

I can get sounds for all except for MBP.

Here is how i connect them all. Please point out where i went wrong.

 

Audio - LG > FiiO D3 via toslink > SA-98 via RCA cables > out to L/R channels to DIA 10.1

Video - PS3 and MBP are connected to LG via HDMI.

 

I have tried tweaking the sound settings for the MBP but does not seems to have any luck.

Thus i need the experts help here.

 

Cheers and God Bless.

post #2 of 6
Thread Starter 

BUMP!

post #3 of 6
Make sure your MBP's optical output doesn't have any special encoding such as Dolby or multi-channel. D3 only take SPDIF in stereo.
post #4 of 6
Thread Starter 
Quote:
Originally Posted by ClieOS View Post

Make sure your MBP's optical output doesn't have any special encoding such as Dolby or multi-channel. D3 only take SPDIF in stereo.

Hi ClieOS,

Thanks for the reply. How do i check that?
I nvr recall installing or setting any codec or endcoding.
Its just out to the TV via HDMI.

Besides this what would be my next best option?
Are there any other DAC that not only supports SPDIF?
In other words how can i get the sound? Heeellp! Haha
post #5 of 6
Sorry, not a Mac user so I don't know the detail.
post #6 of 6
Thread Starter 
Quote:
Originally Posted by ClieOS View Post

Sorry, not a Mac user so I don't know the detail.

ok nvm forget about the mac settings..

do you have any other solution for me and my setup?

Do i need to get another DAC or cables? :)

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Dedicated Source Components
Head-Fi.org › Forums › Equipment Forums › Dedicated Source Components › FiiO D3 + SMSL SA-98 Sound Issue.. HELP!