New Posts  All Forums:Forum Nav:

Whiplash - have they gone missing? - Page 4

post #46 of 181

He's gone missing I suppose? Not replying to my emails at all. Where are you Craig?

Gear mentioned in this thread:

post #47 of 181
Ordered a cable and cc was charged over a week ago...order still shows processing? What's going on?
post #48 of 181

Not responding again and my Paypal payment is past the resolution date. Ugh.

post #49 of 181
Quote:
Originally Posted by xokokx View Post

been 2mths plus even since i send my twag v2 for repair. can u please check ur mail ?

Same here. I think going on 3 months since I sent mine for repair. I got you beat.
post #50 of 181

Soooo has Craig responded at all over the last couple of days?  I was thinking of placing a new order w/ him, but this thread makes me beyond wary.

post #51 of 181
Quote:
Originally Posted by feverfive View Post

Soooo has Craig responded at all over the last couple of days?  I was thinking of placing a new order w/ him, but this thread makes me beyond wary.

Nope.

post #52 of 181
Quote:
Originally Posted by feverfive View Post

Soooo has Craig responded at all over the last couple of days?  I was thinking of placing a new order w/ him, but this thread makes me beyond wary.


Worst customer service I've ever had, opened up a dispute and he didn't even care about it, he's gonna wait til march 4th to give me my money back when paypal demands it.

post #53 of 181
Quote:
Originally Posted by feverfive View Post

Soooo has Craig responded at all over the last couple of days?  I was thinking of placing a new order w/ him, but this thread makes me beyond wary.
Not yet
post #54 of 181

Lets keep this thread going. Are these people still in business?

post #55 of 181
Yes we are....

Sorry for the delays. I will send your request to mike and he will handle it ASAP....

In fact, if you don't get a tracking number by tomorrow, email him at custserv@whiplashaudio.com. He is handling your repair.

Craig
post #56 of 181
Quote:
Originally Posted by SACD-Man View Post

Yes we are....

Sorry for the delays. I will send your request to mike and he will handle it ASAP....

In fact, if you don't get a tracking number by tomorrow, email him at custserv@whiplashaudio.com. He is handling your repair.

Craig

Ok thanks
Edited by Python002 - 2/25/13 at 11:37am
post #57 of 181

Craig,

 

Why would you lie about shipping the cable? Said you shipped it last monday but it's still not here, and after you said that you never provided a tracking number, you never answered the question asking if it was built correctly, and also I already opened a dispute "

Whiplash Audio PP-002-207-392-112 Non-receipt

Claim

-$523.00 USD 2/15/2013 Awaiting other party's response"
post #58 of 181

10 days, still not even a response from the dispute. Interesting.

post #59 of 181

Craig,

 

Could you please check my order as well?

I sent my TWag for repair and ordered TWcu 8 conductor(er4 version)

I sent my TWag and made the payment for the TWcu last December

I had no idea it would take this long

post #60 of 181

I'd rather you tell me upfront if you're having problems with fulfilling orders rather than leading me on for months...

New Posts  All Forums:Forum Nav:

Gear mentioned in this thread: