New Posts  All Forums:Forum Nav:

Whiplash - have they gone missing? - Page 11

post #151 of 181

Hi,  Craig

I waiting for 8 month already. Could you make refund process?

Otherwise I'll contact to PayPal to make a refund process.

Gear mentioned in this thread:

post #152 of 181

I can only speak to my own experience, but I ordered a replacement cable for my FitEar 334 in late August.  Craig was swift in his responses to my queries, kept me updated on the progress, and I received a beautiful cable about a month after ordering.  I am highly satisfied and would not hesitate to order from Whiplash again.

post #153 of 181

Me too. I ordered a Whiplash TWag V3 cable for my MH335DW. I live in HK but Craig was so kind that he had waived the shipping fee for my cable. After one month, my cable arrived and I am quite satisfied with it's quality. I think I will order from Whiplash again if I need other upgrades for my setup.

 

P.S. actually the TWag v3 is already my second order, my first one was the TWag v2 for my ES5 and that was great too.

post #154 of 181
Hi Craig
Please check PM!!!
Thanks
post #155 of 181

Tell me about it. I have a cable owed by them for a year now. I still have the registered shipping form that they received my cable. Never getting anything from them again. 

post #156 of 181
Quote:
Originally Posted by awry View Post
 

Tell me about it. I have a cable owed by them for a year now. I still have the registered shipping form that they received my cable. Never getting anything from them again. 

seriously !?

post #157 of 181
Quote:
Originally Posted by awry View Post
 

Tell me about it. I have a cable owed by them for a year now. I still have the registered shipping form that they received my cable. Never getting anything from them again. 

thats unacceptable. 

post #158 of 181
Quote:
Originally Posted by awry View Post
 

Tell me about it. I have a cable owed by them for a year now. I still have the registered shipping form that they received my cable. Never getting anything from them again. 

 

keep sending craig emails. i definitely believe he will reply

post #159 of 181
Quote:
Originally Posted by chesterljh View Post
 

 

keep sending craig emails. i definitely believe he will reply

a YEAR,12 months,365 days,24 Hours a day,60 Minutes a hour, 60 seconds a minute

 

that is CLEARLY dropping the ball by all standards. thats too long to owe someone something.

 

even if he eventually answers, there is no excuse to prolong such a event like sending out a cable.

 

these cables arent made with unicorn mane stranded wires. come on.

 

just saying...

post #160 of 181

And I was told to send the cable up. think I have the email somewhere. It's to replace a TWag V1 with a V2? Something like that. I dunno. I have emailed plenty of times.

post #161 of 181

Am i the only one that has these problems? i heard they were quite common. Not like anyone else in Whiplash is doing anytihng about it.

post #162 of 181

Disclaimer: I am not a hater of Whiplash in a typical sense. I still value some of their products. I have a TWag v1, one of the good ones without copper, that I wouldn't sell for anything and a couple of older LODs. And I have owned other of their products before. But after this experience with them. I'm not dealing with them anymore. unacceptable.

post #163 of 181

Please send me an email to csanborn@whiplashaudio.com.

 

I have definitely have had my fair share of issues. One of them have been emails going to my Junk folder.

 

Try that...

 

Sorry!

Craig

post #164 of 181

I will send one now saying hi. It should have the history of our email conversations etc. if not I can forward or printscreen or something.

post #165 of 181

Message received and replied!

New Posts  All Forums:Forum Nav:

Gear mentioned in this thread: