New Posts  All Forums:Forum Nav:

Whiplash - have they gone missing?

post #1 of 180
Thread Starter 

Apparently I sent back my TWCU to them for RMA almost 3 months ago, and they haven't replied any of my emails regarding the status of my RMA. The only email i got from them was the first one when they sent me the RMA form which i filled up and their address.

 

I emailed custserv@whiplashaudio.com. That was the email shown on their website.

 

Anyone has the same problem as me?

Gear mentioned in this thread:

post #2 of 180

nope...i get replies everyday!!

 

try emailing the queries part...and craig will reply you from there

post #3 of 180

Me too.  Been in touch with Craig over the past three weeks almost daily on a job he's doing for me.  Received a shipping notice yesterday.  Send Craig another query as chesterljh suggests above.

post #4 of 180
Thread Starter 
I've sent him two emails to both the emails since i started this thread. No replies.

Sorry if I'm impatient. But 3 months is a pretty long time.
post #5 of 180

Try this email address: csanborn@whiplashaudio.com

post #6 of 180
Yes. That's correct. I don't see any outstanding emails that I need to respond to.

Well, to be factual, maybe 2-3, but I'm answering emails as fast as I can.

Most here can stay they can receive an email at 7am and perhaps an email even at 3am. I do my best and I stand behind the fact that's all I can do. Those who know me can easily say I try my best to make everyone happy.


Craig
post #7 of 180
Thread Starter 

sorry for the late reply. I've just sent another email to csanborn@whiplashaudio.com

 

Previously i've been sending to Request@whiplashaudio.com & custserv@whiplastaudio.com

post #8 of 180
Quote:
Originally Posted by bobozhang137 View Post

sorry for the late reply. I've just sent another email to csanborn@whiplashaudio.com

 

Previously i've been sending to Request@whiplashaudio.com & custserv@whiplastaudio.com

I see and will take care of it!!

 

Craig

post #9 of 180
Quote:
Originally Posted by SACD-Man View Post

I see and will take care of it!!

 

Craig

 Craig,

 

do reply my email regarding my headphone cable.

 

thanks!!!

 

regards,

Chester

post #10 of 180

Craig, will sending an email help you coordinate the shipping of my items better?

 

Thanks,

TT3rd

post #11 of 180

Well people, Craig can be a bit slow in responding at times, but the products he delivers are simply amazing.

 

Both in terms of sonic quality and sheer looks they are truly some of the finest in the trade.

I got Craig to make me a angled dock connector for my clas, and boy is it nice, simply gotta post a pic. 

 

Thanks Craig!

 

 

400

post #12 of 180
Just sent Craig a PM. I emailed the customer service link on their website several weeks ago and never got a response. I need a cable cable please
post #13 of 180
Quote:
Originally Posted by Python002 View Post

Just sent Craig a PM. I emailed the customer service link on their website several weeks ago and never got a response. I need a cable cable please

Did you use this email address: csanborn@whiplashaudio.com?

 

I emailed him last week and over the weekend and received responses almost immediately.

post #14 of 180

ok...i am receiving no response since last week..this is very sad Craig... =(

post #15 of 180
Sorry guys. I got out of the hospital today and getting caught up.

I really am trying to get caught up. It's hard to respond here and emails at the same time.

Craig
New Posts  All Forums:Forum Nav:

Gear mentioned in this thread: