Head-Fi.org › Forums › Equipment Forums › Portable Headphones, Earphones and In-Ear Monitors › Ultimate Ears UE 900 Discussion and Impressions Thread
New Posts  All Forums:Forum Nav:

Ultimate Ears UE 900 Discussion and Impressions Thread - Page 219

post #3271 of 3603
@tommy it is disappointing,but what can we do. Its unfortunate because they could of been very good if they fixs those problem but all I can do is keep my 900 until my warranty period is up. And take my bussniss else were.
post #3272 of 3603
Yeah I agree. I'm just puzzled what's up with Ultimate Ears. Ever since Logitech took over it went south.
post #3273 of 3603

lol...they responded to me and said i need to click the link (which was not provided by them) and that there is a 3.5mm adapter included with UE900s accessories. i asked them to escalate since they have no knowledge of their own products 

post #3274 of 3603
Unreal. I don't know if I should laugh or cry lol so frustrating indeed.
post #3275 of 3603

I made this video to detail the story so far and to let other people about the current issue with some of the units you peeps have been receiving:

 

 

Hopefully enough people will watch this video that Logitech will provide some resolution for your issue. If Logitech is indeed selling a new product with old (failure prone) parts, people need to know. 

post #3276 of 3603

I own the UE900 but sold it because it didn't pair nicely with my player. Wonder if the S model will make any difference?

post #3277 of 3603
Quote:
Originally Posted by manutd6389 View Post
 

I own the UE900 but sold it because it didn't pair nicely with my player. Wonder if the S model will make any difference?

There is a very small number of people who actually received the 900s with the new shell and 'bass tube'. The rest are all came in 900s box but look identical to the 900. Read the last few pages of the thread to get an idea of what's going on. 

post #3278 of 3603
Quote:
Originally Posted by manutd6389 View Post
 

I own the UE900 but sold it because it didn't pair nicely with my player. Wonder if the S model will make any difference?

 

What player were you using? 

post #3279 of 3603
900s will NOT include the 1/4 inch adapter.
post #3280 of 3603
Quote:
Originally Posted by tinyman392 View Post
 

 

What player were you using? 

Sony F887. Goes very well with my Westone 3

post #3281 of 3603
Quote:
Originally Posted by manutd6389 View Post

Sony F887. Goes very well with my Westone 3

Possibly an output impedance issue? From Rin's blog, output impedance will make the 900 sound flatter. Knowing you like the W3, that's the opposite direction you want to go. Also, the W3 is a completely different animal to the UE 900. Could also be a signature preference issue as well.
Edited by tinyman392 - 5/27/14 at 5:06am
post #3282 of 3603
Quote:
Originally Posted by tinyman392 View Post


Possibly an output impedance issue? From Rin's blog, output impedance will make the 900 sound flatter. Knowing you like the W3, that's the opposite direction you want to go. Also, the W3 is a completely different animal to the UE 900. Could also be a signature preference issue as well.

Maybe. Guess I have found the right one for me so far after so many testing. But the UE900 is still a great pair

post #3283 of 3603

So I'm wondering if anyone has heard any more news about this situation?

 

I can suggest a way for you to escalate the response to this issue. Someone should open up a new entry in the gear guide for the UE900s, and if you leave your review there it will make it near the top of any Google searches for the UE900s. Or you could leave an Amazon review at this listing: http://www.amazon.com/Logitech-Ultimate-Noise-Isolating-Earphones-VERSION/dp/B00JB66VX4/ref=sr_1_2?ie=UTF8&qid=1401263802&sr=8-2&keywords=ue900

post #3284 of 3603
Annoying. Annoying. Annoying. My UE900 still work ok. They have not been clogged. Trust me, I check them regularly and no ear wax ever reaches the sound tubes. At best there are a few flakes on thw tips after a few hours of listening. I have a very hard time imagining my ear wax clogging the tubes. As for Europeans I have no difficulties seeing more fluid ear wax blocking up every part of that pinhole. But looking into quite many ears and looking at a few in ears used by others I'd say that the difference between their ear wax and mine, is significant. A very positivistic approach but there are also real reports regarding the issue.
post #3285 of 3603

I've had my UE900 for not even a week, already the right side is starting to cut out at the connector.  What a shame.....  Fortunately they are in the return window, back to my TF10 for now....

New Posts  All Forums:Forum Nav:
Head-Fi.org › Forums › Equipment Forums › Portable Headphones, Earphones and In-Ear Monitors › Ultimate Ears UE 900 Discussion and Impressions Thread