or Connect
Head-Fi.org › Forums › Equipment Forums › Portable Headphones, Earphones and In-Ear Monitors › Ultimate Ears UE 900 Discussion and Impressions Thread
New Posts  All Forums:Forum Nav:

Ultimate Ears UE 900 Discussion and Impressions Thread - Page 195

post #2911 of 4277
Quote:
Originally Posted by shacky View Post
 

I had a little trouble too.  In fact I just found best fit with the rubber tips by going smaller.  I kept going larger with foam.  And with rubber even the largest wasn't sealing - till I figured out I needed to go smaller.  

 

I don't like having to squeeze the foam then hold in place while it expands - I liked the black foamies on my Shures in that regard.  But just fiddling around and found best fit so far by going several sizes smaller on the rubber tips.

 

Now sound is nice and warm.  better bass.  I guess I wasn't getting deep enough fit with too large tips for my ears.  I started with 12.5 and went up from there at first.  Then I tried the rubber - smaller than 12.5 - and wow.  This tips fits just right - reminds me of the Three Bears ; )

 

Give it a try.  Hope it works for you.

Yape I agree, I used the comply form but now using the silicone rubber tips.

Silicone rubber gives me better bass while form gives me better isolation.

post #2912 of 4277

HELP! When trying to separate the ear piece and the cord the whole shell BROKE and the wire connecting the drivers and the connection SPLIT. 

 

What do I do? Is this fixable under the warranty?

post #2913 of 4277
Quote:
Originally Posted by jiggahwhat View Post

HELP! When trying to separate the ear piece and the cord the whole shell BROKE and the wire connecting the drivers and the connection SPLIT. 

What do I do? Is this fixable under the warranty?
Talk to logitech!
post #2914 of 4277
Quote:
Originally Posted by jiggahwhat View Post

HELP! When trying to separate the ear piece and the cord the whole shell BROKE and the wire connecting the drivers and the connection SPLIT. 

What do I do? Is this fixable under the warranty?
Crazy glue?
post #2915 of 4277
Quote:
Originally Posted by jiggahwhat View Post
 

HELP! When trying to separate the ear piece and the cord the whole shell BROKE and the wire connecting the drivers and the connection SPLIT. 

 

What do I do? Is this fixable under the warranty?

 

Doesn't sound like you have much choice.  Call or send to Logitech and hope they will cover.  The 900s came with pretty explicit instructions about removing the wires...

post #2916 of 4277
Quote:
Originally Posted by Canadian411 View Post


Crazy glue?

 

If you severed wires, don't do this.  It'll void your warranty for sure. 

post #2917 of 4277

So it looks like other people have had the exact same thing happen to them.

 

http://forums.logitech.com/t5/Logitech-UE/UE900-broke-what-are-my-options/td-p/1045595

 

Guess all the reviews I read about shoddy build quality were right.

post #2918 of 4277

I just received a brand new pair of 900s from Logitech. No sign of maintenance gel though, and the packaging still says 2 year warranty...  Anyway, off with the tips, off with the cable, on with the FiiO cable, on with the medium Comply TSX200s, on with La Vie En Rose (Grace Jones), and I'm happy again.   I hope this pair lasts longer than the first pair... 


Edited by Depechetraff - 4/18/14 at 7:02am
post #2919 of 4277

I've had mine for little over 8 months which are now quieter in the right channel sound tinny and cheap. I've been through 7 or 8 sets of Ultimate Ears some lasting just days others weeks and the longest 7 and 8 months but always end up quieter in one channel and loses its fullness. Every set has permanently lived on my desktop which after every use I drape them over my screen monitor or place them by its side. I never wear them to bed or to commute to work nor when I'm exercising or anything like that just at my desktop which I keep them plugged in permanently into my Logitech Z906 control dock.

 

My Logitech control dock volume is set between 40 to 50%, computer volume 75%, media player volume 75% which media and computer volume never exceeds 75% I adjust volume at Logitech control dock if I want louder but is there anyway to repair or fix these as Logitech said when I was given them that they would only refund the original amount prior to owning UE I use to use cheap £10 Phillips She Model which I had two sets last aprox 3 years each.. I have tried the other cable but it makes no difference which is real shame as I thought that was problem I was having with UE350 & UE400 model

 

I started out with UE 350 (Lasted 3 weeks), UE 400vi (Lasted 7 weeks) UE 400vi (Lasted 7 months), UE 600 (Voided & transferred the warranty to 400) UE 600 (Unwanted returned to Amazon unused) UE 400 (Lasted 4 days) UE 400 (Lasted 2 days) UE 900 (Lasted 8 months).

 

My UE 600 still work but I really dislike the sound due to 3D sound, they're great for speech but really sucky for music due to no bass


Edited by swiftkidd - 4/20/14 at 7:06am
post #2920 of 4277
Quote:
Originally Posted by swiftkidd View Post

I've had mine for little over 8 months which are now quieter in the right channel sound tinny and cheap. I've been through 7 or 8 sets of Ultimate Ears some lasting just days others weeks and the longest 7 and 8 months but always end up quieter in one channel and loses its fullness. Every set has permanently lived on my desktop which after every use I drape them over my screen monitor or place them by its side. I never wear them to bed or to commute to work nor when I'm exercising or anything like that just at my desktop which I keep them plugged in permanently into my Logitech Z906 control dock.

My Logitech control dock volume is set between 40 to 50%, computer volume 75%, media player volume 75% which media and computer volume never exceeds 75% I adjust volume at Logitech control dock if I want louder but is there anyway to repair or fix these as Logitech said when I was given them that they would only refund the original amount prior to owning UE I use to use cheap £10 Phillips She Model which I had two sets last aprox 3 years each.. I have tried the other cable but it makes no difference which is real shame as I thought that was problem I was having with UE350 & UE400 model

I started out with UE 350 (Lasted 3 weeks), UE 400vi (Lasted 7 weeks) UE 400vi (Lasted 7 months), UE 600 (Voided & transferred the warranty to 400) UE 600 (Unwanted returned to Amazon unused) UE 400 (Lasted 4 days) UE 400 (Lasted 2 days) UE 900 (Lasted 8 months).

My UE 600 still work but I really dislike the sound due to 3D sound, they're great for speech but really sucky for music due to no bass

I really can't understand how you've got through so many ear buds in such a short time. The only ear buds I've owned and broken in the last five years were the apple in ears which developed a fault with the remote after 100's of hours in the gym (moisture had damaged the unit) Either you're the most unlucky person alive or, if you are as careful as you describe with them, someone else is borrowing them and treating them badly. I have 2 pairs of UE Triple Fi 10's, UE900's, UE4000 and UE6000 and have no problems to date with any of them. I've always found the build quality of UE products very good with the exception of the 900's which look a bit shoddy. But as I said they've not given me any bother up until now (touch wood!!)
post #2921 of 4277

He's not alone. I've gone through a heap within about a year. I'm quite careful to pack them away in a case after each use by rolling in around 3 fingers

 

RE0 - jack died

UE700, wife stepped on it in a fit of rage

RE0 - left side cut out (replacement coming but will sell)

GR07 BE - left side starting to cut out after 30 minutes of use.

UE900 sometimes cutting out now

RE400 - died once right side cut out due to jack issues

RE400 (replacement) - died again, left side cut out jack issues (i sold the third replacement)

post #2922 of 4277
I agree that it is possible but there's usually an easily identifiable cause. I used to buy and repair for resale batches of Kilpsch S4i mkll with flat cables, which was a bit of a design fault which led to the jacks failing. But after using a pair myself I realised that when my phone was in my back pocket simply walking put a lot of strain on the jack plug and particularly the cable just above it. It is usually only through such constant stress that an eventual fault will occur. I find that if I keep my phone in my inside jacket pocket this relieves all such issues. It also amuses me when people say they always use the case. So do I but believe it or not the damage doesn't occur when they're sitting at home on a shelf it's when they're being used.
post #2923 of 4277

My DAP is usually in my bag which I carry on my back, its not really moving that much since the backpack is on my body, so similar to it being in a jacket. I've never really took my RE400s anywhere and used them only at home and mainly at the desk but have had 2 die on me, I really babied them, because they felt so flimsy. I really think design flaws cause this issue because I've used crappy IEMs that I've chucked around, no case, wrap it around the phone and into my bag or pocket and never had one die. I think design issues make it much worse so 

post #2924 of 4277
I totally agree and in reality the manufacturer's don't want to create a product that lasts for life because they want repeat custom.
post #2925 of 4277

New UE900s.

 

 

 

[EDIT] Official Link: http://www.ultimateears.com/en-us/900s


Edited by aLm0sT - 4/24/14 at 9:20am
New Posts  All Forums:Forum Nav:
Head-Fi.org › Forums › Equipment Forums › Portable Headphones, Earphones and In-Ear Monitors › Ultimate Ears UE 900 Discussion and Impressions Thread