Head-Fi.org › Forums › Equipment Forums › Portable Headphones, Earphones and In-Ear Monitors › Ultimate Ears UE 900 Discussion and Impressions Thread
New Posts  All Forums:Forum Nav:

Ultimate Ears UE 900 Discussion and Impressions Thread - Page 145

post #2161 of 3803
Quote:
Originally Posted by fnkcow View Post

 

Thanks man!

Alas they dont cover Australia.. Cant find them through the Asia Pacific websites

I've sent an email to the Australia branch to ask if I could purchase directly from them

http://www.logitechshop.com.au, but they don't have it (along with a lot of other things.)

post #2162 of 3803
Quote:
Originally Posted by DrSheep View Post

http://www.logitechshop.com.au, but they don't have it (along with a lot of other things.)

yeah it sux to be far away from everyone else

post #2163 of 3803

Looks like you either need to go eBay or just beg someone in the US to get it for you.

post #2164 of 3803
Quote:
Originally Posted by DrSheep View Post

Looks like you either need to go eBay or just beg someone in the US to get it for you.

yeah i guess i dont have much of a choice

post #2165 of 3803
Just get the regular T-500 instead of the round TS-500.  Also pull the tips out from the bore a bit will help.


Currently use the T-500 tips but they're only 2/3 the length of the P series. I wasn't keen on the UE900s initially, but partial blocking of the pinhole bore has made them into a different - & hugely enjoyable - animal entirely... Balanced with a bit of low-end punch. It's just irritating they require constant fiddling with to maintain a good seal. The minute Comply make a P series to fit they'll be perfect.
post #2166 of 3803

I've had these for about 7 months now, and my 1243 batch developed a buzzing in the left channel over this past month, which is quite disappointing.

Not only that, but because I received the UE900's as a replacement for my TripleFi 10, only the original warranty from the TripleFi 10 applies - so Logitech refuses to replace them since my original warranty is 5 months expired.

Does anyone know any working solution for the driver buzzing issues?  I'm basically stuck with a 400$ paperweight now. :(


Edited by porksandwich911 - 8/18/13 at 10:37am
post #2167 of 3803
Have you tried both cables?
post #2168 of 3803

I must be you from a parallel universe two weeks ahead, because I ran into this exact issue with this very batch, which I had also received as a replacement for a broken UE TF10 less than a year ago.  That said, my story has a good ending, so read on.  The only additional twist is that my right IEM fell apart while switching cables, prompting a call to Logitech support.  Upon receiving a polite 'you're out of luck' message despite my offers to pay for repairs or replacement parts, I felt compelled to share my thoughts on the Amazon UE900 review page (http://www.amazon.com/gp/cdp/member-reviews/A3OLWISEVGSA0H/ref=cm_cr_pr_auth_rev?ie=UTF8&sort_by=MostRecentReview).  Within two days I received a comment from someone who worked at Logitech with an offer to set things right.  It has been less than a week since and I am enjoying a brand new pair of UE900s as we speak  (batch 1345 if memory serves me but the light is dim and i am just too lazy to confirm :) 

 

I learned that the individual who reached out to me is the SVP and head of the musical div of Logitech.  Thank goodness they have someone up top who knows what they are doing!   Based on his postings on negative Amazon reviews, I imagine I am not the first person to have received a replacement this way. 
 
I do hope you are able to similarly resolve your problem and are able to once again enjoy what is otherwise a very fine IEM!  
 
Cheers,
Avinash  
post #2169 of 3803
Quote:
Originally Posted by asarin View Post

I must be you from a parallel universe two weeks ahead, because I ran into this exact issue with this very batch, which I had also received as a replacement for a broken UE TF10 less than a year ago.  That said, my story has a good ending, so read on.  The only additional twist is that my right IEM fell apart while switching cables, prompting a call to Logitech support.  Upon receiving a polite 'you're out of luck' message despite my offers to pay for repairs or replacement parts, I felt compelled to share my thoughts on the Amazon UE900 review page (http://www.amazon.com/gp/cdp/member-reviews/A3OLWISEVGSA0H/ref=cm_cr_pr_auth_rev?ie=UTF8&sort_by=MostRecentReview).  Within two days I received a comment from someone who worked at Logitech with an offer to set things right.  It has been less than a week since and I am enjoying a brand new pair of UE900s as we speak  (batch 1345 if memory serves me but the light is dim and i am just too lazy to confirm :) 

 

I learned that the individual who reached out to me is the SVP and head of the musical div of Logitech.  Thank goodness they have someone up top who knows what they are doing!   Based on his postings on negative Amazon reviews, I imagine I am not the first person to have received a replacement this way. 
 
I do hope you are able to similarly resolve your problem and are able to once again enjoy what is otherwise a very fine IEM!  
 
Cheers,
Avinash  

Holy sheet.  Your story sounds the exact same.  I asked about a repair center.  The tech says there are none.  I asked if I could just buy a left driver.  Nope.  Most polite way of saying "**** you." Hmm, maybe I will have some success this way.

post #2170 of 3803
Interesting discovery re eartips. Tried the double-flange tips from a pair of Yamaha eph-100s on the UE900s & much to my surprise they fit, instantly resolving the fit issues I've had with the shallow insertion & insubstantial seal the housing shape on the UE's causes for me. Although they seem too big for the UE's nozzle, the ridge on the nozzle must create a good anchor point since the fit is perfectly firm, though not as tight as on the parent eph-100s.

Best of all the sound is improved, with everything sounding more precise, punchy & with a far less 'woolly' bass.

Just a pity the Yam eartips aren't available aftermarket...
post #2171 of 3803
I just got my replacment and this batch is diffrent idk whats up not sure if its bad or good yet this batch comes from batch 1327 and the filters are white also the pin cabel seems diffrent i mean the inside of the iem where cord and iem connect and lastly it sounds a bit diffrent idk if its bad or good yet and it takes a whole lot more energy to drive like 3 levels below max and lastly there was one problem when i first connected it it sounded like one side was louder and that both side werent fully plug in even tho it was i change the cabel didt fix but unpluging and pluging back work never heard it again so far. Il try to post pics later
post #2172 of 3803

Wow... 127 words in a single sentence.  Anyway, hope to hear some good news from you soon.

post #2173 of 3803
Blue cabel started acting up so i switch to black. The stock tips where small instead of medium like the orginal. There zero distortion on max lv and there more subbass then before. Im try the comply tips to see if its diffrent because on all my other replacement they seem to be one size to small for the 900
post #2174 of 3803
Quote:
Originally Posted by jayaudio116 View Post

Blue cabel started acting up so i switch to black. The stock tips where small instead of medium like the orginal. There zero distortion on max lv and there more subbass then before. Im try the comply tips to see if its diffrent because on all my other replacement they seem to be one size to small for the 900

 

More sub-bass presence is expected, it's what happened with mine.  It'll go back down with time...  What confuses me is the volume and balance issues you're having. 

post #2175 of 3803
The comply tip are stil to small the cabels dont work good on my ipod for some reason but works good on everything else maybe thats why i had to turn it up so much. There still no distortion at max voilum. Defently more subbass but not by that much, sounds a bit fuller and there a littel bit of air and i notice a littel bit of sibilance not a big deal. before i never heard any. Thats the only diffrence that notice
New Posts  All Forums:Forum Nav:
Head-Fi.org › Forums › Equipment Forums › Portable Headphones, Earphones and In-Ear Monitors › Ultimate Ears UE 900 Discussion and Impressions Thread