Head-Fi.org › Forums › Equipment Forums › Portable Headphone Amps › iPod and FIIO LOD Cable Issue
New Posts  All Forums:Forum Nav:

iPod and FIIO LOD Cable Issue

post #1 of 5
Thread Starter 

Dear HeadFi'ers,

 

I just locally bought a FIIO Alpen E17 which I planned on using with my 3rd generation iPod Touch, along with my Etymotics ER-4S. I'm currently using a FIIO L3 LOD cable; however, I have connection issues with my iPod. 

 

The Fiio Alpen E17 with the LOD 3 works without a hitch on my wife's Nano and our iPad. The connection between the iPod port and the LOD is somewhat loose. Upon applying pressure on the Fiio cable head when connected to the iPod port works; however, when I no longer touch the cable connector, it quickly if not immediately drops the sound. If the sound is not lost, I notice that it degrades horriblly. I also used pliers to tighten the LOD connector with the hope that it would establish a tighter connection. It worked with limited success; however, touching or brushing against the cable will retrigger the issues above.

 

I'm wondering whether buying a FIIP LOD 9 will resolve the issue, as I recall that the connectors are slightly larger than the LOD 1 and 3 models. Virtually all the audio stores in Montreal, Canada look at me funny when I ask them if they carry LOD cables. My wife attributes the loose connection issue to my rough handling of my iPod. Have I missed anything? 

 

Regards,

 

Vince

 

P.S. I love the Alpen E17! A very sweet device indeed!


Edited by weemaddox - 8/24/12 at 8:47am
post #2 of 5

It sounds like your wife is spot-on. Think about it:

You've tested the same cable on 3 different devices, and the issue only occurs with one of them. That device is thus most likely the problem.

post #3 of 5

Take the case off your touch.

post #4 of 5
Thread Starter 

Thanks for the suggestion goodvibes. I did in fact remove the case during my initial troubleshooting.

post #5 of 5
Thread Starter 

I was hoping that perhaps a different type of LOD cable would perhaps fit my iPod Touch connector better, but after visiting the FIIO website, I think that was wishful thinking on my part. frown.gif

 

The thing is that I can just sync just fine with Itunes... Why does God hate me?

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Headphone Amps
Head-Fi.org › Forums › Equipment Forums › Portable Headphone Amps › iPod and FIIO LOD Cable Issue