Head-Fi.org › Forums › Equipment Forums › Portable Headphone Amps › FiiO e17 - Not powering on?
New Posts  All Forums:Forum Nav:

FiiO e17 - Not powering on?

post #1 of 5
Thread Starter 

Having just ordered an EO9k to compliment it yesterday I was listeningto my E17 plugged into my work laptop via USB; walked away; and when I came back I was unable to turn it back on.

 

Power switch still has the nice 'click'; just no response...

 

For the last 3-4 months; the DAC hasn't really been unplugged at all (Though it's plugged into a laptop dock; and the laptop moves almost on a daily basis; DAC stays where it's at).

 

Anyone have a similar problem? (or know of a reset switch..)

 

-Chris

post #2 of 5
Thread Starter 

So; I found a reset pin hole on the top; held that down for ~30 seconds and it booted up fine.. Still has me disconcerted... :(

post #3 of 5

Just had the same problem and your solution worked for me aswell, but I was wondering if you have experienced any more problems with it or if it has been working fine ever since

post #4 of 5

Back when I had the E17 it would require a few resets or plug in and then turn on solutions. I would guess its a glitch or a periodic bug that is hard to isolate or reproduce. 

post #5 of 5
Thread Starter 

It's been a few months of daily use for my e17 on my work computer as a usb dac; and I haven't had any other issues.  

 

I do fiddle with it a bit; my earbuds like a gain of 0  while my AKG like 6.  Fingers crossed on having no future issues.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Headphone Amps
Head-Fi.org › Forums › Equipment Forums › Portable Headphone Amps › FiiO e17 - Not powering on?