Head-Fi.org › Forums › Equipment Forums › Portable Headphones, Earphones and In-Ear Monitors › TF10's cable keeps dying on me, been through 3 replacements already. Try another brand?
New Posts  All Forums:Forum Nav:

TF10's cable keeps dying on me, been through 3 replacements already. Try another brand?

post #1 of 6
Thread Starter 

Just wondering what other brands of cables i shoudl try out. i find the orignial ones very comfortable, so i prefer one thats similar to the original one, but i dont want it dying on me every 2 months so it has to be well made. If it has a microphone thats a bonus, as i'm using the TF10vi and i listen to music on my iphone most often.

 

cheers

post #2 of 6

Is it the cable that dies out or the actual headphones?

post #3 of 6
My TF10vi cables broke on me 2 months after purchasing it new & the local distributor wouldn't honour any warranty.

I ended up with Null-Audio's Lune cable & was very happy with it (as it was an upgrade in SQ over stock cable) but I did lose the microphone capability. They cost me approx $110+ a few years back.

Another you could try but is somewhat expensive is Beat Audio's iPhone cable - these will cost you approx $250+delivery. I had those too but for my Unique Melody IEMs instead of the TF10vi's. But Beat Audio do make them for the UE type connectors too.
post #4 of 6
Thread Starter 

ok those kind of prices are WAAAAY out of my budget. the earphones only cost me about $100 during the black friday sale last year. im looking for something under $50. Im not looking for a cable that improves the sound quality. As long as it dosent make it crappy, or die in 2 months, i'd be happy. I hope i can find something to last at least a year, preferably 2.

 

The actual buds are working fine. its just the cable that keeps failing.

post #5 of 6
You could try these, but no microphone on them.

FiiO RC-UE1 cable
post #6 of 6
New Posts  All Forums:Forum Nav:
Head-Fi.org › Forums › Equipment Forums › Portable Headphones, Earphones and In-Ear Monitors › TF10's cable keeps dying on me, been through 3 replacements already. Try another brand?