or Connect
New Posts  All Forums:Forum Nav:

The JVC HA-S500 thread. - Page 486

post #7276 of 8319

The price of the ATH pads is close to what I paid for the headphone.. o.o

post #7277 of 8319
Quote:
Originally Posted by marko93101 View Post

The price of the ATH pads is close to what I paid for the headphone.. o.o
Same here in Canada, but you can get them for $6 a pair from ATH US Parts.
post #7278 of 8319

The bass after 100-150++ hours is very punchy and controlled. No vibrations whatsoever for me. 

Heads up the WS55x is only 60$ on amazonJP!

post #7279 of 8319

Changing the subject somewhat:

 

So it's been said that the cups are too small for a real removable cable mod of any kind. Not gonna dispute that, but has anyone thought of terminating the y-split in a 1/8" F jack? So most of the cable is removable? Just a thought, since the cable, while certainly hardy, is my second favorite thing about the headphones (the first being the chipping).

post #7280 of 8319
Quote:
Originally Posted by TrollDragon View Post


Same here in Canada, but you can get them for $6 a pair from ATH US Parts.

 

 

I don't know what I was reading earlier, I'm putting it down to late night reading, but they're available for 10£ online so that totally makes me look silly..... may have to pick them up next week!


Edited by marko93101 - 8/18/13 at 7:06pm
post #7281 of 8319

Whoops, double.


Edited by marko93101 - 8/18/13 at 7:06pm
post #7282 of 8319
Quote:
Originally Posted by Karuo View Post

The bass after 100-150++ hours is very punchy and controlled. No vibrations whatsoever for me. 
Heads up the WS55x is only 60$ on amazonJP!

I would describe the bass on my relatively new S500 with about 8 hours of normal usage (at reasonable volume levels) just like that: precise, controlled and punchy.
I think that the pads play a big role for the bass perception and the WS55 pads are totally worth it.

-graureiher
post #7283 of 8319

Hey guys, I'm having a problem with my S500's here,

 

Whenever I use the bass boost settings on the E11, there seems to be some loud hissing particularly in the right side. Not really hissing, more like someone blowing air or  breathing heavily near your ear. It's very noticeable especially when listening to music on low volumes, which i do most of the time. I thought it was a problem with the E11, so I switched over to my M50's and DT880's but there doesn't seem to be such problem. Does anyone else have this issue? And how can i fix it?

post #7284 of 8319
Quote:
Originally Posted by xkonfuzed View Post

Hey guys, I'm having a problem with my S500's here,

 

Whenever I use the bass boost settings on the E11, there seems to be some loud hissing particularly in the right side. Not really hissing, more like someone blowing air or  breathing heavily near your ear. It's very noticeable especially when listening to music on low volumes, which i do most of the time. I thought it was a problem with the E11, so I switched over to my M50's and DT880's but there doesn't seem to be such problem. Does anyone else have this issue? And how can i fix it?

Great. I just ordered an E11 on Tuesday. Supposed to get it today.  blink.gif Oh well, maybe it will pair better with one of my other heaphones. Should be interesting to see if it does it on both the S500 and the S400. 

post #7285 of 8319
Quote:
Originally Posted by xkonfuzed View Post

Hey guys, I'm having a problem with my S500's here,

 

Whenever I use the bass boost settings on the E11, there seems to be some loud hissing particularly in the right side. Not really hissing, more like someone blowing air or  breathing heavily near your ear. It's very noticeable especially when listening to music on low volumes, which i do most of the time. I thought it was a problem with the E11, so I switched over to my M50's and DT880's but there doesn't seem to be such problem. Does anyone else have this issue? And how can i fix it?


Nah, I have no issues pairing s500 and e11 even with the bass boost on 2.

post #7286 of 8319

I don't know why anyone uses an amp with the S500 anyways. My Rockboxed Clip Zip can drive them well enough to destroy somebody's hearing very quickly....or is there some other player out there people are using that is lower output than the Clip?

post #7287 of 8319
Quote:
Originally Posted by Achmedisdead View Post

I don't know why anyone uses an amp with the S500 anyways. My Rockboxed Clip Zip can drive them well enough to destroy somebody's hearing very quickly....or is there some other player out there people are using that is lower output than the Clip?


Well, it's not just about getting it loud although there are definitely some sources like phones, especially in Europe that don't go loud enough. In the case of s500 is more about adding a bit more control to the low end and of course boosting it when you need L3000.gif

post #7288 of 8319
The Colorfly C3 only has 12mW of output and an EQ that was designed by deaf people... So I pair it with the E11 on bass boost 1 for that little extra boom while using the S500's.

Works perfectly fine for me as well. The E11 is a great little amp for its price!
beerchug.gif
post #7289 of 8319
Quote:
Originally Posted by TrollDragon View Post

The Colorfly C3 only has 12mW of output and an EQ that was designed by deaf people... So I pair it with the E11 on bass boost 1 for that little extra boom while using the S500's.

Works perfectly fine for me as well. The E11 is a great little amp for its price!
beerchug.gif


Yeah, C3 + E11 (bass boost on 1) + S500 is an awesome portable rig that doesn't break the bank

post #7290 of 8319
Quote:
Originally Posted by TrollDragon View Post

The Colorfly C3 only has 12mW of output and an EQ that was designed by deaf people... So I pair it with the E11 on bass boost 1 for that little extra boom while using the S500's.

Works perfectly fine for me as well. The E11 is a great little amp for its price!
beerchug.gif

I guess that is a little lower than the Clips....I think they were measured at 15mW by he who may not be named. evil_smiley.gif

 

When I use my iPod and LOD with the E11, I won't even use bass boost 2....that makes it too muddy. Bass boost 1 does work nicely though.

New Posts  All Forums:Forum Nav: