New Posts  All Forums:Forum Nav:

Klipsch Image S4 problems?

post #1 of 2
Thread Starter 

Hi, new to the forum and Head-Fi.org.

 

 

I bought an open box of the Klipsch Image S4 on eBay from a reliable seller. They look genuine and I found a page online that shows a fake vs a genuine and mine look genuine. The problem is that the treble is very harsh, and the bass is hardly heard. Would this be better described as "too bright"? Also, volume is not very good. My stock Apple ear buds get quite loud when using my iPod. I tried the S4 on my laptop with iTunes as well.  With no EQ the S4 is too bright and with little bass. I played songs that have a big bass punch and the bass on the S4 sounded soft. I tried different presets in EQ like rock, jazz, piano, and pop, and the treble changed like it should but the sound still sounded bad.  I tried treble reducer in EQ and the treble lessened but sounded flat as the bass was practically non existent.

 

Do my S4s need to to be burned in, or do you think they are defective? I use the small ear tips as they fit my ears better than the medium ear tips. Possibly the medium tips would be better, but I would really have to push them in to fit.

The S4 sound much better than the Apple ear buds do but I think the S4 should have more volume and sound great without EQ and if a preset like Rock is used it should not be too bright.

 

They are an open box and maybe that is the giveaway...previous buyer did not like them and returned them.

Andrew

post #2 of 2
Try burning them in. It may smooth out the sound to a desired signature.
New Posts  All Forums:Forum Nav: