or Connect
Head-Fi.org › Forums › Equipment Forums › Headphone Amps (full-size) › Schiit Owners Unite
New Posts  All Forums:Forum Nav:

Schiit Owners Unite - Page 384

post #5746 of 12183
Quote:
Originally Posted by madwolfa View Post
 

 

I see that it's using the same USB chip, but probably different firmware (USB Audio 1.0, hence no driver required).

Yep the Bifrost and Gungnir seem to run USB Audio 2 which the standard Windoze drivers are incapable of dealing with or scaling back. A mere iPod Touch 5G, as is, can deal with my Bifrost without having to do anything special. I'm really liking my Bifrost.

post #5747 of 12183

Well, its working like it should so no worry I guess.

post #5748 of 12183

I believe the drivers are needed when going above 96khz, and the Modi does not, so no drivers required (Class 1 Audio which is a subset of usB 1.1)


Edited by fenderf4i - 6/20/14 at 7:38am
post #5749 of 12183
Quote:
Originally Posted by fenderf4i View Post
 

I believe the drivers are needed when going above 96khz, and the Modi does not, so no drivers required (Class 1 Audio which is a subset of usB 1.1)

 

Yeah, even while using the same chip, they've saved the higher end USB spec for more expensive models.

post #5750 of 12183
Quote:
Originally Posted by madwolfa View Post

 

Yeah, even while using the same chip, they've saved the higher end USB spec for more expensive models.

 

They've made it pretty clear that they did that to cut down on support issues, which would increase their expense (and they would then have to raise the Modi's cost), not through any sort of ill will or intentional crippling.

post #5751 of 12183
Quote:
Originally Posted by Defiant00 View Post
 

They've made it pretty clear that they did that to cut down on support issues, which would increase their expense (and they would then have to raise the Modi's cost), not through any sort of ill will or intentional crippling.

 

Yeah, I was just stating a fact.

post #5752 of 12183
Quote:
Originally Posted by madwolfa View Post

 

Yeah, I was just stating a fact.

 

Yup, no ill will intended, I was just clarifying before people misunderstood :)

post #5753 of 12183

Can anyone help a new Mac Air user here? Been trying to plug in my Modi to the Air but it just can't detect the Modi through either of the two USB ports. Am using an Audioquest Cinnamon USB cable. It works fine with my Acer laptop though. 

 

Help, please!

post #5754 of 12183
Quote:
Originally Posted by Rossliew View Post

Can anyone help a new Mac Air user here? Been trying to plug in my Modi to the Air but it just can't detect the Modi through either of the two USB ports. Am using an Audioquest Cinnamon USB cable. It works fine with my Acer laptop though. 

Help, please!
Did you go to System Preferences in the Apple Menu and click on the Sound icon? It will open out to a window which should give 2 choices: internal speakers and Schitt USB device (or similar). You choose the latter.
post #5755 of 12183
Quote:
Originally Posted by kothganesh View Post


Did you go to System Preferences in the Apple Menu and click on the Sound icon? It will open out to a window which should give 2 choices: internal speakers and Schitt USB device (or similar). You choose the latter.

Yes i did, it only showed internal speakers. I tried again with a Supra USB cable and there was intermittent connection but it could never lock on. Am really flabbergasted and getting really frustrated with the MBA! Is this an issue with the USB port or Mac Airs in general? I really thought something as expensive as a Mac should not have such issues...

post #5756 of 12183
Quote:
Originally Posted by Rossliew View Post
 

Yes i did, it only showed internal speakers. I tried again with a Supra USB cable and there was intermittent connection but it could never lock on. Am really flabbergasted and getting really frustrated with the MBA! Is this an issue with the USB port or Mac Airs in general? I really thought something as expensive as a Mac should not have such issues...

I've found Apples USB support in general to be pretty crappy.  Rebooting the machine tends to fix it for me until I sleep next.  (same behavior on mid 2013 MBA and a late 2013 15" MBP..)

post #5757 of 12183
Quote:
Originally Posted by Rossliew View Post

Yes i did, it only showed internal speakers. I tried again with a Supra USB cable and there was intermittent connection but it could never lock on. Am really flabbergasted and getting really frustrated with the MBA! Is this an issue with the USB port or Mac Airs in general? I really thought something as expensive as a Mac should not have such issues...
I use the MBA only. I've had no problems except a USB port that I recently changed. Does the USB cable fit firmly in the MBA i.e. It is not loose?
post #5758 of 12183
Quote:
Originally Posted by worminater View Post
 

I've found Apples USB support in general to be pretty crappy.  Rebooting the machine tends to fix it for me until I sleep next.  (same behavior on mid 2013 MBA and a late 2013 15" MBP..)

Rebooting meaning to shut down and restart?

post #5759 of 12183
Quote:
Originally Posted by kothganesh View Post


I use the MBA only. I've had no problems except a USB port that I recently changed. Does the USB cable fit firmly in the MBA i.e. It is not loose?

Yes it sits firmly and there is power as the indicator light is on. Just no digital connection..crap, did i waste money getting this??!

post #5760 of 12183
Quote:
Originally Posted by Rossliew View Post

Yes it sits firmly and there is power as the indicator light is on. Just no digital connection..crap, did i waste money getting this??!
With the USB cable in, restart the MBA. Then check the sound icon again.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Headphone Amps (full-size)
Head-Fi.org › Forums › Equipment Forums › Headphone Amps (full-size) › Schiit Owners Unite