Head-Fi.org › Forums › Equipment Forums › Headphone Amps (full-size) › Schiit Owners Unite
New Posts  All Forums:Forum Nav:

Schiit Owners Unite - Page 237

post #3541 of 7168
Quote:
Originally Posted by K-Otar View Post
 

I’m looking for a DAC for my Asgard 2.  Does the "Bifrost Uber" have any audible advantage over the Bifrost?

 

You could upgrade the Bifrost to Bifrost Uber at any time.  I've upgraded mine and I should say it hasn't made a day and night different but for me it has made $70 different at least. 

post #3542 of 7168
Quote:
Originally Posted by Tuco1965 View Post
 

Skip buyer's remorse, just go uber and be done with it.

 

In some circles, we call it a "teaching moment" :cool:

post #3543 of 7168

My Asgard 2 and Uber Bifrost arrived yesterday. I had the original Asgard at one point, and regretted getting rid of it for the O2. I'm happy to have this set up.

 

post #3544 of 7168

Great call on the Asgard over the O2. :beerchug:

post #3545 of 7168
Quote:
Originally Posted by fenderf4i View Post
 

My Asgard 2 and Uber Bifrost arrived yesterday. I had the original Asgard at one point, and regretted getting rid of it for the O2. I'm happy to have this set up.

 

I have the Bifrost matched with a BH Crack.  I love my setup by am jealous of how neat those 2 look stacked.:gs1000smile:

post #3546 of 7168
Quote:
Originally Posted by sjeffrey View Post
 

I have the Bifrost matched with a BH Crack.  I love my setup by am jealous of how neat those 2 look stacked.:gs1000smile:

Put some tunes on, shut off the lights, and just enjoy.  How it looks won't matter.  :atsmile:

post #3547 of 7168

when I get home there should be some schiit in my mailbox.

 

Can't wait :)

 

Ordered a Magni and a Modi earlier this week.

 

Will be replacing a FiiO E10 dac/amp

post #3548 of 7168

Congrats and enjoy!

post #3549 of 7168

Still listening to Odac/Valhalla/HD650 with 70's rocket logo 6n1p and some 80's novosibirsk 6n6p. Brillant combo. 

post #3550 of 7168
Quote:
Originally Posted by Rem0o View Post
 

Still listening to Odac/Valhalla/HD650 with 70's rocket logo 6n1p and some 80's novosibirsk 6n6p. Brillant combo. 

 

The Valhalla and the HD650 are a very good pairing.  It could be even better by the Bifrost Uber/Valhalla combo, it's my favorite setup for the HD650 unless you want to spend more than $1000.

post #3551 of 7168
Quote:
Originally Posted by pdrm360 View Post
 

 

The Valhalla and the HD650 are a very good pairing.  It could be even better by the Bifrost Uber/Valhalla combo, it's my favorite setup for the HD650 unless you want to spend more than $1000.


Tried with Bifrost [non-uber], and I'm staying with the ODAC.

post #3552 of 7168

Question for Bifrost Owners:

 

I currently have the original Bifrost (non upgraded) with USB

 

recently, when watching movies and listening to music (via USB) the sound will become distorted (very staticy and the music is thin and muffled in the background while the static/distortion sound is loud) for about 20-30 seconds before it goes back to normal.  If I pause the audio and replay it, or rewind, it also goes back to normal.  

 

this only happens occasionally.  the 2 previous times its happened (last eek) i was watching a movie and it was atleast an hour before it occurred 

 

today it happened after listening to music for 10 minutes.

 

I'm my setup is macbook pro -> Bifrost (USB) -> amp -> speakers

 

I will pickup an optical cable so i can see if its the bifrost usb causing the problem. or maybe its some type of interference ?

 

 I don't think the macbook or amp has anything to do with it because I have used the same setup but with an ODAC and never had this issue.  

 

Just curious if anyone has had a similar issue or could share any knowledge as to what could be the source of the problem

post #3553 of 7168

I suspect that it is a RAM issue.  If you upgraded your OS X recently you may be at the memory capacity of your machine.

post #3554 of 7168
Quote:
Originally Posted by mac336 View Post
 

Question for Bifrost Owners:

 

I currently have the original Bifrost (non upgraded) with USB

 

recently, when watching movies and listening to music (via USB) the sound will become distorted (very staticy and the music is thin and muffled in the background while the static/distortion sound is loud) for about 20-30 seconds before it goes back to normal.  If I pause the audio and replay it, or rewind, it also goes back to normal.  

 

this only happens occasionally.  the 2 previous times its happened (last eek) i was watching a movie and it was atleast an hour before it occurred 

 

today it happened after listening to music for 10 minutes.

 

I'm my setup is macbook pro -> Bifrost (USB) -> amp -> speakers

 

I will pickup an optical cable so i can see if its the bifrost usb causing the problem. or maybe its some type of interference ?

 

 I don't think the macbook or amp has anything to do with it because I have used the same setup but with an ODAC and never had this issue.  

 

Just curious if anyone has had a similar issue or could share any knowledge as to what could be the source of the problem

 

 

Quote:
Originally Posted by SoulSyde View Post
 

I suspect that it is a RAM issue.  If you upgraded your OS X recently you may be at the memory capacity of your machine.

 

I've had the same issue pre/post mavericks upgrade on my mac mini.  I may look into getting ram, though.  Only have 4gb

post #3555 of 7168
Quote:
Originally Posted by mac336 View Post
 

Question for Bifrost Owners:

 

I currently have the original Bifrost (non upgraded) with USB

 

recently, when watching movies and listening to music (via USB) the sound will become distorted (very staticy and the music is thin and muffled in the background while the static/distortion sound is loud) for about 20-30 seconds before it goes back to normal.  If I pause the audio and replay it, or rewind, it also goes back to normal.  

 

this only happens occasionally.  the 2 previous times its happened (last eek) i was watching a movie and it was atleast an hour before it occurred 

 

today it happened after listening to music for 10 minutes.

 

I'm my setup is macbook pro -> Bifrost (USB) -> amp -> speakers

 

I will pickup an optical cable so i can see if its the bifrost usb causing the problem. or maybe its some type of interference ?

 

 I don't think the macbook or amp has anything to do with it because I have used the same setup but with an ODAC and never had this issue.  

 

Just curious if anyone has had a similar issue or could share any knowledge as to what could be the source of the problem

 

I had this issue with a number of Bifrost units and the Gungnir. I recall Jason putting the call out for more details some months ago. Not sure if an official statement was ever made about the cause of the issue. Definitely not to do with RAM. I did everything to isolate the problem. Moving on from Schiit DACs solved it for me. Never once experienced this screeching issue with my previous DACs or the NAD M51 I now own.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Headphone Amps (full-size)
Head-Fi.org › Forums › Equipment Forums › Headphone Amps (full-size) › Schiit Owners Unite