Head-Fi.org › Forums › Equipment Forums › Portable Headphones, Earphones and In-Ear Monitors › V-MODA M-100: Discussion/Feedback, Reviews, Pics, etc.
New Posts  All Forums:Forum Nav:

V-MODA M-100: Discussion/Feedback, Reviews, Pics, etc. - Page 1403

post #21031 of 21040

The price on these just went back up to $299 on Amazon :(.

post #21032 of 21040
Just bought mine from Lazada for around $215 inc shipping. smily_headphones1.gif
post #21033 of 21040

Recently dropped them multiple times on different surfaces (wood as well as concrete). Either one or both cups came out and now have some dents and scratches, but no cracks. Seems to be an issue not directly related to abuse.

post #21034 of 21040
Quote:
Originally Posted by ArchDragoon View Post

I have at right earcup -_- drop only one time and it not so high drop
Mine never been dropped, still got the cracks, have ask v-moda about this issue? It's kinda sad this happened, had high expectations with these headphones especially with build quality. Actually left ear cup has two cracks, I though it was just like the plastic mould markings I was wrong. frown.gif
post #21035 of 21040
Quote:
Originally Posted by plakat View Post

Recently dropped them multiple times on different surfaces (wood as well as concrete). Either one or both cups came out and now have some dents and scratches, but no cracks. Seems to be an issue not directly related to abuse.
Thats what im thinking as well, thanks
post #21036 of 21040



Here are the cracks of my m-100's matte black. frown.gif
post #21037 of 21040
Those cracks looks like they're from overtightening the hex screws on the shields. V-MODA have admitted that some early batches have that problem. Contact them. The warranty will take care of it.
post #21038 of 21040
Quote:
Originally Posted by SpiderNhan View Post

Those cracks looks like they're from overtightening the hex screws on the shields. V-MODA have admitted that some early batches have that problem. Contact them. The warranty will take care of it

Gives me a bit of relief knowing that info, Thanks a lot.

 

It's weird having these cracks because I never took off the shields and they just been with me for about 4 months. 

 

Contacted them now as we speak and send some pictures as well, just waiting for their reply.

 

Will give you guys updates regarding this issue.


Edited by Jefferent - Yesterday at 5:12 am
post #21039 of 21040

After two month the right channel stopped working, a little disappointing.

If I remember correctly others in the thread had the same problem before.

post #21040 of 21040
Quote:
Originally Posted by augenleet View Post
 

After two month the right channel stopped working, a little disappointing.

If I remember correctly others in the thread had the same problem before.

Mines a Year old in a week or 2 and don't have this problem. They have a 2 year warranty so just send them into V-moda 

New Posts  All Forums:Forum Nav:
Head-Fi.org › Forums › Equipment Forums › Portable Headphones, Earphones and In-Ear Monitors › V-MODA M-100: Discussion/Feedback, Reviews, Pics, etc.