Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › iBasso DX100:24 bit for bit, PG 1> Reviews & Impressions, Downloads, VIDEO, NEW Firmware 1.4.2.
New Posts  All Forums:Forum Nav:

iBasso DX100:24 bit for bit, PG 1> Reviews & Impressions, Downloads, VIDEO, NEW Firmware 1.4.2. - Page 454

post #6796 of 12539
Quote:
Originally Posted by Roffensian View Post

 

That is exactly my situation.

 

I am always having tracks show / play in reverse order, and albums within an artist in reverse alphabetical.  flac, mp3, wma, whatever are all the same.  However, the tracks show correctly (and play correctly) if you use the albums option on the menu where Directory is (rather than in the usual music menu).  I advised iBasso who told me to upgrade to 1.1.7.  I pointed out that it shipped from the factory with 1.1.7 (4th batch) and no further response.

You have to forgive me...

 

can you type your format for folder and file name like I did. Helps me "see" what is going on ;)

 

example

 

\Music\Artist\AlbumName\track# trackname.extension

 

extension = .mp3, .wma, .flac, .aac, .ogg, etc

track number (format especially, so 1. 2. or 01. 02. 03. or 1-, 2- or 01-, -02 etc)

or whatever you use


Edited by figgie - 7/9/12 at 5:04pm
post #6797 of 12539
Quote:
Originally Posted by figgie View Post

You have to forgive me...

 

can you type your format for folder and file name like I did. Helps me "see" what is going on ;)

 

example

 

\Music\Artist\AlbumName\track# trackname.extension

 

extension = .mp3, .wma, .flac, .aac, .ogg, etc

track number (format especially, so 1. 2. or 01. 02. 03. or 1-, 2- or 01-, -02 etc)

or whatever you use

 

 

Sure, I have some variations on filenames depending on the source, but folder structure is always:

 

Music\Artist\AlbumName\

 

Filename will either be Track# Trackname.extension or Trackname.extension and most of my music is either flac or mp3 - a few wma and wav - trying to avoid wma on the DX100 as it doesn't recognise the tags

 

I make sure that my tags are complete and correct and use mp3tag 2.51 to manage / validate that.

post #6798 of 12539
I actually got to laugh at this point. I did a little experimenting and disnt realize their is not only a 2nd player completely but one plays the tracks in completely reverse order of the other player. I checked 10 albums and they play mirror image orders.
post #6799 of 12539
Quote:
Originally Posted by Vonsamhain View Post

I actually got to laugh at this point. I did a little experimenting and disnt realize their is not only a 2nd player completely but one plays the tracks in completely reverse order of the other player. I checked 10 albums and they play mirror image orders.

 

Right, that's what I have seen - although I just assumed that one was 'correct' and one was 'backwards' - don't have any mixed up orders so can't comment on them mirroring one another.  Problem that I have with the one that is (in my case) correctly sequenced is that it only allows you to play one album at a time - I want to be able to put on an artist and just forget about it - for instance put on Avantasia and lose myself in all three albums that form that band's Metal Symphony without having to come back to the real world and start the next album.


Edited by Roffensian - 7/9/12 at 6:25pm
post #6800 of 12539

Some of my albums are completely jumbled, others are in the correct order... No pattern to it whatsoever. All are FLAC, but there's 16/44.1, 24/192 and everything in between. All files are tagged correctly and all files are named tracknumber - Title.extension. Like "01 - Pretty Little Thing.flac". Folder structure is Artist/Album/Files.

post #6801 of 12539
Quote:
Originally Posted by Sorensiim View Post

Some of my albums are completely jumbled, others are in the correct order... No pattern to it whatsoever. All are FLAC, but there's 16/44.1, 24/192 and everything in between. All files are tagged correctly and all files are named tracknumber - Title.extension. Like "01 - Pretty Little Thing.flac". Folder structure is Artist/Album/Files.

+1. I find this incredibly irritating especially for classical music. This fault alone would cause me to change to the new HiFiman if they get it right. It cannot be rocket science to fix and I'm very disappointed that iBasso hasn't managed to do so.

post #6802 of 12539
OK.

So there are two music players (wow... I am not going to even start on how f'ing silly that is). One plays just one album without proceeding to the next. The other has a sort or problem with descending sort on number.

Roffensian and sorrensiim

Your tracks.. anyway to make a copy of an album and replace the spaces with underscores?

Example

01 - Pretty Little Thing.flac

01-Pretty_Little_Thing.flac

Do this for two albums... along with artist (if needed) and album title (if needed).

The other question... are the two music players custom? Or is one based on Google music?

I managed to get the dx100 update image mounted in the Android sdk... unfortunately it is on work computer so won't get access until I head to work later.
post #6803 of 12539
Quote:
Originally Posted by figgie View Post

OK.
So there are two music players (wow... I am not going to even start on how f'ing silly that is). One plays just one album without proceeding to the next. The other has a sort or problem with descending sort on number.
Roffensian and sorrensiim
Your tracks.. anyway to make a copy of an album and replace the spaces with underscores?
Example
01 - Pretty Little Thing.flac
01-Pretty_Little_Thing.flac
Do this for two albums... along with artist (if needed) and album title (if needed).
The other question... are the two music players custom? Or is one based on Google music?
I managed to get the dx100 update image mounted in the Android sdk... unfortunately it is on work computer so won't get access until I head to work later.

I only use the stock player. Will try the renaming trick, but only as a troubleshooting measure, not a permanent fix. It looks like crap.

post #6804 of 12539
Quote:
Originally Posted by Sorensiim View Post

I only use the stock player. Will try the renaming trick, but only as a troubleshooting measure, not a permanent fix. It looks like crap.

Sorensiim

Yes. It is only a troubleshooting step. Basically looking to see if ibasso screwed the text stream by using the "space" as a delimiter or eof...

Either way... this fix has to come from them. I rember when I worked for best buy...like pulling teeth from Chinese developers of why things needed to work a certain way. It was always a battle.
post #6805 of 12539
Quote:
Originally Posted by figgie View Post

Surfer

 

I don't need the FLAC files.

 

But if you can export the metadata for the offending files in plain text that would be great. (Post them here for all to see, more eyes = more probability of finding a solution or at least heading down the correct eyes). Who knows, maybe you might get the attention of the XDA "developers" ;)

 

***Preface: I am not a developer but I do reverse engineer of code to understand how Java (or any other program) works. These are best guesses based on your symptoms. With that said, without access to the build, it is a guess and nothing else.***

 

It happening on albums (Folders),  music (Files) or metadata (internal content) means for your particular case, it is a systematic global text read stream problem.  I am currently narrowing down where... Looks like it is tied to the Formatter (Java.Util.Formatter) but have to dig in some more. By default it supports literal, lower case and upper case. I see no mention of it supporting out-of-box for capitalization of first letter and lower case the rest.... still digging.

 

Also, what happens when you put ALL the letter lower case? Does it capitalize the first letter regardless?

 

By chance,

 

do you know what your locale is set to (I know 2.3 supports locality)?

Hi Figgie,

 

My language is English (United Kingdom), but i have tried it on USA and it made no difference.

 

Well yes putting "soul II soul" onto the player the player still shows as "Soul Ii Soul"!!!...so it does capitalise the first letter regardless!

 

Going to try to get the metadata now.....can you tell me the process for this please ?


Edited by surfer1000 - 7/10/12 at 12:34am
post #6806 of 12539
Quote:
Originally Posted by surfer1000 View Post

Hi Figgie,

My language is English (United Kingdom), but i have tried it on USA and it made no difference.

Well yes putting "soul II soul" onto the player the player still shows as "Soul Ii Soul"!!!...so it does capitalise the first letter regardless!

Going to try to get the metadata now.....

Surfer

Try the same thing as I mentioned to the other guys.

Ie

Soul_II_SOUL.flac

It probably will read correctly. Which for your case..they def are using the space as a delimiter of sorts.
post #6807 of 12539
Quote:
Originally Posted by figgie View Post


Surfer
Try the same thing as I mentioned to the other guys.
Ie
Soul_II_SOUL.flac
It probably will read correctly. Which for your case..they def are using the space as a delimiter of sorts.

Yes when i do the above it shows exactly like the above!

post #6808 of 12539
Quote:
Originally Posted by surfer1000 View Post

Yes when i do the above it shows exactly like the above!

Surfer

Here us what you need to do.

:-)

Take pictures of the problem along with the pictures if when it "works" correctly.

Send them to Ibasso. Ask them to escelate the issue as a text input stream issue explaining each picture. Also attach the metadata as you entered in on both or how ever many examples. Point them to these troubleshooting steps. These are not critical but I would consider these items a no-ship condition if I caught this during QA testing.

Also. There seems to be two players. Both show the same problem?
Edited by figgie - 7/10/12 at 12:47am
post #6809 of 12539
Quote:
Originally Posted by figgie View Post


Surfer
Here us what you need to do.
:-)
Take pictures of the problem along with the pictures if when it "works" correctly.
Send them to Ibasso. Ask them to escelate the issue as a text input stream issue explaining each picture. Also attach the metadata as you entered in on both or how ever many examples. Point them to these troubleshooting steps. These are not critical but I would consider these items a no-ship condition if I caught this during QA testing.

I've done some of that and here is my latest info! i only have the one player

 

Hi, Martin,

I double checked the problem with the song you provided. I still cant locate the problem. Did you install any third party software that changed the OS?

http://www.ibasso.com/download/DX100 tool.rar

This is a tool that can fully format your DX100 and reload the firmware. Instruction is also included.

You can try to use it to recover this problem. Please back up your music before formatting your DX100.


Edited by surfer1000 - 7/10/12 at 12:51am
post #6810 of 12539
Surfer

Might as well give it a whirl.. see what happens!

Good luck. Keep us posted.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › iBasso DX100:24 bit for bit, PG 1> Reviews & Impressions, Downloads, VIDEO, NEW Firmware 1.4.2.