Head-Fi.org › Forums › Equipment Forums › Computer Audio › MacBook stops playing audio when lid is closed
New Posts  All Forums:Forum Nav:

MacBook stops playing audio when lid is closed

post #1 of 10
Thread Starter 

This evening I started to use my MacBook to feed a DAC. since I am using the Apple Remote app I didn't think I needed the lid open, but it turns out that closing the lid puts he laptop into some sort f power save mde, in which condition it won't play music. Is there a way of stopping the behaviour in Macs?

i could just leave the laptop open, but closing it is a bit neater, avoids dust.

post #2 of 10

Not endorsing Salon or anything. But the first good article to come up on Google.

 

It's because you don't have a mouse, keyboard and monitor connected.

 

http://techtips.salon.com/disable-sleep-mode-mac-lid-closed-4809.html

 

Another thing you could try is turning the display brightness to 0 and closing it almost all the way so it is open just a hair. That would accomplish 90% of what you want. I don't know of a custom work-around for this issue.


Edited by soundman414 - 1/18/12 at 7:46pm
post #3 of 10

The default behavior for Mac laptops is to go to sleep when you close the screen. There's no built-in setting you can change to keep this from happening, but here's a freeware program that will do what you want:

 

http://code.google.com/p/macosx-nosleep-extension/

post #4 of 10
Thread Starter 

Soundman;

 

I will try plugging in a keyboard or mouse, thanks. If Salon goes to the trouble of writing an article on this it is an real issue. 
Dr Webster, have you tried nosleep-extension. Cheaper & less space intensive than a keyboard.
post #5 of 10
Quote:
Originally Posted by DrWebster View Post

The default behavior for Mac laptops is to go to sleep when you close the screen. There's no built-in setting you can change to keep this from happening, but here's a freeware program that will do what you want:

 

http://code.google.com/p/macosx-nosleep-extension/


Thank you very much. I just tried it and it works perfectly well!!!

 

post #6 of 10
Thread Starter 

Tried attaching a USB mouse & closing the lid. It did wake up the mac but the attached Drobo didn't fully wake-up (it seemed to try but went back to sleep) and the Mac seemed to go back to sleep when the Drobo did.

post #7 of 10
Quote:
Originally Posted by alcyst View Post

Tried attaching a USB mouse & closing the lid. It did wake up the mac but the attached Drobo didn't fully wake-up (it seemed to try but went back to sleep) and the Mac seemed to go back to sleep when the Drobo did.

Do you have your Mac set to require a password upon waking from sleep? (System Preferences -> Security & Privacy) If so, then you may need to enter a password if your Mac has gone to sleep at all, so just a mouse wouldn't be effective to wake it.
post #8 of 10
Quote:
Originally Posted by nikp View Post


Thank you very much. I just tried it and it works perfectly well!!!

 



Surprised no one mentioned InsomniaX already:

 

http://www.macupdate.com/app/mac/22211/insomniax

 

Gives you a few more options.

post #9 of 10
Thread Starter 

DrWebster

nosleep-extension has done the trick. Didn't get a chance to try insomniax.

 

thanks

post #10 of 10
Thread Starter 
I am revising my opinion of nosleep. When it is turned on with the lid closed the fan seems to run all the time. Having the lid closed, the processor on ful, with the fan on means the machine gets warm, istat nano says the CPU is upto 80c. So I think it is back to no nosleep and just leave the lid 1-2cm open.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Computer Audio
Head-Fi.org › Forums › Equipment Forums › Computer Audio › MacBook stops playing audio when lid is closed