Head-Fi.org › Forums › Equipment Forums › Computer Audio › A short (audiophile) guide to Winamp (/w Maiko WASAPI)
New Posts  All Forums:Forum Nav:

A short (audiophile) guide to Winamp (/w Maiko WASAPI) - Page 5

post #61 of 100

Many thanks for the guide Bleak, everything is very simple and to the point. Also many thanks to Maiko for a truly exceptional plugin!

 

I'd just like to add that people need to restart winamp once they have added the .dll file to winamps plugin folder. Otherwise it won't show up. This should be obvious though. biggrin.gif

 

I also experienced the 0.1ms skip that at first seemingly occurred at any time during playback. One user here mentioned that he fixed this issue by setting his Power Options in Windows to "High Performance". However, I already had my power options set to high performance and I was still experiencing the issue.

 

I think I may have found the source of the problem in my case. I downloaded a sample 24bit 92KHz file from http://01688cb.netsolhost.com/samplerdownload/ . Specifically the file (LiadovPrevin.flac)

 

After listening to it a few times, I noticed it skips every time at 2:23. Leading me to conclude it's the files fault and not the plugin.

 

When using Exclusive Mode, I have found another issue with sudden noise interruptions. It seems to be that any default Windows sound notification, such as clicking on a folder and opening it, interrupts the audio flow with a quick burst of noise/static.

 

A great example of this is on the Control Panel on Windows 7. Simply open it up and click on any of the browse arrows and you will hear the noise pop up and interfere with the stream.

 

To fix the issue I disabled all Windows sound notifications:

 

1. Right click on your speaker icon 

2. Select "Playback Devices"

3. Select the "Sounds" tab

4. Select the "No Sounds" sound scheme in the drop down menu

 

For reference, I'm using an ASUS Essence STX with the unified drivers.

 

Now lets sit back and enjoy the crystal clear audio beyersmile.png

post #62 of 100
Thread Starter 
Thank you for your kind words. Also thank you for the detailed explanation of your problem and how you fixed it. I am sure that will help others with the same problem!
post #63 of 100
Just saw this thread. Im gona have to try this when i get home. Thans for the guide
post #64 of 100
Thread Starter 
Quote:
Originally Posted by kinubic View Post

Just saw this thread. Im gona have to try this when i get home. Thans for the guide


You're very welcome!

 

 

I have now updated the guide and added a (short) paragraph on exclusive mode! Have fun and enjoy!

post #65 of 100
Thanks for the guide BleaK. I spent more time reading the guides on how set up foobar than it took to install the plugin for Winamp. 5 minutes later I was enjoying Dr. Chesky's binaural in 24/96.smily_headphones1.gif
post #66 of 100
Thread Starter 
Quote:
Originally Posted by Glam Bash View Post

Thanks for the guide BleaK. I spent more time reading the guides on how set up foobar than it took to install the plugin for Winamp. 5 minutes later I was enjoying Dr. Chesky's binaural in 24/96.smily_headphones1.gif


That's great to hear! (no pun intended) beerchug.gif

post #67 of 100
Thread Starter 

Did some fixing to the guide and brushed up the exclusive mode a bit. Please give feedback if you have tried the exlusive mode or have any problems! :)
 

post #68 of 100

thanks for this guide.  After using foobar for years I'm glad to be playing with winamp again

 

I do have one main issue, I cannot get exclusive mode to work (and yes I did the check mark option as it was already set a long time ago for me).

 

Anyways, shared mode I notice I can still hear other windows things in the background which makes me think that perhaps it's not true WASAPI???  EDIT: Read your FAQ it still is.  Well I guess it's not a deal breaker but this is the error I get when I enable exclusive:"Unable to set exclusive mode.  E_ENDPOINT_CREATE_FAILED"

 

Computer is Windows 7 with an ATI Radeon 5000 series card with HDMI output to a Marantz AVR.  foobar2K does it fine with exclusive (e.g. nothing else plays in backgrond).  Thoughts?


Edited by N0sferatu - 4/29/13 at 8:50pm
post #69 of 100
Thread Starter 
Quote:
Originally Posted by N0sferatu View Post

thanks for this guide.  After using foobar for years I'm glad to be playing with winamp again

 

I do have one main issue, I cannot get exclusive mode to work (and yes I did the check mark option as it was already set a long time ago for me).

 

Anyways, shared mode I notice I can still hear other windows things in the background which makes me think that perhaps it's not true WASAPI???  EDIT: Read your FAQ it still is.  Well I guess it's not a deal breaker but this is the error I get when I enable exclusive:"Unable to set exclusive mode.  E_ENDPOINT_CREATE_FAILED"

 

Computer is Windows 7 with an ATI Radeon 5000 series card with HDMI output to a Marantz AVR.  foobar2K does it fine with exclusive (e.g. nothing else plays in backgrond).  Thoughts?


This is weird. Have you tried to allow 24-bit playback in winamp?

post #70 of 100
Quote:
Originally Posted by BleaK View Post


This is weird. Have you tried to allow 24-bit playback in winamp?

 

just did...same error

post #71 of 100
Thread Starter 
Quote:
Originally Posted by N0sferatu View Post

 

just did...same error

 


This is really werid... Sorry, looks like I can't help you. I would suggest to try hook of one thing at the time in the checkboxes in exclusive mode untill somethings happens, but I'm not sure that would result in something.

It might be that Maiko wasapi exlusive mode don't support the output from you video card, this is the only cause I can come up with at the moment.

But the shared mode is working right? In theory this should be all you need for soundquality.

post #72 of 100
Quote:
Originally Posted by BleaK View Post

 

But the shared mode is working right? In theory this should be all you need for soundquality.

 

Right.  I'll just let it go in shared mode then.  

 

The only reason I switched was I started getting some "issues" in Foobar2K so I figured I'd give WinAMP another try.  I always liked the UI better in WinAMP but never the sound quality.  Now I guess I'll be back to WinAMP.  It's weird I've been using this program since it's inception in 1997.  Crazy!!!

post #73 of 100
Subbed.
post #74 of 100
Thread Starter 
Quote:
Originally Posted by N0sferatu View Post

 

Right.  I'll just let it go in shared mode then.  

 

The only reason I switched was I started getting some "issues" in Foobar2K so I figured I'd give WinAMP another try.  I always liked the UI better in WinAMP but never the sound quality.  Now I guess I'll be back to WinAMP.  It's weird I've been using this program since it's inception in 1997.  Crazy!!!

 

Yeah, I've been using it forever too. Tried foobar, but found this unknown and GREAT output! So I decided to make a guide :) Enjoy!

 

Quote:
Originally Posted by SpiderNhan View Post

Subbed.

Cheers! beerchug.gif

post #75 of 100

I need help please guys!

 

When I pause or even shut Winamp, all the sounds continue to be muted. How do I unmute them? I wish it would unmute upon pausing my music or shutting Winamp because this could get quite annoying for me. 

 

And what are some good EQ tips or EQ settings to put into my EQ for my HE 500s? Thanks guys!

 

EDIT: How do I even install Electri-Q EQ?


Edited by highrolller - 9/16/13 at 6:35am
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Computer Audio
Head-Fi.org › Forums › Equipment Forums › Computer Audio › A short (audiophile) guide to Winamp (/w Maiko WASAPI)