Head-Fi.org › Forums › Equipment Forums › Computer Audio › A short (audiophile) guide to Winamp (/w Maiko WASAPI)
New Posts  All Forums:Forum Nav:

A short (audiophile) guide to Winamp (/w Maiko WASAPI) - Page 4

post #46 of 99

I've installed the plugin, and when I try to play any file, it plays the first split second and then stops. The app doesn't crash or anything, it just stops playing after <1 second. I can always double-click on the track again with the same result.

I just uninstalled Winamp, made sure its folder no longer existed, downloaded it from winamp.com, reinstalled it, then reinstalled this Maiko plugin, same result.

Note I typically remove a bunch of useless things from my Winamp install, but I shouldn't think it would cause a problem. Am I doing something wrong? :) I have to say that first split second of playback sounds really nice compared to the default DirectSound plugin!

 

Edit: I tried enabling Maiko's exclusive mode. Result: instead of playing for <1 second and stopping, it plays the same <1 second of the file in a loop.

I also checked the option in the settings that tell Maiko to release the device from exclusive mode and reclaim it when needed, and it worked. Then I set Winamp back to using DirectSound just to compare the sound, then set it back to Maiko (same settings -- exclusive + release when not needed) and it's broken again :(


Edited by Shub-Niggurath - 1/6/13 at 10:34am
post #47 of 99
Thread Starter 
Quote:
Originally Posted by Shub-Niggurath View Post

I've installed the plugin, and when I try to play any file, it plays the first split second and then stops. The app doesn't crash or anything, it just stops playing after <1 second. I can always double-click on the track again with the same result.

I just uninstalled Winamp, made sure its folder no longer existed, downloaded it from winamp.com, reinstalled it, then reinstalled this Maiko plugin, same result.

Note I typically remove a bunch of useless things from my Winamp install, but I shouldn't think it would cause a problem. Am I doing something wrong? :) I have to say that first split second of playback sounds really nice compared to the default DirectSound plugin!

 

Edit: I tried enabling Maiko's exclusive mode. Result: instead of playing for <1 second and stopping, it plays the same <1 second of the file in a loop.

I also checked the option in the settings that tell Maiko to release the device from exclusive mode and reclaim it when needed, and it worked. Then I set Winamp back to using DirectSound just to compare the sound, then set it back to Maiko (same settings -- exclusive + release when not needed) and it's broken again :(


When you install winamp, try not to remove "the useless things" from it. I don't know but there might be something that let's the plugin play. Also make sure you have not ticked of the plugins that lets you play the audio codecs (like mp3, flac etc.).

 

Also, what is your OS? This plugin only works (as far as I know) only on Vista, Windows 7 & 8.


Edited by BleaK - 1/6/13 at 12:08pm
post #48 of 99

Just reinstalled Winamp with all the crap I don't want, same result unfortunately!

I am using Windows 8.

post #49 of 99
Thread Starter 
Quote:
Originally Posted by Shub-Niggurath View Post

Just reinstalled Winamp with all the crap I don't want, same result unfortunately!

I am using Windows 8.


That's unfortunate, what kind of dac are you using? What kind of audio codecs are you playing?

post #50 of 99

Just using my X-Fi Titanium HD, playing MP3s and FLACs, nothing out of the ordinary.

post #51 of 99
Thread Starter 
Quote:
Originally Posted by Shub-Niggurath View Post

Just using my X-Fi Titanium HD, playing MP3s and FLACs, nothing out of the ordinary.


Aha, see this:

 

 

Quote:
Originally Posted by sonci View Post

sorry to bother,

as I noticed from the screenshot "Creative xFi", are you using a xfi soundcard?

 

because you should know that xfi doesn`t support wasapi for bit perfect playback, it has been discussed a lot at HeadFi, 

you should use ASIO,

 

 

Quote:
Originally Posted by BleaK View Post


No I don't have Creative xFi, that screenshot is taken by the author of the plugin used as only demonstration :)

 

 

Your problem is that X-FI soundcard doesn't support wasapi. I think this is a rare occurence in soundcards, none the less unfortunate.

post #52 of 99

Oh. Well that's stupid frown.gif

Thanks for pointing it out though.

post #53 of 99
Quote:
Originally Posted by Shub-Niggurath View Post

I've installed the plugin, and when I try to play any file, it plays the first split second and then stops. The app doesn't crash or anything, it just stops playing after <1 second. I can always double-click on the track again with the same result.
I just uninstalled Winamp, made sure its folder no longer existed, downloaded it from winamp.com, reinstalled it, then reinstalled this Maiko plugin, same result.
Note I typically remove a bunch of useless things from my Winamp install, but I shouldn't think it would cause a problem. Am I doing something wrong? smily_headphones1.gif I have to say that first split second of playback sounds really nice compared to the default DirectSound plugin!

Edit: I tried enabling Maiko's exclusive mode. Result: instead of playing for <1 second and stopping, it plays the same <1 second of the file in a loop.
I also checked the option in the settings that tell Maiko to release the device from exclusive mode and reclaim it when needed, and it worked. Then I set Winamp back to using DirectSound just to compare the sound, then set it back to Maiko (same settings -- exclusive + release when not needed) and it's broken again frown.gif

I had the same problem with my DAC..no sound with Maiko at all except for a fraction of a second..fixed by checking in Maiko configuration "slave to input sample rate when enabled resmple to rate when disabled,hz" Give it a try
post #54 of 99
Quote:
I've installed the plugin, and when I try to play any file, it plays the first split second and then stops. The app doesn't crash or anything, it just stops playing after <1 second. I can always double-click on the track again with the same result.

 

It happened to me too on my Windows 7 x64. It's a buffer issue ; you can fix it in the plugin settings (client buffer size in milliseconds / client invalidate & reload / genuine latency formula).

Try to raise the buffer to let's say 400 or 500 ms (for a start) and click client invalidate & reload. Then try lower values or even 0 (auto buffer). Click client invalidate & reload each time you enter a new value.

 

BTW my soundcard default settings (Windows) are 24bit / 44KHz.

post #55 of 99

Thanks to the OP! Great step by step tutorial.

Quote:
Originally Posted by Bboy500 View Post

It doesn't play my song after I do this.
They play for about half a second and stop.
Any help?
Edit: Fixed it. had to change my audio settings to 24/96 in windows.....
but now I have a new problem. the songs now skip for about .1 seconds in random places throughout the entire song. All my songs are doing this. Any fix for this?
Edit: Fixed again. Had to turn my power options into "High Performance"
Hopefully if anyone has any problems with the above they'll read this.

 

And thanks to you too, fixed the issues that I was having!

post #56 of 99
Thread Starter 
Quote:
Originally Posted by Shub-Niggurath View Post

Oh. Well that's stupid frown.gif

Thanks for pointing it out though.


Yeah I know, sorry about that mate :/

 

Quote:
Originally Posted by Ben Gunn View Post

 

It happened to me too on my Windows 7 x64. It's a buffer issue ; you can fix it in the plugin settings (client buffer size in milliseconds / client invalidate & reload / genuine latency formula).

Try to raise the buffer to let's say 400 or 500 ms (for a start) and click client invalidate & reload. Then try lower values or even 0 (auto buffer). Click client invalidate & reload each time you enter a new value.

 

BTW my soundcard default settings (Windows) are 24bit / 44KHz.

 

A great tip right here!

 

Quote:
Originally Posted by Angelbelow View Post

Thanks to the OP! Great step by step tutorial.

 

Cheers! beerchug.gif

post #57 of 99
Quote:
Originally Posted by Ben Gunn View Post

 

It happened to me too on my Windows 7 x64. It's a buffer issue ; you can fix it in the plugin settings (client buffer size in milliseconds / client invalidate & reload / genuine latency formula).

Try to raise the buffer to let's say 400 or 500 ms (for a start) and click client invalidate & reload. Then try lower values or even 0 (auto buffer). Click client invalidate & reload each time you enter a new value.

 

BTW my soundcard default settings (Windows) are 24bit / 44KHz.


Messing with the buffer setting fixed it for me, thanks so much!

post #58 of 99

Iä ! Iä ! Ftaghn ! wink.gif
 

post #59 of 99

Thanks a bunch for your guide.  I downloaded both components last night (Winamp and the mentioned Winaspi driver), but ended up staying up too late to configure it.  Thanks to your guide, it took me less than 5 minutes to get it up and running.  Thank you!

post #60 of 99
Thread Starter 
Quote:
Originally Posted by wje View Post

Thanks a bunch for your guide.  I downloaded both components last night (Winamp and the mentioned Winaspi driver), but ended up staying up too late to configure it.  Thanks to your guide, it took me less than 5 minutes to get it up and running.  Thank you!


Thank you for your kind words! smily_headphones1.gif

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Computer Audio
Head-Fi.org › Forums › Equipment Forums › Computer Audio › A short (audiophile) guide to Winamp (/w Maiko WASAPI)