Head-Fi.org › Forums › Equipment Forums › Portable Headphone Amps › I have done something very, very stupid to my new E11
New Posts  All Forums:Forum Nav:

I have done something very, very stupid to my new E11

post #1 of 3
Thread Starter 

I plugged my E11 into my computer, and I started listening to music, from my computer, through the E11. Following this, a very stupid idea came into my head: "Oh, wouldn't it be great if I charged it, while listening to music from my computer? That way I won't waste its battery life, allowing me to use it for longer when I listen to it on the go." 

 

As soon as I plugged in the USB charger, while still listening to music at the same time, a decent-sized spark flew out of the E11, followed by a chemical-like burning scent that just screamed "fried electronics."

 

I am used to being able to use electronic devices while charging them; clearly, this is not the case with portable amps. I am not tech-savvy by any stretch of the imagination (as if it weren't already obvious by now), and so I ask the following: Is there anything I can do to fix it? Or is it done completely?

post #2 of 3

You most certainly destroyed your device. "that smell" is the death of all joy. I'm sorry for your loss. I have a different problem with my e11. The line in got tugged in a violent manner, disconnecting the inPut from the circuit board. I need to find a way to take it apart to reconnect it. Soldering time.

post #3 of 3
E11 uses a floating ground (IIRC) that can't be used when charging as it will short the actual ground channel from the USB power supply. The amp itself is supposed to shut itself down as soon as an USB power is plugged in. You might want to contact FiiO about the situation and maybe they can help you.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Headphone Amps
Head-Fi.org › Forums › Equipment Forums › Portable Headphone Amps › I have done something very, very stupid to my new E11