Head-Fi.org › Forums › Equipment Forums › Headphones (full-size) › Sennheiser PC 360 hissing sound when mic plugged in
New Posts  All Forums:Forum Nav:

Sennheiser PC 360 hissing sound when mic plugged in

post #1 of 3
Thread Starter 

I have Sennhieser PC 360 and creative x-fi fatal1ty sound card.  Have an odd problem with the mic.  If you're not familiar with this headset it has one of those mics that come down and auto-mute when put up.  The problem I have is when I have the mic plugged in, and the mic is up and in the muted position there is a hissing sound coming from the headphones.  When I lower the mic for use the hissing goes away.  When I mute the mic in the control panel the hissing goes away.  When I unplug the mic the hissing goes away.   I'm thinking something is defective and I'm tempted to start returning items here, but I'm hoping someone can help me before I have to go there.

post #2 of 3

Hi there. I am wondering if maybe the mechanism that is supposed to shut the mic off when in the "up" position is not being fully engaged, if at all.  Maybe try putting the mic up a little quicker, or make sure it is up all the way...?  Other than that, I would look into the card.  It may have issues like this that others who have experience in this card can chime in and help out.

 

When you do get the issue resolved, please give us an update on what you tried, did, & didn't work for you. That way others will potentially benefit from your experience.

 

 

 

Thanks, and hope you get it worked out,

Matt

post #3 of 3
Thread Starter 

Thanks for the reply.  I ended up returning the headphones and getting some without a mic.  Thanks for trying though.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Headphones (full-size)
Head-Fi.org › Forums › Equipment Forums › Headphones (full-size) › Sennheiser PC 360 hissing sound when mic plugged in