Head-Fi.org › Forums › Equipment Forums › Headphone Amps (full-size) › Pioneer SX-850 hiss
New Posts  All Forums:Forum Nav:

Pioneer SX-850 hiss

post #1 of 4
Thread Starter 

I have an SX-850 and it sounds phenomenal but it hisses, even at low volumes. I noticed that my dad's much more modern Kenwood power amp does this too. I was wondering if this is just how it's supposed to be or if I should be looking out for something broken inside the receiver. I've opened up the 850 and visually inspected all the caps and resistors but everything looks great. 

 

Any help would be appreciated. Thanks.

post #2 of 4

Do you have the -20db button engaged. It's a must for anything other than orthos. I consider it an "impedance button" for headphones. Everything hisses out of my pioneers headphone out other than my he-6. Even a pair of k340s which I use to have even hissed out of it. The thing with the pioneer receiver back in the day is, the headphone out doesn't just push out miliwatts. The headphone out of those actually pushes out 5-10 full watts(depending on the model). That's what the -20db button is for on a lot of these vintage receivers. It's basically a headphone button.

post #3 of 4
Thread Starter 
Quote:
Originally Posted by moodyrn View Post

Do you have the -20db button engaged. It's a must for anything other than orthos. I consider it an "impedance button" for headphones. Everything hisses out of my pioneers headphone out other than my he-6. Even a pair of k340s which I use to have even hissed out of it. The thing with the pioneer receiver back in the day is, the headphone out doesn't just push out miliwatts. The headphone out of those actually pushes out 5-10 full watts(depending on the model). That's what the -20db button is for on a lot of these vintage receivers. It's basically a headphone button.


Hmm that might be it. I've been using my K702s w/o the mute switch. I couldn't turn the knob past 9 o'clock before I felt like I was going to go deaf. I'll try it with the mute switch on tonight.  

 

Thanks, moodryn! 

post #4 of 4
Thread Starter 

So I tried to play music with the mute switch and without it and it sounded exactly the same. There's the same amount of hiss. There's no drop in hissing when switching the mute switch on and off. confused_face.gif

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Headphone Amps (full-size)
Head-Fi.org › Forums › Equipment Forums › Headphone Amps (full-size) › Pioneer SX-850 hiss