Head-Fi.org › Forums › Equipment Forums › Portable Headphone Amps › JDSLabs C421 Preorder is live...
New Posts  All Forums:Forum Nav:

JDSLabs C421 Preorder is live... - Page 5

post #61 of 692

Nevermind...

 

It seems it's picking up this interference/crackling because I'M CHARGING my Archos 7.

(i.e. the AC adapter is connected... when I disconnect it and touch the amp, it stops with the interference/crackling sound...)

 

Not sure if it's supposed to do that though... and I'm not sure if it's the enclosure.

At least with the Altoids tin can, this doesn't happen.

 

Have any of you tried charging your PMPs while using the amp and see if you get

the same thing? (the crackling sound is similar to when a TRS input in a guitar to an amp is messed up

or something like that...)

 

 

Thanks.

 

 

P.S. Even with a cold, I can actually perceive a difference in sound/volume against the Cmoy 2.03!

But I'll give more impressions when I get better! :-(

post #62 of 692
I haven't had any noise issues while charging and listening at the same time.

While I'm still without my MS1is, this amp makes the HTF600s quite enjoyable (and I'm not really a fan otherwise), and makes the M6es that I just got my hands on sound fantastic (not that they need any sort of amping, but hey). I do get some R2-D2 noises with the IEMs occasionally - I can't actually remember doing what now - but I've read that's not out of the norm with IEMs, I assume due to the sensitivity.
post #63 of 692

How do c421 work with SRH940?

Is there any other amp that matches the quality at the price?

post #64 of 692

I haven't tested the c421 with my Shures but if it produces the bright output it produces with my "bassy" Denons, that will not be a good pairing... BTW, I do like the Shur 940s with the original 2.03 Cmoy!

post #65 of 692

Hi all. My c421 unit's LED won't turn off after the first time charging until now. The LED is blue all the time. It shouldn't be like that, right?

post #66 of 692

Quote:
Originally Posted by idunnosoSTFU View Post

Hi all. My c421 unit's LED won't turn off after the first time charging until now. The LED is blue all the time. It shouldn't be like that, right?


That sounds normal, assuming you left the amp plugged into the USB port. The manual showing the different LED status can be found at http://www.jdslabs.com/pdf/Instructions_C421x100.pdf

post #67 of 692

Except that mine will stay blue even unplugged until the battery is dead. D:

post #68 of 692

Quote:
Originally Posted by idunnosoSTFU View Post

Except that mine will stay blue even unplugged until the battery is dead. D:

 

Okay, mine doesn't do that. Shoot John at JDS Labs an email, he'll be able to help sort things out for you.
 

 

post #69 of 692
Quote:
Originally Posted by tmd24 View Post

 

Okay, mine doesn't do that. Shoot John at JDS Labs an email, he'll be able to help sort things out for you.
 

 

 

Allright, will do. Thanks for the fast reply. :D

post #70 of 692

Hello guys.

 

So how many hours of play time have you gotten from your c421s?!?

I forgot when I was testing to take them into consideration!! (ooopsss)

 

I believe that charging while playing takes like 3 and a half hours to fully charge

(i.e. amber light to go off)

 

If I'm not mistaken, I think I got like 12 to 13 hours playing time, gain Low, Bass Boost

mostly off, mid volumes.... not sure how it will be rated.

 

 

P.S. Seems to sound better to my ears now... not sure if I'm getting used to them or if the amp

needed time to "open" up. BTW, bass boost On, some Deadmau5 + Denon D5000 makes the cups

vibrate... hard!! Had never experienced that!!!

post #71 of 692

bah, I've been meaning to test them with my D2000's, but this week (finals week) has been kicking my ass. lol. I've probably only been able to squeeze like 2-3 hours on the c421 so far. :(

 
post #72 of 692

subscribed

 

post #73 of 692
Quote:
Originally Posted by PANGES View Post

bah, I've been meaning to test them with my D2000's, but this week (finals week) has been kicking my ass. lol. I've probably only been able to squeeze like 2-3 hours on the c421 so far. :(

 


Good luck on your finals!!! :-p

 

And yep... it seems the battery only goes for like 10-12 hours...

It's not bad... but their Cmoy lasted almost 20 on the same setting (i.e. I use my player+amp continuosly at work for up to 10 hours a day...)

 

Still find the amp a bit bright so I think this is part of the "sound signature" with the opamp I

bought it. It's not bad though and it's driving my D5000s well! Right now listening to Fiona Apple's Extraordinary Machine... great record

and everything sounds crisp and clear with good instrument separation. Bass response is really good too.

 

BTW, put up some Deadmau5 again this time with bass boost... uffff... I've never felt headphones vibrating this mad

without producing any kind of distortion whatsoever... not sure if it's due to the capability of the amp, the headphones or both!
 

 

post #74 of 692

Now that I'm feeling better (and have vacation days coming up :p ) I'll be comparing the c421 and

the NuForce Icon Mobile...

 

Why the Icon Mobile?

Because I believe this one is also a bright amp and it should be capable of driving my Denons...

 

Anyone has compared the c421 to any other amps?

 

post #75 of 692

5 days w/out and new praise GOOD OR BAD?

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Headphone Amps
Head-Fi.org › Forums › Equipment Forums › Portable Headphone Amps › JDSLabs C421 Preorder is live...