Head-Fi.org › Forums › Equipment Forums › Portable Headphone Amps › [Impression] FiiO E10
New Posts  All Forums:Forum Nav:

[Impression] FiiO E10 - Page 86

post #1276 of 1286
Quote:
Originally Posted by PurpleAngel View Post
 

Any recent news on the E10K?

Any resent news on the FiiO E10K?

post #1277 of 1286
Thread Starter 
Quote:
Originally Posted by PurpleAngel View Post
 

Any resent news on the FiiO E10K?

 

Better ask FiiO directly. I have tested the prototype and I can say I am quite happy with it, which I think it is a more mature sounding product compared to the original E10. It is not a revolution but it is an evolution.

post #1278 of 1286

I'm guessing FiiO will not be releasing any info on the new E10K until they have it in production.

Just hate the wait.

post #1279 of 1286

Yup, just have to wait for the official announcement of announcement.

post #1280 of 1286
Thread Starter 

Well, mostly they are trying to avoid giving the impression of hunger marketing. So now they prefer to announce when the products is fully ready to hit the market.

post #1281 of 1286
Quote:
Originally Posted by ClieOS View Post
 

Well, mostly they are trying to avoid giving the impression of hunger marketing. So now they prefer to announce when the products is fully ready to hit the market.

 

I have no want or need to buy the new E10K, but part of me really want to see reviews on it (when it on the market).

post #1282 of 1286

The new Fiio E10K is now listed on FiiO website

http://fiio.net/products/index.aspx?ID=100000059783139&MenuID=105026003

post #1283 of 1286
Quote:
Originally Posted by PurpleAngel View Post

The new Fiio E10K is now listed on FiiO website
http://fiio.net/products/index.aspx?ID=100000059783139&MenuID=105026003
For its category It looks like they took an already nice gear (I have) and made it better.
post #1284 of 1286
Thread Starter 
Quote:
Originally Posted by Saraguie View Post


For its category It looks like they took an already nice gear (I have) and made it better.

 

Yes, that's exactly what E10K is about.

post #1285 of 1286

Hello everyone, I've spent the last day trying to search for a solution over the internet and I can't find one with my situation and I came across this forum and it seems some people may have had a similar issue.

I just bought a new pair of Kraken Pro Headphones and it sounds amazing. However, whenever it is plugged into the Headphone Output of my Fiio E10 while the Mic is connected to the Mic input of my PC (mobo) it gives a buzzing noise regardless of volume setting on either the Fiio and PC OR Default sound selection in windows settings for that matter.

Whenever I unplug the Mic the noise completely disappears, however I want to use my Headphone DAC/AMP while the Mic is plugged in. 
Another thing to note, if I completely do not use the Fiio E10 and just plug in the headphones directly to the PC's mic input and sound output everything is fine. (So it can't be the Headphones? Maybe its the E10 causing the issue)

Some more information: 
- If the PC is shutoff but still powered I still hear the buzzing noise. 
- Used a different PC (Laptop) I get the same but it is white noise instead of buzzing
- I've used the same setup with a different pair of Headphones (Steelseries H7) and it is fine. (But wait I thought the headphones are not the problem?)
- If I plug my Fiio E10 to a different usb port I get whitenoise instead of the buzzing
- If I use the line out instead of the headphone out of the E10 It works fine. But then it is not using the AMP and I cannot use volume or bass boost on the E10.

I suspect that my kraken headphones are picking up electrical interference going around between the sound output via the Fiio E10's headphone AMP, mobo, and mic input.

I am trying to determine what exactly is causing the noise so that I can replace that component but due to the combinations that I listed above it can be anything.

Unfortunately I do not have another DAC/AMP to test if that is causing the issue. 

Thanks for reading and I hope someone has some suggestions on what I can do going forward.

post #1286 of 1286
Thread Starter 

The problem is probably caused by the different ground of the two devices (the E10's USB and the mic's port) shorting out in the headphones' internal wiring. Other headphone's mic can have a separated ground wiring and therefore doesn't have any problem. Anyway, I don't think there is a fix if that's the problem.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Headphone Amps
Head-Fi.org › Forums › Equipment Forums › Portable Headphone Amps › [Impression] FiiO E10