Head-Fi.org › Forums › Equipment Forums › Computer Audio › ReClock: skipping after first second
New Posts  All Forums:Forum Nav:

ReClock: skipping after first second

post #1 of 4
Thread Starter 

Posting here as a fellow head-fier turned me on to this great rendering engine, and now I'm hooked.  To my ears it clearly is better than JRiver but with a nasty caveat:

 

Repost from: http://forum.slysoft.com/showthread.php?t=49944

 

I am using ReClock as a means of providing WASAPI for KMPlayer on Windows 7 - using only for playing 2 channel audio into my headphone system.  

 
It sounds wonderful, but there is a persistent problem I can not seem to fix... exactly one second after each song starts, there is a skip of maybe 100ms or so.  I've tried songs in FLAC, APE, MP3... doesn't matter.  
 
The crazy thing is if I instantly push next song, pause, wait several seconds, then unpause, it still does it!  But once it does it I can skip around the song without any skips whatsoever, even cueing back to the beginning of the song.
 
I've spent maybe 4 hours scouring the web, this forum, etc, and everything related to drops/skips for ReClock is talking either about video or about something that happens randomly/repeatedly.  This only happens once per song and it happens every single time.   Changing the duration of the sound buffer or the % latency of PCM/Bitstream has no effect.  I've tried both KMPlayer and PotPlayer and the effect happens in both, so it appears to be an issue with ReClock.
 
Included is a picture of my settings.
settings.jpg

Edited by bobeau - 9/29/11 at 4:16pm
post #2 of 4

Hi bobeau,

 

I see you are having some problems with ReClock.  I trust you have tried to increase the buffer and latency already.

 

I have never had that particular problem with reclock but you can also try a couple of other things.

 

One is go to the Start menu and right mouse click on ReClock then select properties-->compatibility and try Window Vista or maybe XP which should open up the Kernel streaming function.  When Reclock starts switch to Kernel streaming

 

Two is right mouse button in the task bar at the bottom and open up the Task Manager, under processes find reclock and set priority to real-time.

 

I don't know if that will fix it but its worth a shot to change the priority at least as well as changing the buffer and latency. 

 

Good Luck!

post #3 of 4
Thread Starter 

Thanks!

 

So good news, got it working.  Oddly enough it happened by searching for info on another player to try, xmplay, and saw that people were having issues with the onboard audio (Realtek) and that a driver update fixed what ailed them.

 

So I gave it a shot and reset settings, didn't work at first.  Rebooted, didn't work.  A bit bummed I decided to click on "clean-up manual frame rates database", then "clean-up video clock timings database".  That did it!

 

My audiophilleo 2 comes in today, have a 96k vinyl rip of The Wall and 88k version of Beck's Sea Change that I can't wait to try out.  This renderer definitely kicks things up a solid notch, thanks for turning me on to it.

post #4 of 4

Great!

 

Glad you got everything sorted out!

 

Don't forget to post impressions of A2 and keep us posted on the Metrum.

 

 

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Computer Audio
Head-Fi.org › Forums › Equipment Forums › Computer Audio › ReClock: skipping after first second