Head-Fi.org › Forums › Equipment Forums › Computer Audio › I'm having problems with ASIO and foobar ! Can someone help me out ?
New Posts  All Forums:Forum Nav:

I'm having problems with ASIO and foobar ! Can someone help me out ? - Page 2

post #16 of 40
Quote:
Originally Posted by AllsWell View Post

Ok;

 

1st -  I downloaded the WASAPI Output Support 2.1 from Foobar2000 website.

2nd-  Then I put the wasapi dll into foobar's component folder and restarted foobar.

3rd-   I then went to preferences/ output and selected my device which is my Speaker: USB Sound Blaster HD.

4th-   Then I pressed play and got this error: "Unrecoverable playback error: Unsupported stream format: 44100 Hz / 16-bit / 2 channels"

 

I also tried all the other wasapi output device options but still nothing.


 

Hi, I too tried working foobar with Asio or asio4all and the media played with no sound coming out from my computer. I also tried WASAPI and I repeat the steps above exactly and I also receive the same error as above. What is going on, why is all direct bit streaming program not working for my computer. I am using a brand ASUS g73sw laptop on window 7 with onboard realtek HD audio. I am planning to get a dac soon however i am trying to maximize my onboard soundcard before doing that.. 

Any one can provide some insights? 

post #17 of 40

Wow, something is definitely going on...

 

What version of Foobar are you guys using?  My last install (update) was 1.1.7...I know during recent updates it gives you the options on installation for various users (and automatic plug-in updates).  If you are new to Foobar it gets a bit confusing.  For various users all your components go to the "roaming/app data "etc folder, whereas for a single-user all components are stored like before in the Foobar2000 folder in program files and you manually have to update the plug-ins.

 

Before the new installation options, you would just install Foobar and drop the different .dlls in the components folder and be done with it no matter what OS was being used.

 

I would try a clean install of Foobar and use the "single user" (sorry, the exact words escape me").  That way all your components stay in program files (Foobar2000) and you just put the .dlls in that folder.  I would at least start from there and work my way to isolate the problems and get the "outputs" (WASAPI, KS, ASIO etc.) to work


Edited by HeatFan12 - 9/16/11 at 7:31am
post #18 of 40

I don't really use foobar, but I just tried setting up WASAPI, it worked and this is what the configuration looks like in my case:

 

foobar > preferences >

output: WASAPI

output data format: 24 bit

no dither

 

w7 > playback devices > r.click the device you're using to output the sound and click properties > advanced tab >

default format: 24 bit, 44100 Hz

exclusive mode: both boxes ticked

 

edit: Without the "Allow applications to take exclusive control of this device" box ticked I get the same error when trying to output through WASAPI.


Edited by fufula - 9/16/11 at 7:37am
post #19 of 40
Quote:
Originally Posted by fufula View Post

I don't really use foobar, but I just tried setting up WASAPI, it worked and this is what the configuration looks like in my case:

 

foobar > preferences >

output: WASAPI

output data format: 24 bit

no dither

 

w7 > playback devices > r.click the device you're using to output the sound and click properties > advanced tab >

default format: 24 bit, 44100 Hz

exclusive mode: both boxes ticked

 

edit: Without the "Allow applications to take exclusive control of this device" box ticked I get the same error when trying to output through WASAPI.


 

Thank you so much .. that completely fix my problem... due to ASIO requirement i unticked the "allow application to take exclusive control..... " options .. and the is the source of problem for my WASAPI application... 
the wasapi add-on definitely improved my Flac file sound quality .. mids are much cleaner, bass are tighter and highs are sharp 
 

post #20 of 40
Thread Starter 
Quote:
Originally Posted by fufula View Post

I don't really use foobar, but I just tried setting up WASAPI, it worked and this is what the configuration looks like in my case:

 

foobar > preferences >

output: WASAPI

output data format: 24 bit

no dither

 

w7 > playback devices > r.click the device you're using to output the sound and click properties > advanced tab >

default format: 24 bit, 44100 Hz

exclusive mode: both boxes ticked

 

edit: Without the "Allow applications to take exclusive control of this device" box ticked I get the same error when trying to output through WASAPI.

 

I tried this, exactly like you said but still nothing. I don't get it. I tried WASAPI and ASIO, I also tried the "Allow applications to take exclusive control of this device", on and off, multiple combinations, still nothing.
 

 



Quote:
Originally Posted by HeatFan12 View Post

I would try a clean install of Foobar and use the "single user" (sorry, the exact words escape me").  That way all your components stay in program files (Foobar2000) and you just put the .dlls in that folder.  I would at least start from there and work my way to isolate the problems and get the "outputs" (WASAPI, KS, ASIO etc.) to work


Yup, tried that too. Did a clean install, and have been storring all the .dll files in the components folder.

The version of Foobar2000 that im using is 1.1.7.

 

I should've mentioned that I'm using windows 7 64bit. ( I don't know if that matters in this case, at this point .... maybe )

 

This is weird.


Edited by AllsWell - 9/16/11 at 11:07am
post #21 of 40
Quote:
Originally Posted by alch View Post

Thank you so much .. that completely fix my problem... due to ASIO requirement i unticked the "allow application to take exclusive control..... " options .. and the is the source of problem for my WASAPI application... 
the wasapi add-on definitely improved my Flac file sound quality .. mids are much cleaner, bass are tighter and highs are sharp


Foobar won't work with WASAPI unless the application is allowed to take exclusive control when in WASAPI mode.

 

I've read on some other sites that people say to uncheck it if bitperfect output isn't working properly, but I read a lot of contradicting statements (esp for 1.1.6 and 1.1.7), that Foobar won't allow bitperfect unless it has exclusive control.

 

AllsWells: Hmm.  When you play back a file in Foobar, do you get a window that pops up giving you an error message immediately, or do you get no sound, but still see playback happening in the spectrum/oscilloscope visualizer?

post #22 of 40

AllsWell, I'm using W7x64 as well. I'd try both WASAPI and ASIO (not ASIO4ALL) in a bunch of other players and see what happens. If they still don't work, it clearly means something other than foobar is at fault. I'd then try cleaning and reinstalling the sound card drivers from scratch.

post #23 of 40
Thread Starter 
Quote:
Originally Posted by Elysian View Post

 

AllsWells: Hmm.  When you play back a file in Foobar, do you get a window that pops up giving you an error message immediately, or do you get no sound, but still see playback happening in the spectrum/oscilloscope visualizer?


A notification with the error comes up right away as soon as I pres play.

 


 

Quote:
Originally Posted by fufula View Post

AllsWell, I'm using W7x64 as well. I'd try both WASAPI and ASIO (not ASIO4ALL) in a bunch of other players and see what happens. If they still don't work, it clearly means something other than foobar is at fault. I'd then try cleaning and reinstalling the sound card drivers from scratch.


I haven't tried using anything else before other than foobar, so I'm not too familiar with using something else. I'll give it a shot with winamp.

 

post #24 of 40
Thread Starter 

Ok.... WASAPI (Maiko Wasapi Output plugin version 0.35) is WORKING with Winamp 5.621.... odd.

 

Well at least I think it is... Music is playing and I believe I hear a difference ( maybe even a bit of a placebo effect due to excitement and anticipation)

Someone check out these screen shots and confirm this for me lol.

 

Winamp Preferences.jpg

 

 

Maiko Wasap Output settings.jpg

 

 

maiko bar.jpg

 

So if it is working... what does it all mean man ?? (Why didn't Foobar2000 cooperate with me)

 

 


Edited by AllsWell - 9/16/11 at 12:41pm
post #25 of 40

Allswell, if you got Maiko to work in Winamp (been following it since dev.) then there is probably a setting that has been overlooked in Foo....Can you control windoze vol with winamp?

 

Might as well throw in Otochan .67 (ASIO) in winamp and try to use with ASIO4ALL since that was your original intent to see if it works--

 

http://otachan.com/out_asio(dll).html


Edited by HeatFan12 - 9/16/11 at 1:23pm
post #26 of 40
Thread Starter 

What do you mean if I can control windows' volume with winamp ?? I don't understand.

post #27 of 40
Quote:
Originally Posted by AllsWell View Post

What do you mean if I can control windows' volume with winamp ?? I don't understand.



When you move the windows volume slider, does the volume change?  Right now I'm using Winamp with ASIO4ALL (Otochan asio) w/ a dac and when I move my volume slider, nothing happens.  The media player has taken control of my dac, telling windows sound not to interfere (bit-perfect)...

 

 

Clipboard01.jpg

 

post #28 of 40
Thread Starter 

Yea when I move the windows volume slider the volume changes.... damn, i guess. How do i get it "bit perfect" like you have it ? (except using wasapi... or i could download otochan asio after ) Yea I'm using a dac as well.

post #29 of 40

Yes, I linked otochan .67 earlier.  You can have as many renderers installed and it won't matter.  You use which one you prefer, does not interfere.  Since you were originally trying ASIO4ALL, that's why I thought maybe you can give it shot with winamp and if goes well, then Foo would be next...

post #30 of 40

Here you go, using asio w/ winamp

 

 

double click highlited and you'll get to:

 

Clipboard01.jpg

 

 

 

 

this--- Make sure ASIO4ALL is showing in the drop down

 

 

 

Clipboard02.jpg

 

 

 

Here is the ASIO4ALL console (should have a "pause" symbol when in active in the taskbar)

 

 

 

Clipboard03.jpg

 

 

 

 

If all goes well then you'll get the "play" symbol in the taskbar

 

 

Clipboard04.jpg

 

 

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Computer Audio
Head-Fi.org › Forums › Equipment Forums › Computer Audio › I'm having problems with ASIO and foobar ! Can someone help me out ?