Head-Fi.org › Forums › Equipment Forums › Headphones (full-size) › Ultrasone Fan Club! (Roll Call)
New Posts  All Forums:Forum Nav:

Ultrasone Fan Club! (Roll Call) - Page 108

post #1606 of 2063
Quote:
Originally Posted by LazBro123 View Post

Oh okay. I just found out the weirdest thing... When I put the EQ to 0 on the E11, there is little to none distortion. When I use the bass boost, there is distortion. Can the bass boost be the problem?

 

Yeah you really need to try with a different set of headphones so you can findout if its the E11 and/or bass boost distorting or the headphones.

post #1607 of 2063
Quote:
Originally Posted by LazBro123 View Post

Oh okay. I just found out the weirdest thing... When I put the EQ to 0 on the E11, there is little to none distortion. When I use the bass boost, there is distortion. Can the bass boost be the problem?

Yes too much equalizer boost can clip the signal (this isn't quite the same as the amplifier going into clipping) - if it isn't distorting with the EQ out and at neutral levels, it should be okay.
post #1608 of 2063
Quote:
Originally Posted by obobskivich View Post


Yes too much equalizer boost can clip the signal (this isn't quite the same as the amplifier going into clipping) - if it isn't distorting with the EQ out and at neutral levels, it should be okay.

thats great to hear. Wow I'm relieved lol. I'm really loving my PRO 900 now. Thanks everyone! biggrin.gif

post #1609 of 2063

whats next step up from HFi 580? I want more bass!

post #1610 of 2063
Quote:
Originally Posted by Illbetheone View Post

whats next step up from HFi 580? I want more bass!


I think the HFI-580 is about as bassy as it gets. If you want significantly more bass, I would get a Z2 amp or at least something with a good EQ bass boost. The PRO 900 is a huge upgrade overall, though. I've never heard the Sony XB1000 myself, but that's another one to look into.

post #1611 of 2063
Quote:
Originally Posted by macrocheesium View Post


I think the HFI-580 is about as bassy as it gets. If you want significantly more bass, I would get a Z2 amp or at least something with a good EQ bass boost. The PRO 900 is a huge upgrade overall, though. I've never heard the Sony XB1000 myself, but that's another one to look into.

Had the Pro 900 and the XB1000.. the Sony was unique in that it would create a suction cup like feeling on the ear drums - you could literally feel the bass vibrations (I did't think it was all that great for my hearing but it was kind of fun). Besides that the XB1000s were nothing special for the price (i think i paid $300), if I were to pick between the Pro900 and the XB1000 I would be the Pro 900, but that is only because they are much more portable; bass/audio wise the XB's have a lot of sub bass and mid bass and its a all around better experience than the 900s for home use.. I think the XB1000s were discontinued though so it may be hard to find.

post #1612 of 2063
Quote:
Originally Posted by Ahzari View Post

Had the Pro 900 and the XB1000.. the Sony was unique in that it would create a suction cup like feeling on the ear drums - you could literally feel the bass vibrations (I did't think it was all that great for my hearing but it was kind of fun). Besides that the XB1000s were nothing special for the price (i think i paid $300), if I were to pick between the Pro900 and the XB1000 I would be the Pro 900, but that is only because they are much more portable; bass/audio wise the XB's have a lot of sub bass and mid bass and its a all around better experience than the 900s for home use.. I think the XB1000s were discontinued though so it may be hard to find.

 

That doesn't look to be the case... there are quite a few on Amazon right now under $300. If they are discontinued, there are plenty left.

post #1613 of 2063
Quote:
Originally Posted by macrocheesium View Post

That doesn't look to be the case... there are quite a few on Amazon right now under $300. If they are discontinued, there are plenty left.

They were discontinued a while ago (Sony confirmed this) - Amazon hasn't had stock in ages, and third party sellers are a different matter altogether. There's a big difference between "Amazon has this" and "Amazon Marketplace sellers are offering this."
post #1614 of 2063

In case anyone wants to add to their Ultrasone collection, the Pro 750s dropped to $150 today on Amazon

 

So tempting biggrin.gif

post #1615 of 2063
Quote:
Originally Posted by obobskivich View Post


They were discontinued a while ago (Sony confirmed this) - Amazon hasn't had stock in ages, and third party sellers are a different matter altogether. There's a big difference between "Amazon has this" and "Amazon Marketplace sellers are offering this."


I said that they were "on Amazon". That's too bad, though.

post #1616 of 2063
Thread Starter 
Quote:
Originally Posted by cel4145 View Post

In case anyone wants to add to their Ultrasone collection, the Pro 750s dropped to $150 today on Amazon

 

So tempting biggrin.gif

 

That is a crazy price...And they have not sold out yet?...eek.gif

 

Listening to them right now out of my first Fiio product ever (E07k)--> W8--> Foobar.  Sounding good indeed...A little house as well as DT's A Dramatic Turn Of Events (24-96)...Good times!!

 

Cheers!!!

 

 

1000

post #1617 of 2063
So guys, my pro 900 has come to an end. The right driver is not playing any sound, only if I press down on the earcup, and the left driver has no bass to speak of. What do I do?????? frown.gif
post #1618 of 2063
Quote:
Originally Posted by LazBro123 View Post

So guys, my pro 900 has come to an end. The right driver is not playing any sound, only if I press down on the earcup, and the left driver has no bass to speak of. What do I do?????? frown.gif

That was abrupt and terrible. ph34r.gif Are you sure the cable hasn't come undone from them?
post #1619 of 2063
Quote:
Originally Posted by obobskivich View Post

That was abrupt and terrible. ph34r.gif Are you sure the cable hasn't come undone from them?

lol sorry if I sounded a little harsh smily_headphones1.gif I tried it with multiple cables and nothing is working.
post #1620 of 2063
Quote:
Originally Posted by LazBro123 View Post

lol sorry if I sounded a little harsh smily_headphones1.gif I tried it with multiple cables and nothing is working.

Oh no, you didn't sound harsh - it was abrupt and terrible that they apparently died; since you had gotten them working not long ago.

If it isn't the cable connection, I'd say wait until Ultrasone returns from holiday and see what they have to say.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Headphones (full-size)
Head-Fi.org › Forums › Equipment Forums › Headphones (full-size) › Ultrasone Fan Club! (Roll Call)