Head-Fi.org › Forums › Equipment Forums › Headphones (full-size) › AT M50 not loud?
New Posts  All Forums:Forum Nav:

AT M50 not loud? - Page 2

post #16 of 19
Thread Starter 

all the music i listen to are 320kbs so there not flac but not low quality. i checked the settings and asked a few friends and they agreed it gets loud but not up to unbearable were you have to turn it back down. so im not sure if i should exchange it or wait to burn it in a little. thanks for all the advice so far! i really dig these phones but wish they could go up just a few notches in the volume

post #17 of 19

You should try an ibud or something with less or equal impedance and similar or higher sensitivity, if they can not reach the unbearable volume, then its probably the laptop's fault. Although I highly doubt that because MSI makes good laptops.

post #18 of 19
Thread Starter 

i tried out and compared it to my ipod headphones and the ipod headphones got to an unbearable level while the M50 got to a pretty high but not close to unbearable. The bass is starting to get more defined along with the sound so im thinking maybe after 20 hours of burn in it might** be okay, but im still surprised it sounds underpowered.

post #19 of 19

You would probably benefit from an amp but just to be safe you could return them and ask for a new pair, no?

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Headphones (full-size)
Head-Fi.org › Forums › Equipment Forums › Headphones (full-size) › AT M50 not loud?