Head-Fi.org › Forums › Head-Fi Special Forums › Premier Sponsor Forums and Sponsor Forums › Premier Sponsor Forums › ARCHIVE: Whiplash Audio Premier Sponsor Forum › twag v1 replacement programme. what is going on? PLEASE CONTACT my customer service email address.....
New Posts  All Forums:Forum Nav:

twag v1 replacement programme. what is going on? PLEASE CONTACT my customer service email...  

post #1 of 16
Thread Starter 

i sent my v1 cable back 3 month ago and received 1 reply 3 month ago and i have sent over 20 emails since and get no reply.

Other day i sent email again then i asked my friend to send email also asking to buy a cable and for prices and he received a reply after 2 hour and i still not get a reply so do whiplash now only reply to people when they are getting money from and not reply to customers who have paid them already.

 

have anyone else been having this problem with them?

 

update Oct 7- still no reply


Edited by HarryPotter - 10/7/11 at 10:57am
post #2 of 16

http://www.head-fi.org/forum/thread/528905/my-apologies-please-read

 

Yep.  Craig is a good guy and all, but unfortunately, this seems pretty standard.  He'll probably PM you after reading this post (if he hasn't already.)  That seems to be the M.O.

post #3 of 16
Quote:
Originally Posted by HarryPotter View Post

i sent my v1 cable back 3 month ago and received 1 reply 3 month ago and i have sent over 20 emails since and get no reply.

other day i sent email again then i asked my friend to send email also asking to buy a cable and for prices and he received a reply after 2 hours and i still not reveived a reply so do whiplash now only reply to people when they are getting money from and not reply to customers who have paid them already.

 

have anyone else been having this problem with them?

Same problem tha you, IEM replaca cable purchased on april 2011, several email without reply... No news 

I'm very disapointed of this mean to treat customers. It's a shame !
 

 

post #4 of 16
Quote:
Originally Posted by davidsylvian38 View Post



Same problem tha you, IEM replace cable purchased on april 2011, several email without reply... No news 

I'm very disapointed of this mean to treat customers. It's a shame !
 

 



 

post #5 of 16
Yea quite same problem here. Ordered a twag v2 two weeks ago and still no news at all.. going to pm Craig again later.

I understand the sellers can be busy but a complete ignore shouldn't be the way things are done. I would be happy if I were assigned a scheduled shipping date even if it came to be one month after... well 3 month is too bad for me no matter what.. xD
post #6 of 16

same problem with you guys.. sent my v1 back for repair, and they told me that I would be receiving a v2 in a few weeks.. the stock has came in for many weeks now, and I havent received mine.. Sent a couple of emails but I got no reply either too. Very disappointing. I've paid for my cable afterall..

post #7 of 16
Thread Starter 
Quote:
Originally Posted by Darwin022 View Post

http://www.head-fi.org/forum/thread/528905/my-apologies-please-read

 

Yep.  Craig is a good guy and all, but unfortunately, this seems pretty standard.  He'll probably PM you after reading this post (if he hasn't already.)  That seems to be the M.O.



i have not got any pm from him and i sent another email after posting this and no reply and i also got my friend to email them again about a purchase and he got a reply withing a day.

so this shows that they are reading all the messages and choosing which they reply to and dont and are only replying to those they expect to get a order from and not those who have already paid for our order or are waiting for our cables.

just shows what kind of greedy company that does not care about it's existing customers whiplash has become.

first they rip me of with a copper cable saying it is silver and now after saying they will replace this cable they will not reply to my emails!

 

post #8 of 16
Thread Starter 

send them a email about making a new order and i will bet everyone get's a reply but send them an email about an order you place'd month's ago and you will not and people actualy call this a good company or graig a good guy?

post #9 of 16

Craig just lost his main supplier of his flagship wire TWag, he has been jumping through hoops and putting his entire company at jeopardy in order to continue the production of this product.  You are all giving him a bad rap, I think that this is something you should discuss with him.  How difficult is it to call or email customer service.  I have never had any issues with Craig and look at what he just did by staking his entire company on getting this wire and maybe even offering it to the public for us DIYers.  

 

Craig is my friend and I do not think he would just accept money and run away.  Put yourself in his shoes, if you do not want the product then ask for a refund and you will get your money back!

post #10 of 16

I think that the passing of Lee from Cryo-Parts/Locus-Design and the effects from this have put a huge hold on everything, rest in peace Lee, but give the guy a break look at what he just posted.  I guarantee you will all get your wires or products soon, seriously I have faith in Craig and Whiplash.

post #11 of 16

HarryPotter,

 

Can you please PM me? I don't see any emails that I'm missing. So maybe I'm not getting them? 

 

Please PM me. 

 

Craig. 

post #12 of 16

PLEASE READ.......................

 

I have said this over and over to everyone and even posted this at the header of my forum page.

 

For customer service please email:

 

custserv@whiplashaudio.com

 


I seriously try and get to all emails. If I missed a few, than I apologize. I have been working with my new site; www.whiplashproaudio.com. So I'm being pulled in about 30 directions. However like I have mentioned before, please contact the above address to reach my employee that can assist you. 

 

He can than reach out to me if he needs to. 

 

Please understand, you are welcome to email me at any time. If I don't get to your email than PLEASE email the address above. This is one reason why I have this system in place. 

 

Craig

post #13 of 16

Hah... don't understand why people start thread here instead of sending pm or another email to you...

post #14 of 16
Thread Starter 
Quote:
Originally Posted by CandYL View Post

Hah... don't understand why people start thread here instead of sending pm or another email to you...



Maybe because he does not reply to pm or emails, if he did there would not have been a need to start this thread, read the OP where i state i emailed him untold times with no reply and he only done something when an actual thread was opened about the issue.

Not only me but a lot of people have been having the same problem with him.

 

post #15 of 16
Quote:
Originally Posted by HarryPotter View Post



Maybe because he does not reply to pm or emails, if he did there would not have been a need to start this thread, read the OP where i state i emailed him untold times with no reply and he only done something when an actual thread was opened about the issue.

Not only me but a lot of people have been having the same problem with him.

 



Did you contact customer service?

New Posts  All Forums:Forum Nav:
  Return Home
This thread is locked  
Head-Fi.org › Forums › Head-Fi Special Forums › Premier Sponsor Forums and Sponsor Forums › Premier Sponsor Forums › ARCHIVE: Whiplash Audio Premier Sponsor Forum › twag v1 replacement programme. what is going on? PLEASE CONTACT my customer service email address.....