Head-Fi.org › Forums › Equipment Forums › Computer Audio › Music on Foobar skipping?
New Posts  All Forums:Forum Nav:

Music on Foobar skipping?

post #1 of 48
Thread Starter 

Recently my foobar's songs have been skipping on me and it annoys the hell out of me.  Sometimes songs will have quick pauses and skips every few seconds.  I know there is nothing wrong with the tracks as they did not do that before.  I'm playing lossless files if that helps and I toyed with the buffer length.

 

Any ideas why my computer is doing this?  Maybe it is having lag?

post #2 of 48

Which output method are you using? DS, WASAPI, ASIO, KS?

 

And what buffer size do you have?

post #3 of 48
Thread Starter 

DS at 50 ms

post #4 of 48

50ms, are you nuts confused.gif You do know that we're talking about a player wink.gif

 

Seriously, try setting the buffer size to something between 500 and 1000ms, player response will be as swift and most likely will completely fix those issues. This still with DS.

 

EDIT: That buffer size is very small, and given that you're doing audio playback, there's no need for it to be set like that, as you won't gain anything from it.


Edited by Roller - 6/28/11 at 1:46am
post #5 of 48
Thread Starter 

ohhhhhh that can explain why it started doing that after I lowered the buffer length.  I will up it to 1000 ms and see if it still have this problem!

post #6 of 48

Yes, 1000ms is a perfectly reasonable value. There are even people using as high as 2000ms, but those are specific cases. 1000ms is the default value and works for most people.

 

Hope it fixes your issue :)

post #7 of 48

how do you change the buffer on foobar?

post #8 of 48
I cranked my buffer to 4096 kB (4MB). I use ALAC, so its like typically a good chunk of a song.
To do this: Preferences-> Advanced-> Playback-> Full file buffering up to (kb)
I do this in hopes of reducing hard drive activity. I am not sure if it really does anything as foobar2000 documentation is usually spotty or old.

You can change your thread priority hear, but I wouldn't do it unless you have a dedicated PC for playing audio back.

Try defragging your hard drive. My hiccups completely went away when I:
1) Store my music on a separate physical hard drive.
2) Defragged all music.

To top it off, I went overboard and used MyDefrag to control the location of the files. I made sure all my music was moved to one big contiguous block on the hard drive. I also defragged the album art into a separate part of the partition so Chronflow can read it and cache it in one fell swoop. This sped up foobar2000 load times by a heck of a lot for me.

Also check if your computer is trying to do something intensive when the hiccups happen. It might be handy to have Resource Monitor running in attempt to discover the responsible process. I turned off preftech and set superfetch to boot-only mode, although I don't recommend doing this unless you know all your software is compatible with such settings.
post #9 of 48
Quote:
Originally Posted by pedxing View Post

I cranked my buffer to 4096 kB (4MB). I use ALAC, so its like typically a good chunk of a song.
To do this: Preferences-> Advanced-> Playback-> Full file buffering up to (kb)
I do this in hopes of reducing hard drive activity. I am not sure if it really does anything as foobar2000 documentation is usually spotty or old.

You can change your thread priority hear, but I wouldn't do it unless you have a dedicated PC for playing audio back.

Try defragging your hard drive. My hiccups completely went away when I:
1) Store my music on a separate physical hard drive.
2) Defragged all music.

To top it off, I went overboard and used MyDefrag to control the location of the files. I made sure all my music was moved to one big contiguous block on the hard drive. I also defragged the album art into a separate part of the partition so Chronflow can read it and cache it in one fell swoop. This sped up foobar2000 load times by a heck of a lot for me.

Also check if your computer is trying to do something intensive when the hiccups happen. It might be handy to have Resource Monitor running in attempt to discover the responsible process. I turned off preftech and set superfetch to boot-only mode, although I don't recommend doing this unless you know all your software is compatible with such settings.


 

First, buffer is set based on its length, not its size. Second, lossless audio doesn't require 4000ms, that's an absurdly high value. People shouldn't go beyond 2000ms IMO. Interface interaction lag is definitely an undesired feature to be had.

 

Unless the HDD at hand is an older model with slower rotation speed, a mere schedules defrag even on the system drive (were the files to be located there) makes things run quite smoothly. And any computer with less than 10 years of existence should have no problem running all kinds of audio formats with those settings.

post #10 of 48

what others have said...

 

Personal experience I run mine at 250ms...basically a 1/4sec delay if I make a setting in foobar to take effect so it's quick but my audio doesn't skip then either.

post #11 of 48
Thread Starter 

Yup, it started doing it again at 1000ms.  I tried 2000, 500 and 250ms too and still get it...  WTH is wrong?!

post #12 of 48

Are you doing something while it skips? Also please take a look at the task manager while the skips occur and check the CPU load.

post #13 of 48

Man, that sucks! I had a similar itunes problem, as my 2010 Mac Mini started doing the same thing last year. At first, the skips seemed pretty random, but I finally noticed that once it started skipping, they usually occurred about 6 seconds apart. Adjusted the buffer, no help. Next, I thought I had some corrupted files but all files played perfectly on my ipod. I set up another user account, installed a fresh version of itunes, downloaded a few new songs...and still had skips. I chased this problem for a few weeks, as nothing seemed to help. I grew increasingly frustrated, just as you are now. angry_face.gif

 

Just before I sent the Mac Mini in for service, I removed the two 4GB Crucial sticks I had installed a few months earlier and replaced with the two original Apple 1 GB sticks, as the Apple Service Center has to have it in "as new, non-modified" condition. After looking at it a week, Apple can't duplicate the problem, so they reinstall the OS after making sure I had all files backed up. Get Mini home, reinstall files...no skips. Apple Service told me it was probably a corrupted kernal. Really? I wonder if I got a bad memory stick. Curious...did you recently upgrade your memory?

 

Anyway, I give the Mini to my young daughter, and I go off to buy an iMac AND a Dell fanless netbook to use as a dedicated music server. No issues thus far...well, except for a whining daughter that says her Justin Beiber songs are occasionally skipping. wink_face.gif

 

Keep us updated!

 

post #14 of 48
Thread Starter 

I just have a few programs open like foobar, AIM, firefox, and adobe reader.  CPU load is at a calm 3% while the memory is at 50%

post #15 of 48
Thread Starter 

Decided to clean up my HDD a bit by deleting like 50gb of crap and still no help.

 

Then I had a great idea since I realize my computer never actually installed any new drivers since I got my Digital Interface since I used to run my DAC via USB.  I turned off my DAC, unplugged my USB cable from my DI, and uninstalled the driver for my DAC.  Plugged the USB back in and let win7 do its thing and install the driver again, turn my DAC back on.  I played a couple songs all the way through without any skipping problems!!!  When I try to select my source on foobar, the name is different, it is now SPDIF/(USB Device) instead of SPDIF/(TE7022), although the same driver has been reinstalled in my computer.  My guess is that I've been trying to output directly to my DAC while my DI is receiving the signal first.  Does that sound right to you guys?  I never had this issue until I got my DI so I guess this explains it?!

 

So far so good.  I definitely hope it stays this way!!!

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Computer Audio
Head-Fi.org › Forums › Equipment Forums › Computer Audio › Music on Foobar skipping?