New Posts  All Forums:Forum Nav:

etymotics blown drivers?

post #1 of 8
Thread Starter 
Looking for some advice with my hf-3s

I bought them about 30 days ago they are my first iems. I'm now hearing a bunch of distortion that wasn't there before paticularily on heavy bass hit sections basically sounds like something reverberating or resonating. I measured my normal listening volume at 70 DB so I definitely don't crank the volume. Being New to iems I'm wondering if there is something else to account for that ie they need a good cleaning? Or some other mistreatment I might have done or whether its just time to get them replaced as defective

Thanks
Edited by ronrad - 6/9/11 at 8:43pm
post #2 of 8

is it occuring bilaterally? have you tried replacing the filters?

 

post #3 of 8

...I really hope this doesn't happen to me with my HF5s when I get them. I had a similar problem with my RE0s.

post #4 of 8
Thread Starter 
Hmmm. Tried replacing the filters and it does seem improved. It was a little intermittent before and showed on some more songs than others. Need to try listening for a while longer with other songs to see if that is the issue.

So that would bring up the big Question of how often one should actually change filters? Given that only one set of replacement filters came with the phones and I've only used them for about a month at most for 2 hrs a day or so
post #5 of 8

There is the possibility that your music was recorded poorly and the etymotics are revealing the flaws of the poor files, but bad drivers are always a possibility.

 

go find some test frequency mp3 files to narrow down the problem.

 

life of the filter is dependent on the amount of ear wax you produce.

post #6 of 8
Thread Starter 

Thanks for the ideas!  Definitely not the source ... I'm hearing it on some of my current favorite flac recordings direct from the Rodrigue / Gabriella web, they are super well recorded tracks, and I've played them a ton with the HF3s since getting them, with this being a change since the original sound.

 

I've been listening to the HF3s for about 45 minutes now with the new filters and not hearing the problem.   May have solved it!  

post #7 of 8

Good to hear because I wouldn't have expected that a distorted sound would be from one of the filters.  It's possible that you had a hair sticking through the filter down into the driver area, or the filter was very loose.  Usually a clogged filter just reduces the sound, esp. the highs, in that ear.  Make sure you have the filter pushed in flush with the nozzle ending.

post #8 of 8
Thread Starter 
Thanks for all the suggestions. I think I've tracked this down to a couple of things. First I had played with the filter a few days before I noticed it so think I must have loosened it. Also I had been playing with eq and I now have the latest voodoo sound with hardware Eq and had it set to increase the bass and an Eq setting on power amp to do it as well. Overall by changing the filters a lot of the problem went away however if I accidentally eq on both bass gains then I still get badly distorted bass (not at the level of the original problem but still quite noticeable)
New Posts  All Forums:Forum Nav: