Head-Fi.org › Forums › Equipment Forums › Portable Headphones, Earphones and In-Ear Monitors › WESC oboe headphone troubleshooting
New Posts  All Forums:Forum Nav:

WESC oboe headphone troubleshooting

post #1 of 6
Thread Starter 

hey i have some white WESC heaphones and i was wondering how to fix a problem i have with it,

 

 on the headphones only one the speaker with the cable is working 

 

i was wondering if anyone knew how to fix this and immediate response would be great thanks 


Edited by HRGTH - 6/7/11 at 11:31am
post #2 of 6

The easiest fix would be to throw the WESC out of a window, forget you ever owned one and buy a headphone that actually sounds good and has decent build quality. wink_face.gif

 

On a less brutally honest note, if one side isn't working it's either cable damage or a busted driver. You could remove the cable and recable the headphone yourself. This calls for a little DIY. You could also try opening the headphone and see if anything looks out of the ordinary around the driver. Is the thing still under warrenty?

 

But really, there's a reason why brands like WESC, Nixon and Skullcandy don't have much of a following here. 

post #3 of 6

Maybe try writing a question that make sense will help.

post #4 of 6

WESC are not worth the trouble repairing

post #5 of 6
Thread Starter 

how do u suggest i do it myself ?

post #6 of 6

To recable it, you would need to buy some wire and a soldering iron assuming you don't have one. The price of those would most likely cost more than your headphones rendering this option useless/dumb.
 

Quote:
Originally Posted by HRGTH View Post

how do u suggest i do it myself ?



 

New Posts  All Forums:Forum Nav:
Head-Fi.org › Forums › Equipment Forums › Portable Headphones, Earphones and In-Ear Monitors › WESC oboe headphone troubleshooting