Head-Fi.org › Forums › Equipment Forums › Portable Headphones, Earphones and In-Ear Monitors › Sunrise SW-Xcape Impressive Edition (NOT v.2) - any impressions out there?
New Posts  All Forums:Forum Nav:

Sunrise SW-Xcape Impressive Edition (NOT v.2) - any impressions out there? - Page 5

post #61 of 76

If it is driver flex, you should only have to pull the IEM out just a hair and it should flex it back into the correct spot.  Sometimes I have to do this with the turbines...they are notorious for this issue.

post #62 of 76
Quote:
Originally Posted by dbdynsty25 View Post

If it is driver flex, you should only have to pull the IEM out just a hair and it should flex it back into the correct spot.  Sometimes I have to do this with the turbines...they are notorious for this issue.



Hm, might be not this issue. Thanks it really helped, because the quiet side does not go to the right sound after slightly changing the position in the ear. I have to take it out and wait for a while. 

post #63 of 76

I got mine replaced today and have same issue within few hours. Either I'm very unlucky or there is some doubt as to whether they are a replacement or whether the pair I sent for replacement were simply sent back. It's taken an unacceptable amount of time to remedy at over a month to send out replacement after supplying extensive info on the issue. The replacement was sent as just iems with medium buds exactly like I sent without box, card etc etc. Of course I'm fine with that if they are indeed new pair and have no problem with it but why not send the rest of the stuff including tips/case etc thinking about it now since they would be useless without headphones and a free case etc isn't much considering the customer isn't refunded for p&p fees of returning (soon to be twice) nor the (currently) 6 week wait over the issue unless of course you are sending out the originally returned pair.

 

Not got too much faith in replacement sent being actual replacement and don't want to wait another 6 weeks when it will make refund harder so want a refund now and may order a second pair from a different seller but will wait to see if it becomes an issue.

 

It could be flex I don't know but it really does affect sound. I've never heard driver do this before and I've come across various issues before now including ear pressure, wrong bud insertion etc and this isn't that. It starts as a gradual change over few minutes then suddenly changes quickly. No popping etc and you can even hear it without buds fitted for example or out of ear which proves it isn't that. One ear goes very quiet, almost silent with not much coming through and the other side drops in volume but sound quality drops by severe amount with limited range. There is no preceeding popping or anything, it's just like a smooth throttle down and shift in LR balance accompanied by range and quality loss.

 

I'm not talking slightly perceivable here I mean it's VERY dramatic difference and you can't miss it when it happens. I actually like the sound when they worked hence still interested in picking a pair up since they have nice bass and suited to my taste and listening to things like Black Mountain seem to shine with the warmth of the IEs compared to v1's for my preferences at least. Sadly I'm running out of patience as far as my current situation goes which is a shame since I don't want it to colour my view of Sunrise or their products but I fear it may. perhaps I'll go through sunrise support instead to see if there is any joy there.

post #64 of 76

i'm curious as well

post #65 of 76

I purchased a pair of v2 from the UK seller (through Ebay) in February. A fault developed in connector after a two months and the seller kindly replaced them with a pair of Impressives.

 

Unfortunately, they have the exact same problem mentioned above by K10W & Egioras - my replacement only took a couple of weeks but everything else is word-for-word identical. I'm not sure there's much point contacting the seller again and risk a repeat process.

post #66 of 76

Seller has solved my problem by refunding money. Thank you Sunrise for being reliable and quick to refund. Hope you will sort the Xcape problem :) In general I can say that, the sound quality was amazing and it is really a pity I couldn't reveal its all beauty.

post #67 of 76
Quote:
Originally Posted by Egioras View Post

Seller has solved my problem by refunding money. Thank you Sunrise for being reliable and quick to refund. Hope you will sort the Xcape problem :) In general I can say that, the sound quality was amazing and it is really a pity I couldn't reveal its all beauty.


 

We found the problem already, there are about 10 pcs of Xcape IE in first batch short of glue which causes the heating in voice coil, our staff made a mistake when send some of the faulty products to UK. We will replace all the faulty products with new one and will check everything careful. Thank you for understand!

post #68 of 76

but..where to buy those products? The sunrise official website doesn't even show the IE as existent! What about the V2 and V1 models?

post #69 of 76

 

Quote:
Originally Posted by -sandro- View Post

but..where to buy those products? The sunrise official website doesn't even show the IE as existent! What about the V2 and V1 models?

 

Where are you from? The UK distributor sells them on Ebay.co.uk

post #70 of 76

Italy. Do they cost like the v1/v2?

post #71 of 76
Quote:
Originally Posted by -sandro- View Post

Italy. Do they cost like the v1/v2?



I would recommend you to contact the official Sunrise Support team for prices and places where you could get their items. They answer very fast (within a few hrs time) and are very helpful.Service.sunriseaudio@gmail.com

post #72 of 76

I already contacted them 12h ago. we'll see

post #73 of 76

Looks like ALO Audio is likely to be the USA distributor for the new Xcapes. I got a response from Sunrise stating that "Bugden Audio stopped response for a long time, we are finding a new distributor in USA. We hope AloAudio will be our distributor in USA soon."

Hopefully soon means very soon, ALO Audio looks far more reputable than Bugden Audio, especially considering they're a sponser of Head-Fi!

post #74 of 76

Hi I'm new here and I have similar problem with the driver as K10W & Egioras too, I think I might have gotten the faulty first batch.

post #75 of 76

Good day!

I think I got the first batch. I also suffered from that low volume on one side of the IE. BUT after 200+ hours of burn-in, it sounds very good to me. It's just perfect to my ears. :)

New Posts  All Forums:Forum Nav:
Head-Fi.org › Forums › Equipment Forums › Portable Headphones, Earphones and In-Ear Monitors › Sunrise SW-Xcape Impressive Edition (NOT v.2) - any impressions out there?