Head-Fi.org › Forums › Equipment Forums › Portable Headphones, Earphones and In-Ear Monitors › Sunrise SW-Xcape Impressive Edition (NOT v.2) - any impressions out there?
New Posts  All Forums:Forum Nav:

Sunrise SW-Xcape Impressive Edition (NOT v.2) - any impressions out there? - Page 3

post #31 of 76
Thread Starter 

Did you get yours Mark?

post #32 of 76

I ordered these about a little over a week ago and received them in the mail already. I have let them burn in a little bit by streaming 320kbps ambient electro to them for 3 hours before having my first listen. This is streaming 128kbps dance/house/dj off my droid phone.

 

I think they sound great for $100 very well balanced but not overly analytical. The bass is there, not as much as my Klipsch S4’s, although I’m hoping with more break-in time that it will get a more of a kick to it. The mids and highs are good and well textured but there is a little lower mid muddiness.

 

I’ve been listening to a pair of Westone 2’s for the last 4 days so these are a nice change of pace for me but I think that may be changing my perception.

 

After some more listening I will do a better review. I just wanted to let everyone know to keep an eye on their mailboxes.

 

post #33 of 76

popcorn.gifpopcorn.gifpopcorn.gif

post #34 of 76
Quote:
Originally Posted by LooptroopRocker View Post

Did you get yours Mark?



no, Sunrise said they have asked the UK supplier to send me one though


Edited by mark2410 - 5/3/11 at 11:43pm
post #35 of 76
Thread Starter 

Oh I got my eyes on my mailbox, being without any headphones/iems hasn't been easy!
 

Quote:
Originally Posted by etg9 View Post

After some more listening I will do a better review. I just wanted to let everyone know to keep an eye on their mailboxes.


@Mark: well played sir!

 

post #36 of 76

 blink.gif

I got mine today. Really impressive SQ, however I have one phone (right) sometimes become very quiet. It would be less annoying if after a few minutes it would not suddenly fix itself. Then again, after I put IEM in my ears, I have one phone quiet. It sounds like I have really hairy and dirty ears, but I cleaned them like 5 times, so they do not cause any problem... If it will keep happening I will contact seller, but I am interested if anyone faced such problem at some time with the same or other IEM?

 

post #37 of 76
Quote:
Originally Posted by Egioras View Post

 blink.gif

I got mine today. Really impressive SQ, however I have one phone (right) sometimes become very quiet. It would be less annoying if after a few minutes it would not suddenly fix itself. Then again, after I put IEM in my ears, I have one phone quiet. It sounds like I have really hairy and dirty ears, but I cleaned them like 5 times, so they do not cause any problem... If it will keep happening I will contact seller, but I am interested if anyone faced such problem at some time with the same or other IEM?

 



is it similar to what happens when you plug a headphone jack in only part of the way? that's what it sounds like to me.

post #38 of 76

Do you mean one side becomes quiet when you insert it in, then it suddenly get better and balance back? If so, it might be that you are using an eartip size a little too large for your ear canal and cause a little back pressure to build up when you insert the IEM in.

post #39 of 76
Quote:
Originally Posted by ClieOS View Post

Do you mean one side becomes quiet when you insert it in, then it suddenly get better and balance back? If so, it might be that you are using an eartip size a little too large for your ear canal and cause a little back pressure to build up when you insert the IEM in.



very likely. i have had this occur with IEM's before.

 

Actually, i sent back a pair of maximo im-590's.. (some pretty awesome headphones, just a bit too bassy for me). They had one of vent holes covered up, causing a really uncomfortable vacuum in my ear on one side whenever i put the earpiece in. (they replaced them for me without a question). Just thought i'd share, maybe its an issue like that. 

 

- not a vacuum. but pressure inside my ear..


Edited by chrislangley4253 - 5/4/11 at 8:15pm
post #40 of 76
Quote:
Originally Posted by Egioras View Post

 blink.gif

I got mine today. Really impressive SQ, however I have one phone (right) sometimes become very quiet. It would be less annoying if after a few minutes it would not suddenly fix itself. Then again, after I put IEM in my ears, I have one phone quiet. It sounds like I have really hairy and dirty ears, but I cleaned them like 5 times, so they do not cause any problem... If it will keep happening I will contact seller, but I am interested if anyone faced such problem at some time with the same or other IEM?

 


Please check if you use right tips and have good fitting. If the product has problem, please send it back to our dealer and we will exchange a new product for you.

 

post #41 of 76
Quote:
Originally Posted by NCT View Post




Please check if you use right tips and have good fitting. If the product has problem, please send it back to our dealer and we will exchange a new product for you.

 


I tried with the all different tips provided. It keeps happening.

 



Quote:
Originally Posted by chrislangley4253 View Post

is it similar to what happens when you plug a headphone jack in only part of the way? that's what it sounds like to me.

It is similar experience, however it is not the case with the jack. I will try to explain in more details:

 

I start to listen to the music with Xcapes. Everything is fine, they are shining for a while, but after some time I loose sound from the right phone. The tips, the jack or my ears are not the problems so it is wrong with something else. I put the phone aside, but the music keeps playing. After a dew minutes everything is fine... That is strange. I am sending back to my seller anyway, hope they will replace them :) Thanks for the help guys wink.gif
 

 


Edited by Egioras - 5/5/11 at 12:41am
post #42 of 76

I got a pair but had issues so have returned them and waiting to hear about replacement/refund still. One side would become very quiet and almost muted and the other would drop in volume and sound poor and harsh but not as much as the other channel. Sounds like others have had same issue so not sure if I'd chance it myself if I could get a refund and knew this in advance as could be a design flaw. UK seller hasn't got back to me yet regarding warranty or refund although I have a set of V1's I've bought too which I'll use so in no rush but will file paypal dispute if not heard within the time limit. The prob happens after around 30min of playback but goes away if left to cool off so to speak for a few hours. However it always comes back hence returned.

 

As for sound they seem rather nice. Much less bright than the v1 and a very warm compared to v1's, I quite like the thick warm sound to them myself and think it would suit some music more than the v1's hence I'm hoping I can get replacement. Even though they are much more bassy and less bright than a v1 they still have detail and are not boomy or quantity over quality bass to me. For reference I'm listening mainly on a sansa clip+ with stock fw, also tried on rockbox'd player and through various other pmp/dap and computer. There doesn't seem quite as much detail as v1's but to my ears they sound easily good enough. The bass doesn't sound bloated and doesn't seem to kill the mid detail as other very bassy phones can (I haven't ever used very expensive ones to compare, most are arounf £60 odd and under range for comparisson), I find for some stuff the sound signature is more suitable than the v1's at times which can be too harsh and bright for my liking when listening to something like sonic youth on my clip with no EQ adjustments.

 

The cable feels like neoprene or silicone and I like it personally and prefer feel of that style cable to regular pvc types. Unsure what it is but if it is silicone then it has a wider temp range so guess it will stay flexible in very cold temps which I personally will find a use for come UK winter time but some time off yet. The none tapered design of the iem housing makes no difference to me and I can't see them in my ears so don't care. The jack I like very much and the strain relief seems adequate and is nice and slim. RH angle jack as slim would have been even nicer for my clip but this is fine still, I just clip it to shirt etc at a 90 degree angle.

 

If not for the potential issue which may be a design flaw in this range I'd recommend them as an alternative to those who don't like v1's as the sound signature sounds drastically different and I'm not an audophile nor have perfect ears so if I can hear it it is obviously different. All things considered they sound decent enough to me although lacking in some detail they certainly don't sound bad and I'd trade that for the nice bassy warm feel. Hopefully if there is a design issue with them it gets ironed out quick for the next batch.

post #43 of 76


 

Quote:
Originally Posted by K10W View Post

I got a pair but had issues so have returned them and waiting to hear about replacement/refund still. One side would become very quiet and almost muted and the other would drop in volume and sound poor and harsh but not as much as the other channel. Sounds like others have had same issue so not sure if I'd chance it myself if I could get a refund and knew this in advance as could be a design flaw. UK seller hasn't got back to me yet regarding warranty or refund although I have a set of V1's I've bought too which I'll use so in no rush but will file paypal dispute if not heard within the time limit. The prob happens after around 30min of playback but goes away if left to cool off so to speak for a few hours. However it always comes back hence returned.

 


 

That's what I am experiencing. I sent mine to the seller (Sunderland, UK) today. Hopefully he will get them on Monday or Tuesday and I could get a refund or a replacement. I am planning to get Hifiman Re0, in case I get a refund instead of a replacement :) I read a lot about those legendary IEM and I understand that the sound is not so thick as Xcape Impressive edition. Am I right?


Edited by Egioras - 5/5/11 at 12:36pm
post #44 of 76
Thread Starter 

Not very encouraging to see two head-fiers with such issues, esp. considering the UK seller has sold only about 20 pairs of these. I got my fingers crossed!

post #45 of 76
Thread Starter 

Joker just posted his first impressions on these here!

New Posts  All Forums:Forum Nav:
Head-Fi.org › Forums › Equipment Forums › Portable Headphones, Earphones and In-Ear Monitors › Sunrise SW-Xcape Impressive Edition (NOT v.2) - any impressions out there?