Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › HiFiMAN Playback Order
New Posts  All Forums:Forum Nav:

HiFiMAN Playback Order

post #1 of 9
Thread Starter 

Is anyone else having trouble getting the songs to show up in the track listing order?

I don't really listen to singles often, I usually immerse myself in an album; so track listing is fairly important to me. I can't seem to get my 601 to cue the songs in order by track number, though. If I go select a song through the 'Album' tab, the tracks still show up in alphabetical order. I set the Playback order option to 'Order.' But they only show up alphabetically, and I'm sure my flacs are properly tagged so that can't be the issue either.

I've also made a single track for some albums for gapless playback but that isn't necessary for most of my albums because very few of them have songs that actually are meant to transition into one another. So for the most part, that option doesn't help either.

Any other suggestions?

post #2 of 9

you can edit track names on your hm-601. just put 1- and 2- and so forth in front of the tracks in your albums, or sth like that. by the way, I don't have the same issue - but I'm editing names of tracks to be shorter (and legible on the small screen) and it's quick and easy.
 

Quote:
Originally Posted by Nod2mybeats View Post

Is anyone else having trouble getting the songs to show up in the track listing order?

I don't really listen to singles often, I usually immerse myself in an album; so track listing is fairly important to me. I can't seem to get my 601 to cue the songs in order by track number, though. If I go select a song through the 'Album' tab, the tracks still show up in alphabetical order. I set the Playback order option to 'Order.' But they only show up alphabetically, and I'm sure my flacs are properly tagged so that can't be the issue either.

I've also made a single track for some albums for gapless playback but that isn't necessary for most of my albums because very few of them have songs that actually are meant to transition into one another. So for the most part, that option doesn't help either.

Any other suggestions?



 

post #3 of 9
Thread Starter 

That would work, but I'm not really a fan of the solution because on the seldom occasion that I did want to listen to a single track it would get lost in the midst of numbers, since I'd have to remember where it fell in the track listing to find it among all my other songs.

You said you don't have this problem? What do you use to edit tags? I use mp3Tag and it works great, very simple and user friendly. Usually, it instinctively knows the track listing to so it makes those tags for me. But, for whatever reason, I can't get the HiFiMAN to read them that way. I tried deleting it and re entering the numbers manually, but they still show up alphabetically.

post #4 of 9

@NOd2mybeats, I never had to edit for order, I only do it for file name length. you may want to check in the settings of your hifiman what the play order preference is set to?

post #5 of 9
Thread Starter 

I have. There are only two options: 'Order' and 'Random.'  I selected order but, again, they only playback alphabetically. I find it strange no one else has this problem. I even tried emailing head-direct themselves, with no response. I don't understand what I'm doing wrong. All the other tags read perfectly.

When you look at your songs through the album option, how do they show up?

post #6 of 9

here, all files in albums are preceded by 1 or 01 (or A1 and B1) and thus in the right album order, for me.

post #7 of 9

having the exact same issue : (

post #8 of 9

Quote:

Originally Posted by Nod2mybeats View Post

Is anyone else having trouble getting the songs to show up in the track listing order?

I don't really listen to singles often, I usually immerse myself in an album; so track listing is fairly important to me. I can't seem to get my 601 to cue the songs in order by track number, though. If I go select a song through the 'Album' tab, the tracks still show up in alphabetical order. I set the Playback order option to 'Order.' But they only show up alphabetically, and I'm sure my flacs are properly tagged so that can't be the issue either.

I've also made a single track for some albums for gapless playback but that isn't necessary for most of my albums because very few of them have songs that actually are meant to transition into one another. So for the most part, that option doesn't help either.

Any other suggestions?

 

Does the 601 have an "SD Card" menu like the 801?  If you find look under the SD Card option for the folder where you put the album (assuming you copied 1 album per folder), the tracks are usually listed in the order in which they were copied.  But this may not be numerical order, even if you put the numbers at the front. 

 

This is one of my main gripes with the HM-801's firmware, but there is a (cumbersome) way around this:  Assuming the tracks are listed in numerical order with the number at the beginning of the file, choose the first track you want to start the album from.  Turn the player off then back on, then hit the top left button from the main menu to go to the "Now Playing" screen.  If your playback mode is "Order", then the player should move in numerical order from that point.

 

I've suggested that Fang work on a fix to make sure that the SD Card menu always lists folders in alphabetical order, and tracks are listed in numerical order within those folders.  At the NY meet, he told me that his programming guy is working on a new firmware update (he seemed especially interested in getting Apple lossless compatibility), and that he would consider my suggestion.  But he wanted to let me know that the firmware is very difficult to upgrade, and it hasn't been an easy process.

post #9 of 9
Older thread, I know. I just wanted to post what worked for me here because this thread is the easiest to find when searching for this particular issue.

I just got the 602 and was having this problem of not liking my folders to be listed in order copied to the memory. The solution is in the 801 firmware thread. Thanks abeautifulife!

I downloaded Drivesort and edited the FAT directory table. It will sort alphanumerically or you can manually shunt files into order. Worked very well for me. Hope this helps any new Hifiman owners.

If there is a simpler solution, please post it here as I haven't found anything else.

Cheers
Edited by Pudu - 9/27/11 at 4:37am
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › HiFiMAN Playback Order