New Posts  All Forums:Forum Nav:

Small Issue with my JH5s

post #1 of 4
Thread Starter 

I'm not sure where else to turn, I figured posting on here would be a decent start, at least as to finding out information/what I can do/if I'm totally screwed etc.

 

Anyway, I purchased my JH5s sometime around late October, and recieved them early November.  Loved them from the beginning, still do, though lately I've been having a bit of an issue.

 

Normally, they sound fine, though once in a while, the right headphone won't play any music.  I can get it to work by moving the cable around a bit, and when it plays, it sounds fine.  It's not quieter/the sound is perfect etc, but it does annoy me as well as worry me that i have to wiggle the cable around to get it to work.

 

Would I be totally out of luck and be required to buy new ones, or is there some sort of warantee/repair I can get?  Would anyone know?

post #2 of 4

Switch the pins and then see if it does that for the left side. It sounds like you need to buy a new cable.

post #3 of 4
Thread Starter 

Yep, does it when I switched them.

 

Email'd customer support, hopefully I can get a replacement cheap/free, if not, should I stick with the default cable, or would I be better off buying a replacement 3rd party cable?

 

I use these out of my iTouch 4th gen, sometimes with my CMoY Amp.  Would it be beneficial at all?
 

Quote:
Originally Posted by rawrster View Post

Switch the pins and then see if it does that for the left side. It sounds like you need to buy a new cable.



 

post #4 of 4

You should get a cable for free! I got it for UE for my Super fi 5 even after two years and even though I was out of warranty!

 

By the way, nice that you like the iems, I'm probably going to buy a pair myself :) 

New Posts  All Forums:Forum Nav: