Head-Fi.org › Forums › Equipment Forums › Portable Headphone Amps › Nuforce uDAC-2 HP disappointing... Using with HFI-780. Imbalance Issue.
New Posts  All Forums:Forum Nav:

Nuforce uDAC-2 HP disappointing... Using with HFI-780. Imbalance Issue.

post #1 of 3
Thread Starter 

I got the Nuforce uDAC-2-HP from Amazon in the mail just yesterday and I must say that I'm quite disappointed with its quality. Two issues:

 

1) Low-volume channel imbalance. The right side dies out way before the left side at low volumes (6-9 o'clock). At around 8 o'clock there's absolutely no sound coming from the right channel, and the sound is clearly biased towards the left side.

 

2) Buzz/crackling when shifting the unit around. There's this annoying buzz/crackling sound when I'm moving the unit around on my table. The sound sometimes completely drops out and reconnects. But the buzz/crackling sound sounds like a connection problem. As if the plug isn't solidly connected to the headphone jack, so any shift makes it slightly lose connection.

 

I'm using this with my new HFI-780's, but both problems exist even when I switch out to different headphones.

 

So, can any of you tell me if these issues are inherent in all uDAC-2's? Or did I just get a defective unit.

 

Also, are there any better alternatives to the uDAC-2?

post #2 of 3

Channel imbalance is normal at very low volumes.

You can find more details here http://www.nuforce.com/hp/support/analog-volume-graph.php

I have Icon HPD, and same thing is happening at low volumes.

 

Generally im very satisfied with HDP, great results with my DENON AHD7000.

 

Regarding buzz noise, did you check the cable?

post #3 of 3

Just got mine in the mail and experiencing the exact same problems.  I knew going in about low volume balance, no big deal there.   But touching the unit to change volume sometimes results in loss of sound for a few seconds and my left channel crackles very quietly during parts of (FLAC) music files when going from silence to seemingly anything in the mids, highs and bass dont seem to make it happen.  I tried 2 cables and 2 pairs of headphones, same results.


 

 

 

 

 

 

 

 

 

 

 

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Headphone Amps
Head-Fi.org › Forums › Equipment Forums › Portable Headphone Amps › Nuforce uDAC-2 HP disappointing... Using with HFI-780. Imbalance Issue.