Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › Ipod classic - rockbox - its happening.
New Posts  All Forums:Forum Nav:

Ipod classic - rockbox - its happening. - Page 54

post #796 of 3087

Went back to 120505. Feel good.

 

 

Edited by yosh - 6/6/12 at 3:32am
post #797 of 3087
Quote:
Originally Posted by Dukedudez View Post

Can someone clear up if installing rockbox still erases your iPod's memory?

It did for me (it formatted the hard drive).

Edit: it's actually the emCORE installation process that did it.
Edited by skamp - 5/12/12 at 2:46am
post #798 of 3087
Hi all,

Firstly let me commend you on all of the work that has gone into this awesome project.i had rockbox on my iRiver years ago, but needed to have a large capacity player and dislike iTunes, but then saw there might be a possibility for RB to rule again. Got my 120gb classic today, didn't even put any data on there, nor play a single song with iTunes. Followed the instructions on p49 and all seemed well, however:

Build 120511 now just sits there when I load RB.

I can go into tools and revert to the 'backup' build, which appears to work as intended, except, drumroll, it won't play music. What do I mean? Well, it simply skips through the songs but won't. Play any. I've looked around for what might be causing this, but I'm stuck. This same issue was happening the one and only time I saw 120511 work.

I might have had something to do with the device now not working with builds other than the 'backup' - on one occasions, Windows wouldn't release the iPod in safe remove, so I had to pull the iPod out without 'safe remove' being complete.

Initially I though I had bricked my iPod, but the thing runs, the songs/files are there, I can browse (in backup mode - 120101) and usual, but no music play.

So, 2 issues here, 1. Why can't I load other builds without it locking up? How the heck can I get to actually play the files rather than simply skipping through them?

P.s. I have reinstalled the emcore process and replaced the .rockbox folder on a number of occasions.

Any ideas? Help is really appreciated.

Cheers,

Raj

**EDIT** Ok, so after playing around a little more, I have found that build 120501 works, including music playback. I tried the 3, 5, 9, 11 May builds and none work, ie, the systems reboots and I select the RB from emCore, and the logo comes up with the right build number down the bottom of the scree, then briefly 'scanning files' - then freeze. Interesting. At least I have it working with 120501, will rely on that for a while and wait to see if there are further developments along the way.

Thanks again for your amazing work! Cheers, Raj

**Further Edit** Build 120501 doesn't seem to go into 'USB mode' when I plug it into the laptop - so I am having to use the 'backup' copy for file transfer
Edited by rajperth - 5/12/12 at 5:27am
post #799 of 3087

aroldan, charging is working again with the latest build. It kicks in when you plug the Classic in with the battery below 90%. Well done!

post #800 of 3087
Quote:
Originally Posted by cooperpwc View Post

aroldan, charging is working again with the latest build. It kicks in when you plug the Classic in with the battery below 90%. Well done!

Actually if did found charging is working with every build if you change battery's display into digital form instead of the bar

 
post #801 of 3087
Quote:
Originally Posted by tupac0306 View Post

Actually if did found charging is working with every build if you change battery's display into digital form instead of the bar

 

 

You are confusing the "fully charged" trickle charging with "charge mode". I have both graphic and numeric charge indications in my theme. I also have a "c" switch that comes on in front of the numeric battery charge indication when in "charge mode". The last three builds were not entering "charge mode" (which is a much higher level of charging than the ongoing trickle charging that you get when your iPod is deemed to be  fully charged).

 

Anyway it is fixed now. 

post #802 of 3087

Is there any risk of over-charging an ipod? which is definitely what I wish to aviod.

post #803 of 3087
Quote:
Originally Posted by tupac0306 View Post

Is there any risk of over-charging an ipod? which is definitely what I wish to aviod.

 

In fact, there is. The strange thing about the "charge mode" on the Classic Rockbox is that the percentage that is displayed during charge mode is way too low. When the Classic has 80%+ remaining battery, the charging percentage shows 40%+. This is why I added the "c: switch to the charging percentage in my theme's WPS file, i.e. to remind me that the percentage indicator is wrong during charging.

 

Quote:
%ac%bc%bl%%

 

 (%bc displays the "c" during charging mode)

 

When the percentage hits 69% during charge mode, this seems to equal an actual 100% charge. At this point I normally disconnect my iPod from power since the iPod is still (erroneously) in charge mode. The good news is that this time, I left it plugged in and at some point it seems to have jumped from 69% to 100% and entered "Fully charged" mode. "Full charged" mode is fine. That just trickle charges.

 

Anyway I will monitor over the coming days to see whether this can be relied upon.

 

aroldan, here is an extreme challenge: Can you fix this incorrect charging in the Classic Rockbox release? It may not be possible until they update the Rockbox firmware to correct this error but you will be my hero if you can do it.  :-)

 

Edit: I do still think that using "charge mode" is important. If there is only trickle charging, the battery never gets properly topped up.

 

Edit 2: Now we know why this is still not considered a stable release. Lots of bugs but lots of fun.  ;-)


Edited by cooperpwc - 5/12/12 at 9:28am
post #804 of 3087
Quote:
Originally Posted by cooperpwc View Post

When the percentage hits 69% during charge mode, this seems to equal an actual 100% charge. […] I left it plugged in and at some point it seems to have jumped from 69% to 100% and entered "Fully charged" mode.

That's not what I see with my iPod. Any chance you have an after-market battery?
post #805 of 3087

I still can't get my computer to recognize this damn thing.  How the hell do I get the original Apple firmware back on?

post #806 of 3087
Quote:
Originally Posted by skamp View Post

That's not what I see with my iPod. Any chance you have an after-market battery?

 

Interesting. No, I bought my Classic at the Apple Store in Toronto and it has the original battery.

 

So maybe the inaccurate percentage display is just my Classic. There was no issue with the OF. It's only in Rockbox when in Charge Mode.

post #807 of 3087
Quote:
Originally Posted by Addonexus View Post

I still can't get my computer to recognize this damn thing.  How the hell do I get the original Apple firmware back on?

 

http://www.freemyipod.org/wiki/EmCORE_Uninstallation

post #808 of 3087
Quote:
Originally Posted by Addonexus View Post

I still can't get my computer to recognize this damn thing.  How the hell do I get the original Apple firmware back on?

 

I've found the most important part of getting the rockboxed classic to connect to PC is to make sure disk access has stopped on the iPod before you plug it in.
just hold the iPod up to your ear - you can hear if the drive is still spinning. once its stopped - plug it in.

post #809 of 3087
Quote:
Originally Posted by skamp View Post

That's not what I see with my iPod. Any chance you have an after-market battery?

Correction, I'm seeing the same thing now (with rockbox-ipod6g-efab9e8M-120511.zip). It took a while to get to 69%, then it jumped to 100% while I wasn't looking.
post #810 of 3087
Quote:
Originally Posted by skamp View Post


Correction, I'm seeing the same thing now (with rockbox-ipod6g-efab9e8M-120511.zip). It took a while to get to 69%, then it jumped to 100% while I wasn't looking.

 

Thanks. So I'm not crazy. Well, at least not in relation to Rockbox.  ;-)

 

It is strange behaviour. However if it consistently jumps from 69% to 100% and then enters Fully Charged mode, I think that it is okay. I will keep monitoring this.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › Ipod classic - rockbox - its happening.