Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › Ipod classic - rockbox - its happening.
New Posts  All Forums:Forum Nav:

Ipod classic - rockbox - its happening. - Page 185

post #2761 of 3138

Sorry, your PC operating system is not supported. Please get access to either a Windows (XP or newer) or Linux computer to install emCORE.

http://freemyipod.org/wiki/EmCORE_Installation/iPodClassic/PrepareDFU

 

And as far as I know some Macs have difficulties recognizing a Rockboxed Classic on USB, perhaps because it is still being approached as a normal iPod instead of a mass storage device.

But I could be wrong here, there are not so many OSX users in this topic. I'm still curious if something like Wine would work here..

 

The latest daily Rockbox (f580714) is still working fine. However, there is a bug: after connecting through USB to a pc, it will always spin up the disk when you press any key, making it relatively slow and unresponsive. Rebooting solves this everytime, first boot after connecting USB there's always the message "scanning disk", after that it's fine until the next time you connect through USB ;-)

post #2762 of 3138
I have seen alot of people asking if emCore is supported by mac osx and i havent seen anything about it......i would think someone out of all the people that have ask about it hear that one of them would have reported back with good news about being able to install......from what i have seen on here transfering music via a mac is kinda hit or miss
post #2763 of 3138

I have been following this thread for a long time and I use OSX on a regular basis as well as Linux and Windows.  I have done a lot of testing and just like others have reported, my 160GB Classic works under OSX right after installing Rockbox, but once I update to any level other than what is recommended at the beginning of this thread, it no longer connects under OSX or Windows.  If I boot into failsafe mode, that works sometimes, but is not stable when transferring music.  And once I update a second time, that failsafe image no longer works either.

 

What has consistently worked for me is connecting through Linux.  I have a Macbook Pro (Retina) model and I dual boot between OSX Mountain Lion and Linux Mint. I can't see my iPod when booted up in OSX, but it works just fine when booted up in Linux Mint, so it appears to be driver related and nothing to do with the hardware.  Currently I am running emcore r880 and f580714-131009, but the symptoms were the same on previous versions of emcore and Rockbox.

 

Hope this helps some of you.

 

 

--Paul

post #2764 of 3138
Quote:
Originally Posted by superstar19 View Post
 
Quote:
Originally Posted by vinay View Post
 

I did rockbox around few months back with old version of it.. Since it was working i just never bothered to change it.. though i do get the annoying problem of getting it connected to a PC.. it just does not appear as a disk.. anyone has a idea on that?

 

 

 


I have a 160gb ipod that has issues getting connected to my PC. My PC is rather old (P4 running XP). Haven't had the opportunity to try it on a modern machine, but my music library is all on the XP PC. I used to be able to get it to connect in 2 or fewer tries, but recently it hasn't connected no matter what I do.

 

 

Quote:
Originally Posted by starfly View Post
 

 

I dunno if this'll work for you, but what might help is if you plug it in while the iPod is turned off and then turn on the iPod while it's still plugged in.

 

 

Quote:
Originally Posted by ThurstonX View Post
 

I've found that if the iPod is not recognized within a couple minutes of plugging it in (to a Win7 laptop), I use the Menu + Select reboot function, after which it's detected. That reboot while plugged in has never failed me. I also tell Windoze not to "sacn and fix" the iPod, which it usually asks to do.

 

Sorry guys.. got busy at work.. The above never worked but as i mentioned i was using an old emcore and build.. I just updated the emcore to 880 and it working fine.. hope this helps you superstar19 ...

post #2765 of 3138

does anyone know if you can use rockbox with Fedora(linux)??

post #2766 of 3138
Quote:
Originally Posted by mwoolweaver View Post
 

does anyone know if you can use rockbox with Fedora(linux)??

 

Yes, you can use it to install emcore and rockbox on the classic:

http://freemyipod.org/wiki/EmCORE_Installation/iPodClassic/PrepareDFU

 

After that it should display as a mass storage device in Fedora.

post #2767 of 3138

i was able to install rockbox on the 7g ipod classic (160g) on OSX ML...well technically via a virtual machine on linux(parallels, running Ubuntu)

 

summarizing the steps:

 

1.) follow the emcore installation for linux

* it takes a long time for ubuntu to process some terminal commands. dev/sdb for example doesnt appear after a few minutes and mounting takes longer than 10 minutes. Just when i thought nothing would happen the volume mounted and i was able to complete the process.

2.) Loading rockbox

* follow the steps in emcore page and use ubuntu whenever you want to push a new daily build

3.) Loading Music (on osx)

* Use the fallback image of rockbox. I experienced that this image is the only one that mounts successfully on OSX. After loading music , reboot your rockbox ipod to your current version.

 

 

I tried many builds and not one could mount to osx. But i can't complain about the fallback image working since it was not a complicated step. as long as im able to load flac on osx im happy

 

hope this helps

post #2768 of 3138

have 2 ipods, a 5.5.80gb which rockboxed fine, all the settings work as expected,

 

i then rockboxed my 6g 160gb ipod, i used emcore r859 and the latest rockbox build 25/10/13 78c060b - this works as expected apart from the settings for  volume (which has no effect), the treble and bass - which have no effect apart from at the highest setting reduce the volume and the balance setting which has no effect.

 

Is there a more suitable build revision of rockbox for the 6g 160gb ipod.

 

Also i cannot find the setting to avoid the intiail emcoere screen and boot directly into rockbox??

 

Any help appredciated

 

d

post #2769 of 3138
Quote:
Originally Posted by magicalmouse View Post
 

have 2 ipods, a 5.5.80gb which rockboxed fine, all the settings work as expected,

 

i then rockboxed my 6g 160gb ipod, i used emcore r859 and the latest rockbox build 25/10/13 78c060b - this works as expected apart from the settings for  volume (which has no effect), the treble and bass - which have no effect apart from at the highest setting reduce the volume and the balance setting which has no effect.

 

Is there a more suitable build revision of rockbox for the 6g 160gb ipod.

 

Also i cannot find the setting to avoid the intiail emcoere screen and boot directly into rockbox??

 

Any help appredciated

 

d

i have the f580714-131009 build of rockbox with emCore r880 installed everything work great but some combinations don't work great together you might try updating emCome to verson r880 from here http://www.freemyipod.org/wiki/EmCORE_Installation/iPodClassic/PrepareDFU

 

 

edit: corrected rockbox version


Edited by mwoolweaver - 10/27/13 at 7:05pm
post #2770 of 3138

The latest build (27111d8) fixes the constant disk spinning up after a USB connection. What I would still like to see is the disk turning off as soon as possible after booting, so that the value 'Disk Spindown' in the Settings only applies to USB connectivity. But these are very small imperfections ;)


Edited by r100 - 10/29/13 at 5:19am
post #2771 of 3138
Quote:
Originally Posted by vinay View Post

 

 

 

 

 

Sorry guys.. got busy at work.. The above never worked but as i mentioned i was using an old emcore and build.. I just updated the emcore to 880 and it working fine.. hope this helps you superstar19 ...

 



Thanks. I may have to try it again. I have a new computer now, but I have everything functioning fine with iTunes. I'll probably jump back in eventually.
post #2772 of 3138

I rockboxed my ipod classic 160g 7th genaration, through several attempts, its stuck half way at "no partition, connect to usb and fix it" but the installation process did complete after several trials. I copy a music file to my ipod, and it plays, when I tried to shut it down by holding the  play/pause button, its stuck, have no choice I got to reset it by holding the menu and select key together, after that, the same message came back(no partition....). I tried to get into disk mode again but it failed. When I open itunes it asked to restore the device however it stuck again on the screen "do not disconnect" forever. Since then, I cant do anything with it, the ipod will boot till apple logo, when its connected to pc, its again ask "do no disconnect".

 

Both ipod classic device usb and mobile driver appears on windows devices, in My computer, it appears as removable disk, which is empty! When I check with Windods disk management, ipod's status is healthy but the file system is now RAW!

 

Can anyone help before I send it to repairer which they definitely will recommend me to replace the HDD.

TQ>

post #2773 of 3138

I'm waiting for my ipod classic late 2009 that should arrive today.. I've already read about Rockbox and EmCORE install procedures. 
Since I don't have time to read 185 pages of thread I was wondering if someone could give me some advice before rockboxing my ipod. 

 

Thanks 

 

PS: Especially after reading the upper post :eek:


Edited by Hellkitchen - 10/31/13 at 5:02am
post #2774 of 3138
Quote:
Originally Posted by MLTKSHHBT View Post
 

I rockboxed my ipod classic 160g 7th genaration, through several attempts, its stuck half way at "no partition, connect to usb and fix it" but the installation process did complete after several trials. I copy a music file to my ipod, and it plays, when I tried to shut it down by holding the  play/pause button, its stuck, have no choice I got to reset it by holding the menu and select key together, after that, the same message came back(no partition....). I tried to get into disk mode again but it failed. When I open itunes it asked to restore the device however it stuck again on the screen "do not disconnect" forever. Since then, I cant do anything with it, the ipod will boot till apple logo, when its connected to pc, its again ask "do no disconnect".

 

Both ipod classic device usb and mobile driver appears on windows devices, in My computer, it appears as removable disk, which is empty! When I check with Windods disk management, ipod's status is healthy but the file system is now RAW!

 

Can anyone help before I send it to repairer which they definitely will recommend me to replace the HDD.

TQ>

 

I suggest the following:

Boot your Classic into EmCore, in the menu choose Tools -> Run UMSboot. Then connect via USB to your PC, and copy r859 to the 64MB-sized drive. Safely remove/eject the device and wait for it to finish installing. You should end up in the EmCore menu again, from there choose Tools -> reformat data partition. This will format the hard drive!

 

After this you can start Rockbox and you should be able to connect via USB. Copy a new daily build (contents of the zip) to the root of your hard drive, replacing all possible existing files. Again safely remove/eject the device and when prompted choose to reboot. Now you should have Rockbox running stable on your Classic. If it doesn't, let us know.

 

Quote:
Originally Posted by Hellkitchen View Post
 

I'm waiting for my ipod classic late 2009 that should arrive today.. I've already read about Rockbox and EmCORE install procedures. 
Since I don't have time to read 185 pages of thread I was wondering if someone could give me some advice before rockboxing my ipod. 

 

Thanks 

 

PS: Especially after reading the upper post :eek:

 

The information in the first post of this topic should be sufficient. If you run into a specific problem there is usually someone here who can help you.

post #2775 of 3138
Thanks for reply. I must admit that I'm quite impressed about ipod classic SQ. I've decided to give him a try with original Apple's firmware.. I really like itunes library management and features like genius.
Maybe I say so because I've never try RockBox on any Apple's device...

Will be the SQ so much improved over original firmware?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › Ipod classic - rockbox - its happening.