Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › Ipod classic - rockbox - its happening.
New Posts  All Forums:Forum Nav:

Ipod classic - rockbox - its happening. - Page 170

post #2536 of 3113
post #2537 of 3113

does ipod classic have usb class 2 audio driver built-in?

post #2538 of 3113

@Lifted Andreas:

 

So on original firmware and in EmCore it works? Then it must be something with Rockbox. Maybe this patch also applies to SD-card adapter in your iPod. Sorry, don't have any experience myself with these adapters..

post #2539 of 3113
Quote:
Originally Posted by jasonxff View Post

does ipod classic have usb class 2 audio driver built-in?

Does anyone have an answer to my questions?

post #2540 of 3113
Quote:
Originally Posted by r100 View Post

@Lifted Andreas:

So on original firmware and in EmCore it works? Then it must be something with Rockbox. Maybe this patch also applies to SD-card adapter in your iPod. Sorry, don't have any experience myself with these adapters..

Well, emCore works but Rockbox won't boot.

I just bought a faulty iPod 5th gen 30gb on ebay so I'm gonna be Rockbox'ed again soon!
Edited by Lifted Andreas - 7/6/13 at 12:39pm
post #2541 of 3113

Which is your harddisk is already dead...

I have dead 2 harddisk after rockbox on Classic.

 

now i change to a SD card with SD to CF adpter, but seems is buggy when Rockbox on CF card.

 

If you do a reset or format on emCore, it will get a Kernel Panic when boot

post #2542 of 3113
Rockbox is messed up still, plays for a few mins then iPod switches off. I was gonna replace the logic board but it doesn't happen with stock Apple firmware.

So it's definitely a Rockbox / CF-SD adapter compatibility issue.
post #2543 of 3113

Can someone please teach me how to display chinese characters during Now Playing? I did use Mp3tag to edit all my music files...

post #2544 of 3113

OK, so I took the plunge and installed emCORE r568 and Aroldan's 130217 build of Rockbox.  The install went successfully, and I uninstalled iTunes (I've been using MusicBee as my main player anyways), but when I tried to plug in the iPod after I took it out to verify the Rockbox install, in order, to install fonts, themes, and get a database started, the computer recognizes "Rockbox media player" as a device, but it says that some drivers aren't being successfully installed and I can't access it as a hard drvie.  Does anyone have any idea of what's going on, or even better, a solution?

post #2545 of 3113
Hey guys. Earlier my Rockbox ipod was bugging out and being super slow. I deleted all album artwork and that helped somewhat. Then I deleted the database and reinitialized it and now it's working like normal. Just thought I'd report in. 7c31ff2 120806 with emcore.0.2.3
post #2546 of 3113

emCORE r568?  If thats what you installed then thats your problem right there.

post #2547 of 3113
Quote:
Originally Posted by 808Ronin View Post

emCORE r568?  If thats what you installed then thats your problem right there.

 

That isn't exactly right, because I damn well know that there have been others that had no problems with r568.

 

Relatedly, an update: so a bit after my last post, I decided to switch to the 7/11/13 daily build, add in the desired patches, and put in my music.  This was after I did a reformat, and I added it all before I ejected the Rockboxed iPod Classic.  Now, I've decided to try again, and when I check in Device Manager, the device "rockbox media player" ends up being issued a code 10 i(once, I think after restarting the computer while keeping the iPod in, I received a code 28) n regards to its driver.  I've done the reformat and info addition several times, and it's the same thing.  Does anyone have any suspicions as to why this is?

post #2548 of 3113
I guess I should be on a different version? Only problems I've had regularly are getting windows to recognize the ipod right away. Gt any build suggestions?
post #2549 of 3113
Quote:
Originally Posted by shrimants View Post

I guess I should be on a different version? Only problems I've had regularly are getting windows to recognize the ipod right away. Gt any build suggestions?

 

Quote:
Originally Posted by cooperpwc View Post

 

Here. (Aroldan 1208020)

 

(I am really not sure that it is the best, only that it works perfectly for me.)

 

(Edit: It specifically works perfectly with the official r859 release of EMcore.)

 

If you reformat your iPod Classic then start from scratch with the version of Emcore immediately above followed by the Aroldan 120802 version of Rockbox also above, you should have no problems.

post #2550 of 3113

One more point: always wait for the hard drive on the iPod Classic to stop spinning before plugging it into your computer. Rockbox must be fully loaded.

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Portable Source Gear
Head-Fi.org › Forums › Equipment Forums › Portable Source Gear › Ipod classic - rockbox - its happening.