Head-Fi.org › Forums › Equipment Forums › Dedicated Source Components › Yulong D100 DAC - static problem
New Posts  All Forums:Forum Nav:

Yulong D100 DAC - static problem - Page 2

post #16 of 44
lol... no wonder audiophilechina or the Yulong makers aren't replying to my emails about my unit being dead. probably too busy replying to emails from all of you guys biggrin.gif

Oh well, on the bright side, I never had the problem described with either of my laptops and my D100 before it died...

>is that the self-powered USB port lessens the work-load of the CPU which has to power the USB port on the PC itself

nooo, just no.


>I could always add more RAM to my PC too..

also very doubtful if you have anything over 2gb, and not too many apps running.


For any pc, get the latest drivers for everything (stable ones, provided no evidence on forums of stable ones being defective with regards to DPC latency, and beta ones fixing it) and the latest bios update. For crackling - If you have a laptop - disable all the power saving features (for pc/windows - in power settings set to high performance mode, in the bios - set the cpu to disable speed stepping), search for the laptop model and DPC spike issues and follow the instructions in the thread (generally involves disabling devices potentially causing it. E.g. on my old laptop crackling went away after disabling acpi devices - battery and adapter (probably just coincided with that disabling all the power saving fluff the easy/sure way))
Edited by svyr - 3/2/11 at 5:14am
post #17 of 44

Cheers - that is really helpful  - I am already one the road to disabling power savers..but I will also run into BIOS and see what I can do...cheers!

post #18 of 44

Just got this problem today out of my 2 week old unit. Strangely, it happened out of the blue while nothing was being played out of them. I noticed the sampling rate somehow jumped to 96khz. I pulled my headphones out and tried plugging them back in and heard a high pitched hum. Turning it off and on again, changing my laptop out of power saver mode, I haven't heard anymore static.

post #19 of 44

I consider myself thankful mine has been reliable as it has redface.gif. I had a roughly one week period where I would have that static problem maybe every other day (maybe slightly more often), but I have been perfect since then. Has Yulong commented on what might be the cause?

post #20 of 44

Not that I know of - but so far - I am of the belief that it is the operating system in conjunction with the USB port that is causing the issues - not the YULONG itself...I wish it were as simple as regular audio - plug in and play - but with PC audio there is lots of tweaking to do...

 

Seriously - I'm learning alot about how PCs work...

 

 

post #21 of 44
Quote:
Originally Posted by svyr View Post

lol... no wonder audiophilechina or the Yulong makers aren't replying to my emails about my unit being dead. probably too busy replying to emails from all of you guys biggrin.gif

Oh well, on the bright side, I never had the problem described with either of my laptops and my D100 before it died...

>is that the self-powered USB port lessens the work-load of the CPU which has to power the USB port on the PC itself

nooo, just no.


>I could always add more RAM to my PC too..

also very doubtful if you have anything over 2gb, and not too many apps running.


For any pc, get the latest drivers for everything (stable ones, provided no evidence on forums of stable ones being defective with regards to DPC latency, and beta ones fixing it) and the latest bios update. For crackling - If you have a laptop - disable all the power saving features (for pc/windows - in power settings set to high performance mode, in the bios - set the cpu to disable speed stepping), search for the laptop model and DPC spike issues and follow the instructions in the thread (generally involves disabling devices potentially causing it. E.g. on my old laptop crackling went away after disabling acpi devices - battery and adapter (probably just coincided with that disabling all the power saving fluff the easy/sure way))


 

I've disabled speed stepping and also the graphics card power-saving functions - I'll retest the audio in this weekend! Let you know it fares...

post #22 of 44
Quote:
THanks for your help on the thread about the D100 -



Just a question - is there anyway of adjusting setting in BIOS so that I give priority to that USB connection (to the D100) or in fact - where can I set the speeds to the USB ports to max??



I'm not knowledgeable with PC audio - more of a hifi man myself - but since I got the D100 - I'm trying to get the best performance...



Cheers!

H


If you're using windows you can also set the cpu scheduling to favour background services (includes audio, I think)
ZC
(this is in sysdm.cpl - (System properties in control panel)->Performance->advanced)
Edited by svyr - 3/4/11 at 6:54am
post #23 of 44

Awesome - thanks!!

post #24 of 44

 

Well - afraid to say - still have the glitching - after about 12 minutes....Next stop - finding all those programs that don;t need to load up on the start menu - 

 

Do you recommend i still play with buffer latency settings? And ought I to still upsample or simply playback at the original sample rate?? 

 

I could buy the self-powered USB and then plug in most the USB plug ins that are currently plugged into my PC - like my wireless mouse etc...

 

Could it be Internet Security absorbing power etc...

post #25 of 44
Using xperf is probably your best bet, but it's a bit complicated. First verify that you still get DPC spikes (and try turning your wireless off biggrin.gif ) then if you still do, follow the instructions here: http://www.scottmetoyer.com/archives/my-solution-for-dell-xps-m1530-dpc-latency (xperf lets you pinpoint where the DPC latency issues occur. I used it on my old crappy dell with much success)
Edited by svyr - 3/5/11 at 2:59pm
post #26 of 44

 

Test 1 - 

 

Internet totally switched off - at 400ms - Much better playback - no glitching until over 25 minutes.

 

Test 2 - 

 

Internet totally switched off - at 1000ms - Glitching after 20 minutes.

 

So the latency settings on itunes are not related...

 

At least I know the Internet and Norton Internet is sucking some of juice of my CPU 

Should I download the Latency DPC Latency checker to see where the spikes are coming from? Please remember I am using XP - not Windows 7 and the link you sent me was regarding XP..

 

BTW - Tks for your ongoing help.

 

Hervie

post #27 of 44

I used to use DPC Latency Checker until I found this program http://www.resplendence.com/latencymon . It's easier and faster to spot the culprit that cause DPC latency with this program. You can read the instructions there.

post #28 of 44

TKs put that program doesn't support XP

post #29 of 44
DPC latency checker just shows whether there are spikes (yellow or red ones = bad). xperf profiles all the running processes, services and drivers and lets you know the DPC time spent in each.


>>Test 1 - Test 2 -

so you can see the spikes on the DPC checker graph? If so, the article above is still applicable,
https://www.microsoft.com/downloads/en/details.aspx?FamilyID=6b6c21d2-2006-4afa-9702-529fa782d63b Windows 7 SDK that contains xpref (look at the system requirements, it lists windows xp under supported OS)... Having said that, it might not support the necessary features for the tracing on winxp, but just install and try it.


>At least I know the Internet and Norton Internet is sucking some of juice of my CPU

Generally, it shouldn't be a problem. Are you sure, or assuming?



>http://www.resplendence.com/latencymon

very nice, thanks
Edited by svyr - 3/5/11 at 7:57pm
post #30 of 44

I am assuming that - because when I turned off the Internet completely - the playback lasted longer without clicks...

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Dedicated Source Components
Head-Fi.org › Forums › Equipment Forums › Dedicated Source Components › Yulong D100 DAC - static problem