New Posts  All Forums:Forum Nav:

My Apologies. Please read. - Page 3  

post #31 of 123

just wanted to state I got all my items and everything was resolved, thanks Craig/Whiplash!

post #32 of 123

Just an update that I have finally received my twag cable.

And a little surprised by the wrist band, thanks craig, whiplash. :)

post #33 of 123

wristband? i suppose it cold be a wristband but isnt it a band for audio stuff? like dap and amp? think you must made a new fashion statement! lol

 

craig, hope to hear from you soon!

post #34 of 123
Quote:
Originally Posted by debitsohn View Post

wristband? i suppose it cold be a wristband but isnt it a band for audio stuff? like dap and amp? think you must made a new fashion statement! lol

 

craig, hope to hear from you soon!


It all depends on how you view it friend.. :)

To me, its function as a wrist band came first, before people use it as a band for your portable rigs.

 

 

Wow.. after a month + of being deprived from my twag and living on stock cables.. switching back to twag, not to mention twag v2 made a dramatic improvement man ! :D
Can't wait for this gem to be burned in ! :)
Once again, thanks craig and cryopart for this awesome cable.. :)

 


Edited by Junliang - 3/25/11 at 8:11am
post #35 of 123

lol and yes about his cables and stuff. very very impressive :)

 

now i need a wristband!

post #36 of 123
Quote:
Originally Posted by Junliang View Post

 

Wow.. after a month + of being deprived from my twag and living on stock cables.. 

 


I understand exactly what you mean, Junliang.  My Twag V2 has a acquired short in the left connector to the earpiece (JH13) and I had to revert back to stock cables.  Oh dear, what a difference.   Where's that clarity, openness and transparency of the Twag?   Sibilence is back as is top and bottom roll off.  I am almost loathe to pick up my JH13s!   Talk about a forced comparison!  Makes me so grateful for Craig's quality products.

 

I emailed Craig and asked him when he would be good and ready to get the V2 back for repair.   I'd hate to send the cable when he's so busy.

post #37 of 123

received my cable and as always great product.... always makes the wait worth it!  Craig, another great cable!  Now I wish I waited for the "eclipse" black twag version.... excited to see how it looks

post #38 of 123
Quote:
Originally Posted by TekeRugburn View Post

received my cable and as always great product.... always makes the wait worth it!  Craig, another great cable!  Now I wish I waited for the "eclipse" black twag version.... excited to see how it looks



Lucky you! I've been waiting over three months now for a TWag v2 IEM cable (ordered 20/12/2010). Every 2 weeks I send off an email to Craig, and for the most part he responds promptly and is very apologetic. But still nothing arrives in the mail... :(

Anyway, still haven't lost hope yet.

post #39 of 123

Craig-    I left you a PM and an email.  My TWag arrived but it is not what I ordered.  Please let me know how to exchange for the correct cable.  It is torture staring at it in the package.


 

 

 

 

 

post #40 of 123
Quote:
Originally Posted by zeffa View Post





Lucky you! I've been waiting over three months now for a TWag v2 IEM cable (ordered 20/12/2010). Every 2 weeks I send off an email to Craig, and for the most part he responds promptly and is very apologetic. But still nothing arrives in the mail... :(

Anyway, still haven't lost hope yet.



Send and email to custserv@whiplashaudio.com with your name and what you ordered. There were a few orders for IEM cables placed on that day and according to my records they all shipped. There may have been a problem with shipping, I believe that is around the time we started switching over to UPS to handle all of our shipping.

 

Thanks,

Mike.

post #41 of 123
Quote:
Originally Posted by Likwid View Post

Send and email to custserv@whiplashaudio.com with your name and what you ordered. There were a few orders for IEM cables placed on that day and according to my records they all shipped. There may have been a problem with shipping, I believe that is around the time we started switching over to UPS to handle all of our shipping.

 

Thanks,

Mike.


Thanks Mike, I suspect you are right about the shipping problem. I've sent you an email.

 

post #42 of 123

Dear Craig,

I had received from you via pm that my twag cable for HD650 with balanced connector will be shipped out. Till today, I have yet to receive the cables. Please check. This is my 1st time ordering from Whiplash and yet I am very disappointed with the service. Very sad :(

post #43 of 123

hey craig just wondering any ETA on twag cable i sent to be re done with HD800 connectors and termination changed, to via blue mini. I sent on 4/1, hope to talk to you soon! I am gonna get an RCA cable from you too

post #44 of 123
Just asking anyone contacted craig through email recently ? Been emailing him since 2 weeks but no reply at all. Ordered the twag 3 weeks ago. But no update ever since. Getting impatient already.
post #45 of 123

Hey guys,

 

We are getting through everything as quickly as we can and Craig has been trying to be as responsive as he can lately. We have a bunch of different things going on here, and some good news that we have been hearing is making things even more crazy! I promise we are working to get everything out as quickly as possible for everyone!

 

Thanks,

Mike.

New Posts  All Forums:Forum Nav:
  Return Home
This thread is locked