Head-Fi.org › Forums › Equipment Forums › Headphones (full-size) › Ultrasone Pro 900 Cable Problem (extremely frustrated)
New Posts  All Forums:Forum Nav:

Ultrasone Pro 900 Cable Problem (extremely frustrated)

post #1 of 7
Thread Starter 

Okay, so today I just got my brand new Ultrasone Pro 900s. They are absolutely fantastic. I had a great time listening to Emperor's Prometheus in the family room and am really glad I bought them. HOWEVER, later on in the evening I was trying to plug the cable into the headphones again but with no success. I realize it is a screw-in but it just won't "catch" or something. I cannot get it in properly. I have heard of similar issues before but cannot find a thread on it.

 

Anyone able to help me out here? I am seriously frustrated (and made a great effort at not swearing in this thread!).

post #2 of 7

Hold the headphones with one hand, while inserting the cable & applying slight upward pressure into the earcup with the other hand, as you turn one or the other until the thread catches. Keep turning/screwing in the cable until it won't go any more.

 

No need to apply undue force, but a firm hand is required.

post #3 of 7

brute force fixes everything, they are a very sturdy headphone so you aren't going to break them by applying excessive force in order to get the cable to screw in. 

post #4 of 7
Thread Starter 

Wow. Jeez, thanks guys. I really appreciate it. I was terrified of breaking them earlier and I just gave it some "man" and it worked just fine. I heard a small click, actually. Thank you very much for the help!!

post #5 of 7
Quote:
Originally Posted by Sonic Atrocity View Post

Wow. Jeez, thanks guys. I really appreciate it. I was terrified of breaking them earlier and I just gave it some "man" and it worked just fine. I heard a small click, actually. Thank you very much for the help!!


Hahaha I had the same issue when I first got them. Was afraid I would break them but just had to give it a good push. Glad you got it going.

 

Edit: Hooray for bumping old posts >.>

post #6 of 7
Thread Starter 

Hurray for responding to extremely old threads while stoned. :)

post #7 of 7
Quote:
Originally Posted by Sonic Atrocity View Post

Hurray for responding to extremely old threads while stoned. :)



hey, i was wondering if aftermarket cables will fit into the pro 900's?, if so, wt kind of cables do i need to look for?...

i know some1 selling them w/o the cables hence the silly questioning :P

 

peace!!!

New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Headphones (full-size)
Head-Fi.org › Forums › Equipment Forums › Headphones (full-size) › Ultrasone Pro 900 Cable Problem (extremely frustrated)